• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

[Fixed] Captions burning into video even when not selected to

Explorer ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

When I export a video ( h.264 ) I am selecting to create a sidecar file ( SRT ) on the captions tab , when I export, it does create the SRT file, but it also burns the closed captions into the video. When I select NONE for Caption Export options when exporting, it is still burning the closed captions into the MP4 file.

This is happening on all 23 sequences inside my project file. The only way I can get the captions to not burn in, is to turn off the eyeball on the Subtitle track. Which then requires me to re-render the entire timeline.

This is using Premiere v15.4.1 build 6 . Any thoughts ?

 

TOPICS
Error or problem , Export

Views

10.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Explorer , Oct 28, 2021 Oct 28, 2021

Had time to start a new small project , using some of the same footage and audio. Captions are exporting as they are supposed to.

The only thing I can think of is I use a master project with all  my folders, sequences, etc already created so I have a common start point, something in the project must be "off". I am going to create a new master project "template" and go forth with that.

 

Votes

Translate

Translate
Explorer , May 18, 2022 May 18, 2022

Hi again, I updated to Premiere v22.4 and it seems to have resolved. Thanks for your assistance.

Votes

Translate

Translate
Participant , May 16, 2024 May 16, 2024

Hello Folks,
Any permanent solution to this issue? I just ran into this issue on Pr 24.3 (Build 59) as of May 16, 2024. Using MacStudio 2023 macOS Ventura 13.5. I even tried deleting cache to no avail. The only workaround I figured out is to turn off caption track, export the video; then turn on the caption track and export as a SRT file from the captions panel. Not very helpful if I have longer videos. Any other guidance to solve this issue once and for all would be most appreciated.

Votes

Translate

Translate

correct answers 1 Pinned Reply

Adobe Employee , Mar 07, 2024 Mar 07, 2024

Hi Community,

This bug has been marked as fixed in Premiere Pro 22.1 and later. If this fix is still not working for you, please let us know.

 

Thanks,
Kevin

Votes

Translate

Translate
Participant ,
Dec 13, 2022 Dec 13, 2022

Copy link to clipboard

Copied

This has come back with 23.1. I have a brand new project that I imported the sequences into and now there is no way to get the video to export without the captions being burned into the video without disabling the caption track.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 13, 2022 Dec 13, 2022

Copy link to clipboard

Copied

ghuff,

 

I'd love to replicate this if there is a continuing issue. But so far, I cannot replicate in 23.1 on Win10. I am seeing the same behaviors that I reported above for 23.0.

https://community.adobe.com/t5/premiere-pro-discussions/captions-burning-into-video-even-when-not-se...

 

The primary symptom is that captions are burned into an export even though "None" is selected. In one variation, this would only happen if a sidecar file had been exported first.

 

How does your process differ from this description of my tests:

 

If a caption track in the sequence is disabled in the caption track header (eyeball), it results in the Caption button being disabled in the Export settings -  you can't burn in or export sidecar, and no captions show in a) the Program Monitor, b) the Export preview window, and c) the exported file.

 

If the caption track is still enabled in the sequence, it shows in the Program Monitor. If the Caption button is enabled in the Export settings and is set to burn in, the captions show in the export preview window and in the exported file. If the export settings are set to sidecar, the captions DO NOT show in the export preview window, and are not burned into the exported file. There is a sidecar file exported, and some players (VLC is the one I was using) may automatically detect the file and play the subtitles. If you disable subtitles, they do not show.

 

If the export caption settings are None, the captions DO NOT show in the export preview window, and are not burned into the exported file. If the name of the file is the same as a previous export of a sidecar file, then some players (VLC is the one I was using) may automatically detect the file and play the subtitles as if they are burned in.

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 14, 2022 Dec 14, 2022

Copy link to clipboard

Copied

This is on macOS Monterray and Ventura. Two different iMacs. In order not to have the captions burned into the video, I have to disable the captions track.

 

I am using macOS Preview to see the file. It does not automatically load the captions from the SRT, and when I disable the captions, it does not show up on the video even though an SRT is in the same folder.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

Thanks Stan,

I created a new project and it started working again. Kind of a pain but not the end of the world. One thing though, when I open the Captions workspace every grinds to a halt. If I want to edit one word on one caption it literally takes one minute for the change to appear on preview. I'm going to try on a new computer later on today and see if that's the problem.Some specs for the problem child in the meantime:

 

Windows 10 v21H1

OS Build 19043.1237

Processor Intel(R) Xeon(R) CPU E5-2680 v4 @ 2.40GHz 2.40 GHz

 

Looks like it hasn't had an update since last July. I'll also try that and see if that fixes things.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

I updated the system software I'm now on 

OS Build 19043.1466

 

Still have the same problem. I switch to sidecar file and the captions remain burned in. I can't really render the timeline because I'm used linked comps with AE and it would have to render the whole thing (it's almost an hour long). 

 

I have deleted Media Cache to no avail. 

 

There is, however, an NVIDIA driver that needs updating apparently. I'll try that next. In the meantime, I'm good to go with the new project. If that one starts acting funky I'll post an update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Hi all,

It seems as if this works fine if I do not link my footage to After Effects (right click on clip, select Replace With After Effects Composition). I have a bunch of zoom presentations to edit and I was using AE to align everything. I have abandoned that because it takes much longer to export and as a result it looks like I can export from Premier with a sidecar file and it is not burned into the video. 

 

Hope that helps someone else.

 

Andy

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2024 Mar 07, 2024

Copy link to clipboard

Copied

I know it is a pain in the... Until we solve this problem (2024 still), I deactivate the toggle caption track on my timeline. Previously, I save the cc as srt file and I add it after uploading the video and it works fine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

This is exactly what happened to me. I transcribe and then create captions. I like to upload to YouTube using the SRT file so I can edit it or tranlate it later. But today, the captions won't turn off even when I hide them. Yesterday and previously, it worked great. Now it does not work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

valerie,

 

What specific version of PR are you running? Never had this problem before?

 

Any Windows etc updates? Any other changes in your system/the project you can think of?

 

Stan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

No changes. I'm using the most recent update. The caption function was working normally as of two days ago. I'm a busy YouTuber with several channels. I edit about 5 videos a week. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

That is very odd. I'd reset preferences, clear the cache, create a new test project, and see what happens there.

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

I am having the same problem. h.264 render burns in captions rather than creating sidecar.

 

New project it does not happen, but over time, somehow the problem rearises within the project. Unclear when/where the bug kicks in.

 

My current workaround is to render twice. Once to get the sidecar (which is also created along with the captions burning into the video). And render once with the eyeball for captions turned off.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

I have the same problem.

Premiere v22.3.0 build 121

Mac OS Monterey 12.3.1

Exporting through Premiere's new-ish export interface, not media encoder.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Premiere Pro 22.5.0 build 62
MacOS Montery 12.5

 

I'm also having the same issue. I discovered that you can export the .SRT file from the captions tab in the text panel; so I don't have to export the video once just to get the .SRT file. But I still have to toggle OFF the captions layer after exporting the .SRT before I can export the video without burned-in captions.
This is marked as solved but its unclear based on reading the whole discussion:
If I create a new project and copy everything into it, will that solve the issue? Or do I have to replace all the linked AE comps?

BTW; based on this discussion, this is clearly a software bug, so its not great to say it is 'solved' just because a workaround is available that may or may not work for some folks...
Something is happening in the caching or rendering mechanism that is breaking the export options; that needs to be fixed..!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Edit: My conclusions here are in error. I totally forgot that, using VLC player as my "test," it is set to play captions from an srt file automatically. So the pattern I discovered was that if I had exported srt, then it would appear that the captions were burned in. If I had not yet exported srt, the captions would not appear - and appear not to be burned in. My new conclusion is that 22.5 (and Beta 22.6 and 23.0) are behaving correctly.

 

Original post: ray, I had not tested this before, and did not see any problem. Your response encouraged me to give it a go. I have confirmed a problem in 22.5. I am confused as to the exact nature of it, however!

 

This is in a new project, with one short video. I created 3 sequences from it, transcribed each, and created captions.

 

Sequence 1. Exported with captions "None," no captions in export. Exported with sdiecar, and I get a sidecar, but the export includes BURNED IN captions. Export with captions "None," no captions in export. 

 

Sequence 2. (Partly wondering, based on this thread, whether the problem will exist for other sequences.) Exported with captions "None," no captions in export. Exported srt from Text Panel (3 dots); sidecar okay. Exported with captions "None," but the export includes BURNED IN captions.

 

Sequence 3. Same steps as sequence 1; same result.

 

This is the type of "inconsistent" result that can result in various beliefs about what fixes it or does not. I would first test duplicating the sequence and exporting a (hopefully) clean file.

 

btw, I have no argument with an answer to a question being marked correct, even if it is simply saying "this is a bug." Solving the underlying bug remains an issue, but the question is answered. And yes, a workaround is a good thing. But it is an extremely unsatisfying answer.

 

I have not tested yet in Beta,but I plan to.

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

Note that I have edited my previous post. My conclusions were in error. 22.5 is behaving correctly.

 

(Posting this in case anyone is only looking at emails.)

 

Stan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

I have the same problem 😞

The captions appear on the exported video even if I selected "None" or "Embed in exported file" in the caption export settings. I tried starting up a new project but no more success. It does the same on Media Encoder as well and I just updated to the more recent software versions (PR: 22.6.2 build 2 / ME: 22.6.1 build 2)

 

Any solution for this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

And even if the caption tracks "eye balls" are off, they still appear on the program monitor 🤨

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

estellej, thanks for the screenshots; very helpful.

 

22.6.2 is behaving correctly for me. Your problem may be different from what is being discussed in this thread. But what you are seeing in odd.

 

The difference is that when other users would turn off the eyeball, the captions would not show in the Program Monitor - even if they then appeared in the export. Yours are showing a) in the Program Monitor with all caption tracks off and b) in the export preview monitor with "None" selected. In the export preview, you should see captions ONLY if "burn in" is selected - not for sidecar, not for embed, and not for burn in IF there are no caption tracks enabled.

 

I believe there were two problems in this thread: 1) there was a bug that was fixed in 22.4. I could never replicate it, so could not test. 2) I incorrectly believed I had replicated the problem some users reported in 22.5. What I believe happened there was that a) it worked correctly until a sidecar file was exported and b) thereafter, the captions appeared to be burned in even though "None" was selected. What was happening was that the player used to test the file (in my case VLC) was always seeing the sidecar file in the directory with the export (that, in fact, did NOT  have captions burned in) and played them.

 

I would check a) that the source file does not already have captions (yes, a long shot) and b) delete all previews/cache files and retry.

 

If that doesn't work, as a test, create a new, simple test project. Add a video and add a couple of captions. Can you turn them off with the eyeball? If yes, can you export without burn in.

 

Stan

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 01, 2022 Dec 01, 2022

Copy link to clipboard

Copied

Just chiming in here to say I am having the same problem. Most sequences export fine, without the captions burned in, some do not. The ones with the sticky captions include imports from the same AE file. The rest do not, so I suspect it's something to do with that.


I'm using v 22.6.2 (Build 2), on Windows 10.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

Hi, are you having the issue in V23?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2022 Dec 03, 2022

Copy link to clipboard

Copied

valerie,

 

Thanks for reporting. Interesting.

 

Do you see the sticky captions in the export preview window?

 

Is this an AE dynamic link clip? Or an exported file from AE that has been imported to PR. It happens every time with such a file? If you bring in a new AE file, does it happen from the very beginning? Or do you get one good export first?

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2023 Jan 04, 2023

Copy link to clipboard

Copied

Experiencing this issue with MXF exports as well. Cannot nail down anything specific between projects that cause it. Trying a cache flush now and an export direct from Pr instead of Me and will advise but this is super frustrating and wasting a lot of time.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 04, 2023 Jan 04, 2023

Copy link to clipboard

Copied

Aflalo,

 

Thanks for reporting. Let us know what you find.

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2023 Mar 22, 2023

Copy link to clipboard

Copied

18 months on, and still an issue?

 

This happened the very first time I tried to use Premiere Pro, and I can't seem to get rid of it.

The only solution is to disable the subtitle track of rendering and export it separately. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines