Major BUG with Frame Hold and Frame Hold Segments for AE MOGRTS brought into Premiere

Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Hey guys just want to bring a major bug to the attention of Adobe Staff  here in Premiere Pro, every instance of bringing in a MOGRT from After effects containing  a precomp I encounter that the 'Frame Hold" and "Insert frame hold segment" feature results in a blank or black frame rather than the desired still frame.

 

Another test using the same MOGRT animation without items within a precomp from After effects r appeared to work but only at the expense of losing 'Time Responsive' capabilities which are crucial to MOGRT workflow.

 

Other examples of imported MOGRT templates the Frame hold features are completely greyed out. total mystery.

 

I know i'm going to be told that I must utilize the Export frame workaround as I have seen this answer to this question answer said repeatedly in these forums in almost 6 years of Premiere Pro updates. But trust me I have a client who has to edit over multiple 3hr episodes with a ton of graphics who cannot afford to spend time doing this hundreds of times manually. And to sacrifice the 'Time Responsive capabilities' for layers from AE in my second example will also completely defeat the purpose of creating or using MOGRTS.

 

This clear bug which has been identified yet hasn't been fixed in nearly six years has unfortunately screwed our whole project pipeline. Many Hours digging through forums and trying work arounds has not given a direct answer to feature which should be working by now. Im basically a sitting duck here.

If any experts here can shed some light here on a solution or some intention in future to finally fix this bug (among many other issues) between AE and Premiere pro MOGRT workflows that would be fantastic

Thank you

Views

159

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

If you think you found a bug please post here:

Premiere Pro: user voice – Adobe video & audio apps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Noted, thanks for the heads up

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

@DaciaSaenz  ... if she's available ... is awesome at this sort of stuff.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Thanks for the heads up, Neil! I appreciate the ping 🙏🏽

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

SI bien es cierto que podria ser un BUG deberias ver en que año fue creado el MOGRPH, hay algunos que de por si traen algunos errores.
epro si crees que es algo constante en todos puedes reportarlo aqui

Premiere Pro: user voice – Adobe video & audio apps

Saludos

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Hi @Jack22956158qyz3 , 

 

Thank you for reporting this issue. I'm not seeing a blank or black frame but I am seeing the wrong frame.

I have confirmed that if a Mogrt has Responsive Time enabled, then the Hold Frame that is created is from frame zero and not the frame at the CTI.  I can reproduce this behavior whether I have PreComps in the Mogrt or not. And I cannot reproduce the issue if the Mogrt I'm using does not have Responsive Time. Responsive Time has to be enabled by creating Protected Regions at the Primary Comp level, fwiw. 

 

Another thing bug I'm seeing when using Add Hold Frame is that whatever is before the cut re-times that part to include the entire duration of the original mogrt from beginning to end. 

I'm getting this filed now and will let y'all know when you can find a fix in Beta or if there is a reason why this behavior cannot be resolved. 

In the meantime, here's a tutorial on how to create controls in your Mogrt with Expressions. This approach gives you way more control over specific elements in your animation than Responsive Time, which can only stretch all elements uniformly over time. 
https://evanabrams.com/control-time-in-templates-adobe-after-effects-tutorial/

Thanks so much for reporting this,

Dacia

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Dacia,

 

Thanks so much for popping in, establishing what was going on, and even giving a good tutorial to see another way of doing this!

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

Thanks for your investigation into this Dacia, unfortunately im still quite stuck and just needed time away from the problem to think of a plan of attack.

 

If I find any other work arounds I'll post them here and share some insight 🙂

 

Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

Just a thought, the ability to manipulate multiple keyframes for separate layers and animate them at once would be a very neat feature to have in Premiere Pro. After effects has had this for a long time.

 

If this were possible, building custom MOGRTS within Premiere Pro with Responsive Design Time and then being able exporting them as Motion Graphics Templates might save a lot of time and potential issues. I'm ball-park guessing the problems occur as a result of  the complexity of After Effects Precomps not playing nicely with Premiere in some situations.

 

Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

My brain just exploded thinking about this situation you're in, Jack. Sorry about this. I think that Evan's tut may hold some keys for you. I hope that is the case. Let us know how it works out.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Cheers for your understanding Kevin, its a definately quite an ordeal. Thanks will do 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

LATEST

Hi @Jack22956158qyz3

 

I spoke with devs and unfortunately this is one of those cases where features collide. The various Hold Frame workflows and the re-timing that makes Responsive Time Mogrts work under the hood were never resolved and not supported. The real bug here is that those options should have been disabled for Responsive Time Mogrts ☹️

Apologies for the inconvenience and I wish I had better news. I hope the Timing Control tutorial from EC Abrams can help though. 

 

Cheers,

Dacia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines