• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Mercury playback engine gpu acceleration greyed out

New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

I have the brand new macbook pro max fully upgraded. My project for some reason recently has just been super laggy. ill open it up & then when i skim through the timeline all of a sudden the playback will freeze. I have all other funcitons in premeire but the playback on the computer wont work. Im trying to see if i can change the Render & Playback settings but its greyed out i cant figure out why. Ive tried opening a new project but its the same thing. 

Screen Shot 2022-03-10 at 12.37.04 AM.png

TOPICS
Error or problem , Freeze or hang , Performance , User interface or workspaces

Views

546

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 09, 2022 Mar 09, 2022

That setting is enabled by default if running Premiere Pro as Apple silicon native.

 

While Premiere Pro is closed, get into on the application in the Finder and enable "Open using Rosetta".  You'll then be able to change that project setting.

Votes

Translate

Translate
Community Expert ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

That setting is enabled by default if running Premiere Pro as Apple silicon native.

 

While Premiere Pro is closed, get into on the application in the Finder and enable "Open using Rosetta".  You'll then be able to change that project setting.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2023 Aug 20, 2023

Copy link to clipboard

Copied

What??? Could you be a little more specific?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 21, 2023 Aug 21, 2023

Copy link to clipboard

Copied

Specifically, when you open Premiere Pro normally, it runs in Apple Silicon native mode by default, and it's renderer is permanently locked into the Metal GPU acceleration mode. You will need to open the Creative Cloud desktop app, then click on the Apps tab, then click on the three dots next to the Premiere Pro line, then click Open in Intel mode. Unfortunately, the only other renderer setting besides Metal that's available is Software Only.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 08, 2024 Jun 08, 2024

Copy link to clipboard

Copied

Hi.

I'm just now having the same issue, and Open Using Rosetta didn't work for me. I've been on Premiere 24.1 for a while without any issues. I restarted my computer the other day and all of a sudden the gpu acceleration is greyed out. I upgraded to 24.4 with no luck. I'm using a 2022 Mac Studio M1 Ultra - OS Ventura. Any ideas for this not so technical minded editor would be much appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 08, 2024 Jun 08, 2024

Copy link to clipboard

Copied

@Erik Hutch 

Version 24.x of Premiere Pro no longer supports running the software using Rosetta.  As such, "Open using Rosetta" is not available.  If running the Intel version of Premiere Pro on an Apple Silicon based Mac is important, users must use 23.x (or earlier if it's already installed).  Importantly, if a workflow relies on an Intel-only feature, it should be adapted to what is supported under Apple Silicon while version 23.x can still be installed.  For example, Mac users with a large library of video that uses GoPro Cineform should transcode that footage to ProRes.  Other known limitations may be reviewed here.

For version 24.x running on Apple Silicon, the Renderer pop-up menu Under File > Project Settings > General > Video Rendering and Playback is grayed out because Mercury Playback Engine GPU Acceleration (Metal) is always enabled even though the dimmed terminology in the application reads " - Recommended".  Hopefully, this will be updated at some point to read " - Always enabled".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 10, 2024 Jun 10, 2024

Copy link to clipboard

Copied

LATEST

Hmmm? I thought I had already posted this . . .

 

Thanks very much for this detailed and helpful explanation Warren.

 

I was able to open PP23 in Rosetta, but it took a while to launch.

 

I may be remembering wrong, but I could've sworn that the GPU Acceleration menu wasn't grayed out on either PP23 & 24 until recently. I've been editing with MXF and all kinds of MP4 files with no lagging issues until now. I've deleted cache files and and trashed preferences. But I'll trust that the GPU Acceleration is enabled even though it's greyed out :p.

 

Thanks again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines