Welcome to Premiere Pro 14.4!

Adobe Employee ,
Sep 15, 2020 Sep 15, 2020

Copy link to clipboard

Copied

New Update.jpgPremiere Pro 14.4 is now available for download from the Creative Cloud desktop app. This update includes new features, several bug fixes, and performance improvements. It is recommended for all users.

 

 

New features & enhancements

Scene Edit Detection.pngScene Edit Detection
Use machine learning to automatically detect and add edits where cuts occur in a video.

 

 

 

HDR.pngHDR for broadcasters
With the new Rec.2100 HLG color space, broadcasters can work with more vibrant and dynamic content.

 

 

Proxies.pngExport with proxies

You can now choose to use proxies while exporting if you want a quick export that doesn't require full resolution media.

 

 

Plugin Enhancements.pngOther enhancements

Premiere Pro now scans VST 3 and AU (Audio Unit) plugins faster. Also, exporting an AAF with Breakout to Mono deselected preserves audio channelization.

 

Fixed issues.png

 

 

Here is what we've fixed in version 14.4

  • Playback does not stop when waveforms expanded with smooth scrolling and multicam view enabled
  • Improved location of licensing information for Stock Audio
  • Improved consistency of contextual menu behavior using search bins
  • Deleting an empty Audio track prevents VoiceOver from being recorded
  • Hardware encoding not available on Mac when encode height is greater than 2196 pixels
  • DNxHR MXF files files exported as non-standard frame size that contain display aspect ratio of 16:9 may play incorrectly in external players
  • Some files that play correctly in QuickTime Player import as audio only
  • Improved ProRes Multicam Playback Performance
  • Twitter 1080p preset now produces higher quality outputs with match source for frame rate and higher bitrate.
  • Cannot log in to Vimeo

 

Complete documentation

New feature summary

Fixed issues

Known issues

TOPICS
FAQ

Views

3.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 15, 2020 Sep 15, 2020

Copy link to clipboard

Copied

The Time Remapping keyframe issue with Timeline clips (targeting was off) should also be fixed in Premiere Pro 14.4.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2020 Sep 15, 2020

Copy link to clipboard

Copied

Having issues with 4K footage playing and rendering as black in the timeline. 1080 footage plays back fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2020 Sep 15, 2020

Copy link to clipboard

Copied

Resolved by deleteing render files and then deleteing the clip and undoing. Unistalling update for now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2020 Sep 15, 2020

Copy link to clipboard

Copied

This update keeps crashing and crashing... can't open any of my current project files.

Lost half a day trying to troubleshoot, you guys need to stop dropping sloppy updates like this man, people trying to make a living here. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

Same as you. I lost a lot of works. And I can't copy the time line from 2020 to 2019 version. It's incredible. I contacted the online support...a a journey to hell...nobody know anything...nobody knows anything about anything

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2020 Nov 03, 2020

Copy link to clipboard

Copied

I too have had the same problem and finally got through the support centre. They gave me a download pack for an older version of Pro and so now I have now got Pro 2019 running as 14.4 'is buggy' according the support person.  Big step backwards and of course none of my projects would open in the older version.  The Doltards at Adobe have dropped the ball on this release! I don't even know if they (Adobe) know the support centre cannot help us.  Pretty poor considering the dime i just dropped on updating the subscription for CC.... and now i have got PPro2019??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

Had a quick look on the 'Known issues' page on the Adobe site (https://helpx.adobe.com/premiere-pro/kb/known-issues.html) and it turns out that Trend Micro Security Agent appears to be the problem.  Followed the steps and 14.5 is now working!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

I'm having the same issues, constantly crashing. Making it super hard to get any real progress done. Something that really causes a crash is anytime i change or modify the footage in the project window or audio tracks. Also if i change the sequence settings, or even just click in the project window. Why can't adobe just put updates out when they work all the bugs out!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

EXACTLY!!! Just fix the current problems before making new ones. Adobe still has not fixed the custom palettes when making a new project. If I make a new project the palettes just find some random way of placing themselves across 3 monitors. To fix this: I need to open and existing project, then make a new project, the new project will now set the palettes as per the existing project. What the?? Don't get me started on the cluster that is colour match, how poorly implemented is this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Im still having an issue with getting anything done on it constantly not responding its terrible

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Literally had to completely reinstall my adobe premiere pro because it just refused to start up. It was an active program in my process list but there was no window or interactivity.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Render now is VERY SLOW!!!! Wtf? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

I did the update, and now this is happening. The video card IS completely up-to-date. Everything was working perfect before the update.

Won't workWon't work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

What happens if you click the blue Fix button and follow the instructions?

 

I had this happen to me a while ago and Premiere Pro wanted me to upgrade the drivers to my GFX card.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Love the Scene Edit Detection feature. Some have reported it doesn't work or crashes, for me it works but places all cuts one frame before the actual cut. This wouldn't be an issue if I could just select all and slip all by one frame, but for some reason Ctrl + Alt + Left only slips the first clip. It would be optimal to fix scene edit detection since it's the root cause but slipping all clips is something I've dealt with before and it also needs fixing. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

MacOS Mojave 10.14.6 // Can't even get Premiere to launch after this update was (presumably) automatically installed on my machine. Premiere Pro was working absolutely fine as of 3 days ago, now I can't even get through to the splash screen - the Pr icon just keeps bouncing and then I have to force quit PrPro. Have rebooted multiple times, tried NVRAM resets, tried a bunch of things that were suggested for older releases to get them working, but no luck.

 

Any advice? Physically cannot do my job currently because of this. Adobe you need to fix this. 45 mins on hold to your support line for the call to drop, you're happy to take thousands of £ a year from our company but where's the support when we need it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

Hey Joe,

Hope that you reached support by now. If not, let us know. I typically trash media cache and preferences, and I did that myself this time, as well. I did get the same spinning wheel you did, but I walked away for around 10 minutes and it finally got past that. Another thing to try is to sign out of Creative Cloud and then sign back in. Come back after trying these things. 

 

I'm also running Mac on Mojave with 14.4. Quite good from there, actually, but as I said, I also got the spinning wheel at first.

 

Regards,
Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Many thanks Kevin, I wasn't able to get through to support so in the end I rolled Pr back to 14.3.2 as I had some time critical projects to complete, and this seemed to allow Pr to launch as expected. What I'll probably do is over the weekend I'll try the update again (manually this time) and try your suggestion of sign out/in, clear cache and prefs.

 

Please could you let me know the recommended method for clearing cache and preferences manually? I guess I can't do it through Premiere itself if I can't get it to launch after the update.

 

Cheers
Joe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 23, 2020 Sep 23, 2020

Copy link to clipboard

Copied

I've been working on a project for a month with Adobe Premiere Pro. This morning I clicked on the update of it and medica encoder.

It has made it impossible to complete my work because it has rendered completion of the work impossible,    as a 'frame substitution recursion - error' message is coming up a 100 times a minute and it has blacked out footage that has been perfectly okay for the past month. Now Media encoder won't let me convert it to anything courtesy of it's upgrade when the previous version pre upgrade worked with all of the footage I am currently working on.

I need to seriously consider quitting my subscription to Premiere pro as the upgrade has rendered it useless, I have work to do and there are other software companies out there.

mark D 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 29, 2020 Sep 29, 2020

Copy link to clipboard

Copied

I have an issue that's putting a project on hold.  Additional editors on different computers are reporting the same issue to me.

 

Problem:

Import h264 mp4 (Import or Media Browser).

Error message popup "Import Error: There is not enough memory to import the requested file(s)."

Clip will not import

 

Solutions tried:

Restart.  Sometimes this fixed it.

Uninstall and reinstall Premiere. No change.

Try importing h265 clips. Doesn't import.

 

System:

Windows 10

Surface Book 2

16GB Ram

4TB storage drive

1TB internal SSD

 

This workflow had no issues before the recent update.  Is there a workaround for this?  Thank you

 

Additional editors on different computers are reporting the same issue to m

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2020 Nov 04, 2020

Copy link to clipboard

Copied

Hello darkness my old friend... What's the point of paying for this? Just dropped the video

DislexicDude_0-1604537617480.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

LATEST

my premiere 14.4 came with a lot of problems in the timeline, yours too?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines