Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


RH 11 HTML: Enable Substring Search caches & highlights previous search term

New Here ,
Apr 20, 2016 Apr 20, 2016

Copy link to clipboard

Copied

I'm using RH 11 HTML and primary layout is WebHelp.

If I have Enable Substring Search turned on, search caches the prior search term. For example, I search for: prepay. Topics containg the word prepay are listed, and when I click a topic, it jumps to the first instance of prepay in the topic text and all instances of prepay are highlighted. Great. Now I search for: unbalanced. The topic list is correct, but when I click on the topic, it jumps to the first instance of prepay (many topics contain the word prepay; only one topic contains the word unbalanced). All instances of prepay in the topic text are still highlighted, and so is the one instance of unbalanced (althought the topic did not open at that word, I have to scroll way down to see it).

When I turn Enable Substring Search off and regen, search works like it should. There is no memory or caching of prior search terms so they are not highlighted for the next search and the topic opens at the term I actually searched for.

How can I have both be functional: substring search AND correct highlighting/jump-to's?

And yes, I have already searched Peter Grainge's site (it's the first place I check for RH issues) but I didn't see this issue posted.

TOPICS
HTML

Views

128

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation
Resources
RoboHelp Documentation