Highlighted

RoboHelp 2015 Cannot Add to TFS Version Control - Could not load file or assembly

Community Beginner ,
Apr 18, 2017

Copy link to clipboard

Copied

Was hoping someone could help me resolve this issue. I get this error when I try to add to version control.

1.png

I get this error after I Add to Version Control and select Team Foundation Server MSSCCI Provider. I just recently noticed this after upgrading from RH 10 a few months ago.

3.png

Here is my Robohelp version.

2.png

Thank you!

Hmm. In that case you will need the MSSCCI provider for 2015: Microsoft Visual Studio Team Foundation Server 2013&2015 MSSCCI Provider 32-bit - Visual Studio Marketplace

The error message you posted seems to imply that the TFS client couldn't be loaded for connecting to the repository. Perhaps upgrading the MSSCCI provider helps.

Did you successfully map the repository to a location on your disk in the workspace?

Topics

Source control

Views

698

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RoboHelp 2015 Cannot Add to TFS Version Control - Could not load file or assembly

Community Beginner ,
Apr 18, 2017

Copy link to clipboard

Copied

Was hoping someone could help me resolve this issue. I get this error when I try to add to version control.

1.png

I get this error after I Add to Version Control and select Team Foundation Server MSSCCI Provider. I just recently noticed this after upgrading from RH 10 a few months ago.

3.png

Here is my Robohelp version.

2.png

Thank you!

Hmm. In that case you will need the MSSCCI provider for 2015: Microsoft Visual Studio Team Foundation Server 2013&2015 MSSCCI Provider 32-bit - Visual Studio Marketplace

The error message you posted seems to imply that the TFS client couldn't be loaded for connecting to the repository. Perhaps upgrading the MSSCCI provider helps.

Did you successfully map the repository to a location on your disk in the workspace?

Topics

Source control

Views

699

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Apr 19, 2017

Copy link to clipboard

Copied

What version of the MSSCCI provider did you install? And what version of the Team Foundation client/VS do you have installed?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 19, 2017

Copy link to clipboard

Copied

Not sure what my MSSCCI version is... but I installed it way back in 2014.

As for TFS, I have two installed: VS Express 2015 for Desktop and VS Express 2015 for Web.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Apr 19, 2017

Copy link to clipboard

Copied

Hmm. In that case you will need the MSSCCI provider for 2015: Microsoft Visual Studio Team Foundation Server 2013&2015 MSSCCI Provider 32-bit - Visual Studio Mark...

The error message you posted seems to imply that the TFS client couldn't be loaded for connecting to the repository. Perhaps upgrading the MSSCCI provider helps.

Did you successfully map the repository to a location on your disk in the workspace?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 19, 2017

Copy link to clipboard

Copied

Thank you. I'll try that.

Yes, it has been mapped correctly, I believe. When I make changes in RoboHelp, I get a message that the file needs to be editable. So I have to go checkout my files in TFS so I don't keep getting the error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
ChadPink LATEST
Community Beginner ,
Apr 19, 2017

Copy link to clipboard

Copied

It worked! Thank you very much!

Here's what I did:

  1. I installed the new MSSCCI version on top of what I had (repaired install) - didn't work.
  2. Uninstalled previous version of MSSCCI and then tried to install latest version. Couldn't install. I got an error saying VS Team Explorer 2013 could not be found.
  3. So had to download/install Team Explorer, and then I was able to install MSSCCI.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...