• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Fixed: can't embed unlisted YouTube videos

Explorer ,
Apr 18, 2023 Apr 18, 2023

Copy link to clipboard

Copied

Update: it miraculously works now

 

 

When I try to embed an "unlisted" YouTube video, such as this, it says the following, even though Unlisted videos are public, and only hidden from YouTube search results:

You are attempting to upload a private video. A private video cannot be played in the community. Please try your upload again with a video that is public to all viewers.

Screenshot 2023-04-18 at 3.39.08 PM.png

 

Uploaded by Stefan Wrobel on 2023-04-18.
TOPICS
Bug

Views

2.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Apr 25, 2023 Apr 25, 2023

I'm not sure what changed, but it's working now. See OP

Votes

Translate

Translate
Community Expert ,
Apr 19, 2023 Apr 19, 2023

Copy link to clipboard

Copied

It's a restriction imposed by YouTube. You can't embed content that isn't publicly accessibile.  Only the owner of the video can make it public.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 19, 2023 Apr 19, 2023

Copy link to clipboard

Copied

This is a falsehood. I have embedded plenty of unlisted videos. "Unlisted" videos are different from "private" videos, and as you can see, embedding is enabled for this particular video. Here is the embed code that YouTube gives me for this video:

 

<iframe width="560" height="315" src="https://www.youtube.com/embed/7dmhKDPiddY" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture; web-share" allowfullscreen></iframe>

 

Screenshot 2023-04-19 at 2.43.13 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 19, 2023 Apr 19, 2023

Copy link to clipboard

Copied

What you do with your personal website is your concern. 

Adobe must protect its corporate and legal interests.

If YouTube says the video URL isn't publicly accessible, it cannot be embedded here.

 

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 19, 2023 Apr 19, 2023

Copy link to clipboard

Copied

lol, who even are you? I'll wait for a response from someone who officially represents Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 19, 2023 Apr 19, 2023

Copy link to clipboard

Copied

This is a user-to-user community.  You're talking to fellow product users & unpaid volunteers. Adobe staff rarely participate in these discussions.

 

That said, this forum platform made by Khoros will accept public YouTube URLs.  If you submitted the video, you can make it public on YouTube.  Problem solved.  Otherwise, there's nothing you can do except find another video to post.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2023 Apr 22, 2023

Copy link to clipboard

Copied

You will not get an official response from Adobe in this forum. You can either choose to respect the advice of @Nancy OShea who is quite knowledgeable about such matters, or you can search elsewhere; but please do not treat fellow users who take the time to respond to you here in the forum so rudely. 

Jill C., Forum Volunteer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2023 Apr 22, 2023

Copy link to clipboard

Copied

in the future, to find the best place to post your message, use the list here, https://community.adobe.com/

 

p.s. i don't think the adobe website, and forums in particular, are easy to navigate, so don't spend a lot of time searching that forum list. do your best and we'll move the post if it helps you get responses.

 

<moved from using the community>

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2023 Apr 25, 2023

Copy link to clipboard

Copied

I'm not sure what changed, but it's working now. See OP

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

LATEST

SWROBEL  - you are not crazy - and I feel yout pain with this issue. I get this issue on my community as well, usually after imediately uploading a video to youtube and trying to embed it in a blog post. It has nothing to do with Adobe. It is a YouTube / Khoros (used as the community platform) issue. Usually you need to wait a few hours (or some unknown amount of time) and it will work. Sorry you didn't get the answer you were looking for the first time. Yes - my videos are unlisted and I have embedded them many many times as unlisted - but Khoros for some reason does not mesh well with YouTube as soon as the video is uploaded. its annoying but nothing you can do about it. Stay well. 

(same error on my Khoros run community)

 

2023-08-17_15-55-04.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines