What does the following Error mean: "invalid graph channel frame type"

Explorer ,
Oct 27, 2017 Oct 27, 2017

Copy link to clipboard

Copied

Hi,

one thing that appears from time to time in the final release is the "invalid graph channel frame type" Error on completing a take. What does it mean?
It seems to be connected to recording a take with webcam + keyboard triggers. If I do them one after the other it is fine. Any way to avoid it? Or any idea what causes it?

Cheers,

Johannes

Views

2.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 07, 2017 Nov 07, 2017
Hi, thanks for your response. I actually find the cause. I recorded the quarter right and left face with trigger input and it seem that it was the animation causing trouble. I still have the original file if you want me to send it to you.

Likes

Translate

Translate
Adobe Employee ,
Oct 27, 2017 Oct 27, 2017

Copy link to clipboard

Copied

Hmm. I've never seen that error occur in practice, but it suggests that somehow Ch is writing invalid arf files (that's the extension it uses when saving recorded data for playback). Could you zip up and send a project showing this error to me? I'm hoping a closer inspection of the arf files will reveal some clues as what wires got crossed to create this condition.

I've done webcam and keyboard triggers before and haven't seen it, but I'll also do some investigating to see if I see anything amiss.

Thanks -- DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2017 Oct 27, 2017

Copy link to clipboard

Copied

Hi Dan, I'm on a slow internet connection in the mountains right now and the project folder is pretty substantial: 1.4 Gigs
For me it is not a big issue as I don't do live broadcasting and if I'm the only one who can "produce" the error, nevermind.

But if you would like to investigate here are more details for your investigation:

In trying to analyze the error I found that it appears when I record from the webcam and call 3 or 4 keyboard triggers (in sequence; some call an animation cycle replacing body and head, one a replacement mouth - no error. If during the same take I later call another animation cycle the error appears). The error pops up only when finished and the the keyboard takes appear in the timeline. But it won't allow playback or any other interaction with CH. It will keep popping up whenever I click something in the window, though I can select the takes individually inbetween clicking away the error message and can then hit "delete" for each one until all keyboard trigger takes are deleted. Then the error message disappears. The take based on the webcam is not affected and can remain in the timeline fully functionally.

In other news:
Thanks to the entire team for the final release. I'm really enjoying the new features and look forward to putting out my first big project - a labor that started and grew with the beta version over the last 11 months!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2017 Oct 27, 2017

Copy link to clipboard

Copied

Looking in analytics, I do see a few other customers have hit this case as well. I wasn't able to reproduce it, but will keep trying.

Since it sounds like you can reproduce it on demand, one thing we could try is just locating the individual malformed arf file since that should be much smaller and more slow connection friendly. After doing a recording that shows the error and then undoing/deleting so that the  dialog will get out of the way, if you use the File menu command to Reveal the project in Finder/Explorer. Inside the project there's a Ch Media folder, inside that there's a recordings folder, and then there are folders for each day with arf and wav files. An individual arf is often quite small, so if you could zip those up, they might provide some clues.

donjojo-hannes  wrote

Thanks to the entire team for the final release. I'm really enjoying the new features and look forward to putting out my first big project - a labor that started and grew with the beta version over the last 11 months!

Oh, wait. I remember you! Hi again! That reminds me that I did figure out why we use so much RAM when linking long scenes in After Effects. I'll post back on that thread with more information. I'm glad to hear you're finding a lot to like in the new release.

Definitely let us know when you share it. The team loves to look at things that are created with our product!

DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2017 Oct 29, 2017

Copy link to clipboard

Copied

Hi Dan,

Here are two arf files. Sorting them by time I chose the two with a creation date before and after the event. There was none produced at the actual time the error occured.

https://www.dropbox.com/s/oh6f20t4owxwjoc/arf.rar?dl=0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

Strange. Those two seem to be ok, though they also seem to be arf files generated by editing and not recording (based on the naming pattern). Anyway, I'll have to do some more walking through the code paths to try to figure out how this error could happen. We also updated the different code paths that emit this error to have different messages and include the type that was seen. Hopefully if this remains lurking, that'll give us better clues once that change is in a public release.

Thanks! -- DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Hi, i also have the same problem. I render a first animation in png file, evrything went good, then i wanted to update that first png render and he created a new folder with the exact same name as the first one (don't know how is it even possible). After that the same error message shows up. I tried to save the project in different location but the problem is still the same i don't know what to do.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Is your project small enough to zip up and send it to me?  I'd really like to see an example of the problem to figure out what is going wrong.

Thanks -- DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Hi, thanks for your response. I actually find the cause. I recorded the quarter right and left face with trigger input and it seem that it was the animation causing trouble. I still have the original file if you want me to send it to you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

If you'd be willing to share the project in the bad state, I would still be interested in using it to diagnose what is happening. I haven't been able to recreate the error myself.

Thanks -- DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Excellent. I can see the error in this project and will file a bug and get to the bottom of it.

Thanks! -- DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Ok, the problem turned out to be that the track had no events for more than 10 seconds and there was some code related to drawing the timeline that queried the file contents in a way that was intolerant of that condition. This explains why the original workaround of recording different types of takes separately works because it probably tends to mean less "dead air" time for any given track.

We have a fix internally.

Thanks again for the report!

DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2017 Nov 07, 2017

Copy link to clipboard

Copied

Glad it help you to solve the proble. Thanks you for your quick reactivity

have a nice day

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2017 Dec 05, 2017

Copy link to clipboard

Copied

Hello DanTull ! How are you?
Did you already fix this problem?
I am making a web series with the Character Animator and this problem is killing my production. I can't edit the triggers because when I zoom in the timeline, this message show and I can't click anymore. Edit the trigger is very important for me because almost all the movements are triggers on the animation. This is happening all the time.
Can you help me?
DO you have a deadline to fix this problem?

Thanks a lot!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 06, 2017 Dec 06, 2017

Copy link to clipboard

Copied

We do have a fix internally (assuming this is exactly the same issue as the original thread and not merely the same error message) and it is currently slated for inclusion in our next dot release which is not super far away (usually grumbly caveats about not being able to say anything more precise, etc).

Unfortunately, without that fix there's only a workaround to avoid creating takes that produce this error (avoid recording long periods of silence, usually by recording different kinds of takes separately so that what is being recorded starts near the beginning of the take) and not a way to silence the error for takes that have already been created.

DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

The 1.1.1 update which just went live fixes the instances of this issue that we've seen: What's New in Character Animator

If you still see it after updating to 1.1.1, definitely post back with details!

DT

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

Dan the man! Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

Reporting: Did a 2 minute take with different triggers that would have previously produced the error.

No error. Hurray!

Thanks for fixing it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2017 Dec 18, 2017

Copy link to clipboard

Copied

LATEST

Ah thanks for the fix! That error message was driving me crazy. Thanks guys. Keep up the good work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines