P: LrC Second monitor blurry in Ver 10.2 Develop Module

18 Votes
Community Beginner ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

When in the Develop module my second monitor becomes blurry.  This happened at the time of 10.2 update. I am running iMacPro and MacOS Big Sur 11.2.3.  Interestingly, LR system info incorrectly shows I'm running MacOS 10.16.0.

 

iMacPro 

64GB Ram

Radeon Pro Vega 64 16GB

LG Ultra Fine Display 27in - Secondary Monitor

Bug Fixed
TOPICS
macOS , Windows

Views

1.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 26, 2021 Oct 26, 2021
Greetings,   The Max 2021 Photography products updates have been released and include remedies for this topic.  The updates will be rolling out worldwide, October 26 and 27, 2021. If you do not see the updates in your Creative Cloud Desktop app, you can refresh the apps to see if the updates are available in your region.  The keyboard shortcut to refresh is [Cmd/Ctrl] + [Opt/Alt] + [ R ].    Note: iOS and Android updates may take up to a week to appear in your App Store.   Thank you for your pat...
Status Fixed

Votes

Translate

Translate
replies 147 Replies 147
147 Comments
Participant ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

Does 10.1 fix it?  How do i roll back?  Thanks

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

@LarryGRC In the Creative Cloud app there are three dots to the right of each installed app - click on that and you will see an entry for other versions, which will show a list of earlier versions you can install. 10.1 fixes this issue for me, and newer versions don't offer anything more important than being able to see the image.

Votes

Translate

Translate

Report

Report
New Here ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

Thank you for reply David, hope we get a fix in next release.

Votes

Translate

Translate

Report

Report
New Here ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

agree *TimSmith1001 weeks of treatment like I made it up only to learn it's known and this group of similarly experiencing users exist. Hope we get a fix next release.

Votes

Translate

Translate

Report

Report
Participant ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Any progress on this from Adobe?

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

hey, I think adobe fixed it...LR 10.4

Ok. It seems to be working perfectly. Sharp images on both monitors. Finally. Thanks Rikk and whomever else helped get this taken care of.

Hope this works for everyone.

Sorry. I was wrong. Both monitors sharp in the library module. Second monitor still blurs in the Develop module.

Now I wonder. Is Adobe ever gonna fix this?

This started for me with the 10.2 update. No fix for 10.3. Now 10.4 doesn't fix it. So I'm back to using 10.1.1 again. The updates, I can't use them. I'm still paying the monthly fee. What gives, adobe?

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

There is no mention in the release notes for LR 10.4 of any fix to this issue. Very disappointing.

Adobe - when (if ever) do you plan to fix this problem which has been outstanding for months?

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

*Peter Hassett That's a very good question! Capture One doesn't have this issue thankfully!

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Hello Peter + all - Sure like me you all waited for the promised fix in 10.4, imagine like me you're furious it wasn't fixed. Anyone that runs two monitors will be experiencing this. It's made editing in LR a drag. If I wasn't a designer that uses the full Adobe ecosystem it sure would make a jump to Capture One attractive.

I faced Adobe's total denial this issue even existed for weeks. They said "people all over the world use LR" insinuating I was the only one reporting the issue. Against better judgment I let one support agent do remote and they proceeded to mess up my monitor calibration settings.

What do we do to get Adobe to take this seriously?

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

"What do we do to get Adobe to take this seriously?"

wish I knew...

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

What makes you think it's Adobe's fault, are you a full-stack developer with ties to Apple and Adobe? It could be Apple, just like the "images appear like a red box" issue, which was just fixed by, wait for it, upgrading to MacOS 11.5.

Votes

Translate

Translate

Report

Report
Participant ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

I've not had the problem on Windows and my son doesn't have the problem on either his previous MacBook Pro 16 nor his new MacBook M1 (16GB RAM). He and I are both using the Dell P2715Q 4K monitors. I also have a Benq PD3200Q 4k monitor and switching which is the primary and secondary monitor has no effect; beautiful on both screens. 

 

Hence it is likely that something else is causing the issue though what it is, is anybody's guess. Most likely would be the video card (hardware and/or drivers) though other posters have said that disabling it in preferences didn't help. 

 

I might suspect other resource shortages but LarryGRC is a very potent machine with the problem. 

 

And of course, plug-ins often cause problems even if they aren't in use. 

 

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

*carlos_cardona Well a batchelors degree and 30+ years of working in tech including many years in support has taught me a little. For example when upgrading from 10.1 to 10.2 triggers the problem and downgrading from 10.2 to 10.1 fixes the problem then that's a pretty strong indicator that it's a regression in Adobe's software.

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

I'm not saying you're wrong, but the complexities are SO great it's impossible to have 100% certainty, unless you're the coder. -25 years in Tech for me, you win!

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Hello All. See all the ideas of what could be culprit. Yes all systems are potentially different. Yes maybe the new version is showing up shortcomings of some systems, however there is no escaping one fact. This was not an issue until recently. All worked great until what seems like 10.2 - Hopefully Adobe reads this stream and puts some real effort into supporting pro-users with dual monitor workflow.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Took time to chat with Adobe again and make sure this issue is not forgotten about. Included a link to this forum to confirm it is not isolated to my system. Requested senior developers were reminded we need a fix.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

*David Tong are you on latest Mac OS? as you rolled back and it works that would rule out Mac OS as the culprit as was suggested here.

Votes

Translate

Translate

Report

Report
Participant ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Just to be clear this issue didn’t occur until lr classic version 10.2.  Many have upgraded tom10.2, 10.3 and now 10.4 and the issue persists.  Once those same people downgrade to a 10.1 versio the problem goes away.  Seems pretty clear that this is an Adobe problem or at least they had a direct hand in causing it from 10.2 on.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

@LarryGRC  that's what I suspected. It's not OS, not hardware. Issue arrived with 10.2 and persists to 10.4 ~ thank you, helpful in narrowing down culprits

Votes

Translate

Translate

Report

Report
Participant ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Still, if it is working fine for most people, there must be something different about your machine. For Adobe to test a potential fix, they are going to have to understand why it is unique to a small number of systems. 

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

@bill_3305731 already gave full specs to Adobe. It's difficult I know but reality that it works fine for all up to 10.1 Adobe must have an idea of what they changed that is throwing up compatibility issues.  I just want to get back to enjoying using LR, never had any major issues before this. My system not a slouch or old so hopefully Adobe do research and understand where the issue is coming from. All the best Bill

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

I also have the problem as explained in my original post... you are not alone Desructo 😉

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

This thread contains an Acknowledged badge at the top. That means we've reproduced the bug and are working on a fix. However our ability to reproduce this behavior came very late in the 10.4 cycle so we were unable to get a fix in to this update. We are working on the fix for a future update. 

Thank you for your continued patience. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

@Rikk

thanks Rikk...looking forward to 10.5

in the meantime, i'm brushing up on my capture one 21 skills...admittedly lacking...been using LR since it was available, and Photoshop since the early 1990s...was at an adobe briefing in Manhattan New York when they 'finally' introduced the ability to create text in photoshop 😉

Votes

Translate

Translate

Report

Report
New Here ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

Hello @Rikk thank you for reply. Pleased there is acknowledgement as I have met with a lot of denial this issue exists. Even on chat yesterday this was the case and support wanted to remote login to my machine?

I'm patient, know this takes time, Reassuring it's at least being worked on. Overall just want to get back to an enjoyable LR editing experience.  All the best

Votes

Translate

Translate

Report

Report