• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Premiere Pro 24 Video Preview Glitch

Community Beginner ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

This is happening on all of my premiere pro projects. Started when I updated to Premiere 2024. When I look at a video in either source or the timeline, it glitches (see photo). I haven't found anyway to view my footage. The only way to see the real video is by playing the video. This makes it impossible to color correct or colorgrade footage. Please help fix this, it basically is preventing me from editing. 

 

Premiere Pro 24.3

2019 MacBook MacOS Sonoma 14.4.1

 

Screenshot 2024-04-04 at 2.18.44 PM.png

Bug Unresolved
TOPICS
Editing and playback

Views

228

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
9 Comments
LEGEND ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

That looks like a GPU driver issue. Change drivers.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

Sorry I'm not very tech savy, how do I do that?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

Everything is up to date, both Adobe and my Mac. Premiere is unusable for me until this gets fixed...

Votes

Translate

Translate

Report

Report
Community Expert ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

Try resetting the cache. Hold down shift when you start pp, then choose from the dialog.

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

This isn't something being experienced by others, indicating it is probably something with your machine. Have you set the project acceleration to software only? If that fixes this, then it is a GPU issue.

Votes

Translate

Translate

Report

Report
New Here ,
May 10, 2024 May 10, 2024

Copy link to clipboard

Copied

This is happening to me too!!! I have the same laptop and updates as you. It will also export like that too. Sometimes it works sometimes it doesnt. Did you find a fix for this? 

Votes

Translate

Translate

Report

Report
New Here ,
May 10, 2024 May 10, 2024

Copy link to clipboard

Copied

This is happening to me as well. Same laptop and same verison premeire as maxp

Votes

Translate

Translate

Report

Report
LEGEND ,
May 10, 2024 May 10, 2024

Copy link to clipboard

Copied

Are you also on Sonoma? As there are also problems with ProRes with Alpha channels not working on both Resolve and Premiere. On units running Sonoma.

Votes

Translate

Translate

Report

Report
New Here ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

LATEST

I have  the same problem and also I guess we have the same Macbook. Did you resolve?

Screenshot 2024-05-19 alle 14.45.18.png

Screenshot 2024-05-20 alle 10.05.40.png

Votes

Translate

Translate

Report

Report