• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

All colors and contrast, luminosity is changed when I use after effect composition in premiere

Explorer ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

Hello everyone,

 

On premiere when I cut a part of my video and I make a right click on it to modify it to an after effect composition. Even if I do any modification in this .aep all the colors and contrast, luminosity are changed in premiere pro. Why it does that ?

 

I tried to export my .aep when I play it with VLC no problem with all the colors and contrast, luminosity but when I import it in premiere boom it changes into something different, and you can clearly see it.

 

All my files are in .mov in my premiere project so I tried to export it in .mov, it doesn't work. I even tried to render it in premiere with "render of entry and exit" and it doesn't work too.

 

Does someone have a solution ?

 

TOPICS
Editing , Error or problem , Import

Views

233

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jul 07, 2022 Jul 07, 2022

So I find the solution what I do is if I import a video not from the Iphone I go in the project panel right click on the video/Modify/Footage(Or métrage in Fr) And in color management I select replace color space and select Rec. 2100 HLG (because that's the one that my Iphone uses and the project too) and like this it looks like the original one.

 

And for my own footage so a video from the Iphone I go in Lumetri Color and add the custom lut HLG_to_Rec709 because premiere does not support well thi

...

Likes

Translate

Translate
Community Expert ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

@R Neil Haugen, do you have any idea? Is this caused by a mismatch in color working spaces between PPro and Ae?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

As Richard comments about, this is typically because you don't have the Ae color management setup to the same as Premiere.

 

Make sure that Ae's CM is set to Rec.709/2.4.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

Hello @R Neil Haugen thanks for your answer but yes my Ae's CM is set to Rec.709/2.4. As you can see (yes sry but I am french).

Nicolas247377897fdt_1-1654550541825.png

 

 

You are saying that I might do not have the same color management in premiere pro, but where do I find this setting in premiere ? I just find this :

Nicolas247377897fdt_2-1654550579816.png

I tried to find on the web for the color management of the software of premiere pro but but I can't find it ? Where is it ? Or is this only what I showed ?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

That should be correct ... but the Premiere CM is all over the program, sadly. For media, it's in the Project panel, right-click/Modify/Interpret Footage ... for comps, that would just be in the Seqeunce settings for that Sequence.

 

So ... have you unchecked "composite in linear color' in Premiere's Sequence settings dialog?

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Wow this look very complex to me sorry but I am new to premiere.

 

I select my composition and this is what I found :

Nicolas247377897fdt_0-1654605874650.png

So yes I have "composite in linear color" that is unchecked, what should I do @R Neil Haugen ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Apparently, your Ae has that option already disabled or it isn't available for the things you've done in Ae.

 

At this point, the best place to get help is probably go to the AfterEffects forum and ask, as that's where the people with the most knowledge of Ae/Pr workflows will be found.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Ok I will try in these forum so, thanks for trying to help me

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

But I don't think the problem comes from AE ! because when I make a render of that composition and I open it with VLC the image looks good but when I play it in premiere the image looks bad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

The suggestion to ask in the AE forum wasn't to necessarily change something in Ae, but in simple recognition that the people with the best knowledge of getting Ae comps & media into Pr successfully are those who regularly work in Ae.

 

On this forum, most of us that use Ae just do so occasionally. We don't tend to have a ton of experience outside our own few uses.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Ok thanks for the precision !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Hello again @R Neil Haugen as you can clearly see it still does crap even with images :

(on the left it's the original image, I do any modification in premiere)

Nicolas247377897fdt_0-1655937787118.png

Did they're is somewhere, where I can report this bug to adobe ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

See if changing to software only acceleration helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

It changes nothing 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Their portal to the engineer's is the UserVoice system ...

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Wow I just looked at it and it look like a nightmare for reporting bugs...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

You can easily search by keyword, pull up anything that matches. Add comments or simply "upvote". Easy to add new posts, and to attach files.

 

Not understanding why you think it's a nightmare, though.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Where do you see that ?

I just find a heavy pdf with instructions

 

And I think maybe a precision that could be useful for you, I just do video with premiere and AE, and I had any bugs, any problem, most of the video was some content filmed with OBS. And with this one I filmed with my iphone and it's a nightmare to edit I have a lot of bugs, crashes etc. Is this buggy because most of the footage comes form my Iphone ???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Then you must have hit the 'help' file ... the  Premiere Pro UserVoice  is their bug/feature posting site.

 

iPhones typically use HLG, an HDR format unless you change the preferences. That's a problem in Premiere, and for working with that, you need to set the Override to Rec.709 option in the project panel/bin ... right-click/Modify/Intepret Footage.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 01, 2022 Jul 01, 2022

Copy link to clipboard

Copied

Sorry but changing to Rec.709 is way worse.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2022 Jul 01, 2022

Copy link to clipboard

Copied

As you had the color space set to something else in Ae while creating that, you may need to mod the Ae image with the color space now set properly to Rec.709 ... then it should work.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

Hello again I just change the same color space in AE and premiere and nothing changes...

 

I might just stop using premiere and use only AE because of this bug

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

Ok I don't know why but with the video that I imports if I modify the color space of these here it works. So this bug should be solved if I do all export of my AE comp in my project and I modify the color space of these imports. Thanks a lot for your help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

But just to be precise I will not use premiere now because it does the same with gif and images... And I can't do you advice with it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 07, 2022 Jul 07, 2022

Copy link to clipboard

Copied

LATEST

So I find the solution what I do is if I import a video not from the Iphone I go in the project panel right click on the video/Modify/Footage(Or métrage in Fr) And in color management I select replace color space and select Rec. 2100 HLG (because that's the one that my Iphone uses and the project too) and like this it looks like the original one.

 

And for my own footage so a video from the Iphone I go in Lumetri Color and add the custom lut HLG_to_Rec709 because premiere does not support well this... And with this it looks like almost the original footage.  You can dwl it here : https://drive.google.com/file/d/1mEUbVlca2nbC5RMQPAYdubwTgMt7W5zX/view

 

And I find this in this video : https://www.youtube.com/watch?v=cNb2S_W1Csc

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines