Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Arabic characters not joining correctly in the new captioning tool

Explorer ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Hi all,

 

Since the latest update with the redesigned captioning tool, Arabic characters show correctly in the caption editor, but are not rendering correctly in the program monitor. I have "South Asian and Middle Eastern" checked under Text Engine in Preferences. Screenshot below

 

Screenshot 2021-03-17 at 07.18.13.jpg

TOPICS
Effects and Titles, Error or problem

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 20, 2021 Mar 20, 2021
See the correct answer from staff (Trent Happel via Kevin Monahan): https://community.adobe.com/t5/premiere-pro/srt-import-with-right-to-left-language-e-g-hebrew-arabic-text-is-reversed/m-p/11909031#M335759 "Do you have South Asian and Middle Eastern set in your Caption Track Settings? Right-click on the Caption track header, choose Track Settings... and then under Styling Options > Text Engine, click button for South Asian and Middle Eastern. Then click Ok button." Interestingly, I don't th...

Likes

Translate

Translate
Community Beginner ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

I'm having the same issue.  My graphic preferences are set correctly and I'm even using the English-Arabic version of the software.  Similar to above, my Arabic text appears correctly displayed (R-L) in the captions window but in the timeline/Program monitor is displayed incorrectly L-R.  The text direction toggles in Essential Graphics are disabled.  Hopefully I'm missing something but my guess is the fuctionality doesn't exist yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Yeah they worked for me in older versions of Premiere captioning tool so I presume something broke / wasn't included in the new update. I think installing older version is the only solution for now 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

See the correct answer from staff (Trent Happel via Kevin Monahan):

https://community.adobe.com/t5/premiere-pro/srt-import-with-right-to-left-language-e-g-hebrew-arabic...

 

"Do you have South Asian and Middle Eastern set in your Caption Track Settings? Right-click on the Caption track header, choose Track Settings... and then under Styling Options > Text Engine, click button for South Asian and Middle Eastern. Then click Ok button."

 

Interestingly, I don't think you need to set the regular preferences to South Asian and Middle Eastern as long as you set the caption track. But when I set the regular preferences to that and created a new track, it set the caption track to the same.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

Thanks!  That worked for me.  I don't think I would have ever found the track menu w/o you pointing it out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

Yes. I sure didn't find it until I saw Trent/Kevin's answer.

 

And no, it is not in the documentation yet...

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 21, 2021 Aug 21, 2021

Copy link to clipboard

Copied

Agreed with everyone else, wouldn't have found this until it was pointed out. I'd done the standard steps, turning on south asian and middle eastern scripts in the preferences. Why the added step to turn it on in captions seperately? Adds to the confusion if you ask me.

 

Kape

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 21, 2021 Aug 21, 2021

Copy link to clipboard

Copied

LATEST

I just checked, and this is still not in the caption workflow documentation. One day I'll have to figure out who to send a comment to that team.

 

My guess is that because the general preferences sets a global setting there is a need for captions to have different settings per caption track (multiple languages). Totally a guess.

 

Stan 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines