Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Audio waveform not showing visually

New Here ,
Jan 02, 2019 Jan 02, 2019

Copy link to clipboard

Copied

Having issues with this since updating to 2019. Basically, after importing a clip into the timeline everything is as it should be (video plays, audio plays) but the audio waveform does not show up until it's played through so I cannot visually see the audio waves unless I play/skip through the whole clip, which obviously makes editing a lot slower.

Attached an example. Image 1 is the clip just imported to the timeline and image 2 is after playing through a few seconds (as you can see the audio only shows up after I've played through the clip and the remaining audio waves are still blank)

Any help would be appreciated!

Using Windows and Adobe Premiere Pro 2019.

Audio1.PNG

Audio2.PNG

Views

105.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 02, 2019 Jan 02, 2019
First, go to Edit > Preferences > Audio and make sure that the setting "Automatic audio waveform generation" is ticked. If this is un-ticked no waveforms are generated when importing files. This will not affect already imported clips, it will only affect clips you import from now on.Second, for creating audio waveforms on clips that dont have them, select the clip/s in the Program panel and go to Clip > Generate Aduio Waveform.If the first trick fails i would have trashed the Preferences in Prem...

Likes

Translate

Translate
Contributor ,
Apr 09, 2019 Apr 09, 2019

Copy link to clipboard

Copied

One work around in to convert your audio files to a video file. Also try placing your cache folder on different drives if you can. That worked for me. I think this is a major bug since more and more people are complaining about it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2019 Apr 09, 2019

Copy link to clipboard

Copied

i should note that I have no issue with audio-only files: these come in with waveforms as usual. My issue is with video files (with audio tracks included). Here the audio waveform is currently either: (a) A flat line; (b) not apparently anything to do with the video; or (c) correct. On bringing a video file in the audio tracks will either display or not. If they display, they may be correct, or they may not relate to the video. The waveforms if present can change from synched to meaningless in mid-clip without warning. In these circumstances reloading the clip has no effect (the same with all of the remedies proposed in this conversation so far).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 09, 2019 Apr 09, 2019

Copy link to clipboard

Copied

Sounds like you have a way bigger problem than me. But it's probably all related

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2019 Apr 09, 2019

Copy link to clipboard

Copied

Another work around is Render & Replace the audio clips that you are using in the timeline.  Not the best solution, but it does get you a waveform...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

Thank you so much! This is the only response on this thread, so far, that has actually unblocked me. In my particular case I had a sequence within a sequence which was just showing empty audio. I had to unlink video and audio before I could 'Render & Replace' just the audio element. At least I can work now as I've not got time to debug this on behalf of Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 09, 2019 Apr 09, 2019

Copy link to clipboard

Copied

We have had this same issue on and off for the past couple of years. Deleting the .pek and .cfa doesn't work reliably. What does work for us is to delete or move the media cache database. Then close Premiere and reopen. For us, this works every time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

Are you moving the folder to a different drive. I tried replacing the folder in didn't work unless I put it on a different drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

BREAKING NEWS!!! For some unknown reason I put my cache files on my original scratch drive the waveforms now work again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

By relocating the cache files, the DB was updated AND I am wondering what speed/interface the drive that you had been using for the cache that didn't work?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

I'm back to my original cache drive which is a local raid drive. I upgraded last week and that didn't seem to fix it. So just for the hell of it I just wanted to see if it would work and it did , so confusing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

We move it to a different location, either within the same drive or completely delete it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

I ended up deleting the Media Cache and Peak Files, and the waveforms came back.  It took a long time to regen, due to the project size, but it was working in the background (vs. rendering or replacing the files).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2019 Apr 12, 2019

Copy link to clipboard

Copied

The same problem here. I can't see the waveforms not only for audio files but for all files. And part of my project files have them and part not.

I tried to move my cache delete it, enable "place cache files next to original", re-render project. re-render waveforms. Nothing helped me, only zoom in the sequence window show waveforms but when you zoom out you can't see the waveforms again.

Really stupid bug and it's sad that Adobe isn't fixing this fast.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2019 May 10, 2019

Copy link to clipboard

Copied

Sometimes, this solution doesn't work. It didn't for me. But then I found another, simple method. tl;dr below. Hope it helps people.

So I have found that you can trick Premiere into make a new .pek file without much effort.

  1. Make sure this checkbox is checked: "Premiere Pro > Preferences > Audio > Automatic audio waveform generation"
  2. In the Premiere timeline, on the clip in question, right-click > Reveal In Finder
  3. In Finder, move the audio clip up in the Finder folder hierarchy
  4. Return to Premiere
  5. The clip should have lost its link to the file and the Link Media dialog box should automatically appear (if it doesn't, right-click > Link Media)
  6. Relink the clip to where it is in its new location

That should be it. Look at the bottom right of your Premiere windows to see if it's automatically generating new waveforms (generally a blue status bar). Wait till that bar is complete and tada: waveforms. They should show up immediately and automatically. I think what's happening is that this process disrupts Premiere's link between that file and any previously generated waveform information. So the incomplete or corrupt waveforms are ignored, and new ones are generated for the file in its new location. Moving the files up (as opposed to down or into a new folder in the same place) seems essential to confusing Premiere's automatic relinking process. If you've moved it sideways or down, when you click back over to Premiere from Finder, Premiere seems to be able to find it, and so nothing really happens.

A couple notes from experimentation:

  1. Seems okay to make a new folder, just has to be higher up
  2. This can be done in batches (batch move in Finder, batch relink in Premiere)
  3. Seems also to solve the problem of not being able to see Waveform information up through Multicams

tl;dr

Move the associated audio files in Finder to a higher folder in the hierarchy, then relink in Premiere.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 12, 2019 Sep 12, 2019

Copy link to clipboard

Copied

The "correct" answer here is not.  At least not always.

In my case, the sequnce stopped showing audio waveform after I'd done manual work in the multicam it sources from.  (I manually edit my multicams a lot.  Usually, things behave fine.  But in today's case, the "no waveform" bug occurred.  Oddly, I could not then recreate it in new test sequences, right afterwards, by following the same steps.  So it's more nearly random.)

None of these fixes worked:

  1. Edit > Preferences > Audio: Check "Automatic audio waveform generation" 
  2. Select clip in Program Panel, then frommenu: Clip > "Generate Audio Waveform"
  3. Delete media cache database (even manaully outside PrP0; close PrP; reboot PC. 

(I also unsuccessfully tried a number of things not listed in this thread, which I'll omit for brevity.)

Which leaves me with THIS WORK-AROUND:

  1. Select audio track in sequence (not in multicam).
  2. Right-click, Render & Replace.   (Creates/imports/replaces with a file of same name + " Extracted".)
  3. In Project panel, go to audio file that you want the sequence to use, and manually add it to your sequence (not to the multicam) under the rendered-replaced audio track, and then sync manually (visually, using a sharp peak of the waveforms; but cross-check by ear to ensure no echo).
  4. Delete the rendered-replaced audio track, leaving just the desired audio track.
  5. PRO: Any future changes to the manually placed audio file (in the sequence) such as refinements made in Audition will show up in the sequence.  Minor CON/FYI: but changes to the audio in the multicam source are now of course being ignored wrt your sequence.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 14, 2019 Dec 14, 2019

Copy link to clipboard

Copied

I found one other fix.  If you manually edit your multicamera sequences a lot, like I do, then you might at some point unmute audio tracks below you top audio track.  This will consistently flatline your audio peak trace in timelines that point to this multicam sequence.

 

While I suspect you can fix this by -- as recurringly offered in this thread -- render/replace, I think the cleaner approach is to just mute the audio tracks below the top track in the multicam sequence.  Seems PrP wasn't intended to mix audio tracks within a multicam sequence.

 

I tend to do all my audio mixing in Audition anyway.  So this update here is just to report that any seeming short-cut -- to mix in a bit of audio in the multicam sequence -- is actually quite problematic, and best avoided.

 

Adobe post.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 04, 2019 Oct 04, 2019

Copy link to clipboard

Copied

For what its worth I had a simmilar problem and adobe helped find a fix for me. I layed out the steps on my post here.


https://community.adobe.com/t5/Premiere-Pro/Audio-Waveforms-not-appearing-despite-sound/td-p/1064784...

🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 04, 2019 Oct 04, 2019

Copy link to clipboard

Copied

franciss, Glad to hear it worked for you. It did not for me, hence my 12 Sep 2019 post. Note that just as I wrote it, I manually deleted the cache, outside PrP; I did not just use PrP's delete cache option in program.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Oct 10, 2019 Oct 10, 2019

Copy link to clipboard

Copied

Well none of that worked for me-- resetting, etc... What did was first opening the file in Audition and making sub clips there.  At least for the audio only files. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2019 Oct 21, 2019

Copy link to clipboard

Copied

SOLVED: Go to Preferences > Timeline > Check 'render audio when rendering video'

After that just select the clip and go to Sequence > Render selection.

Hope this works for you as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2019 Oct 24, 2019

Copy link to clipboard

Copied

In case anyone wonders in here, I FOUND A FIX. Right-click your audio clip that has no waveform, and click the option that says "Render and Replace." It will spit out the new clip with the audio waveforms in full view. Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

This solved the issue for me. Thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

It's a year later and this is still happening. I had a waveform, zoomed in once and it disappeared, now nothing is bringing it back. This mainly happens for me when I use nested sequences, but all the other clips in the timeline using the same subsequence are displaying properly. Just not the one I actually need to edit, of course.

 

Combined with the wacky display errors when you apply an ease to alpha animation, Pr 2020's UX continues to be an adventure.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

Go to Preferences > Timeline > Check 'render audio when rendering video'

After that just select the clip and go to Sequence > Render selection.

Hope this works for you as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2020 Jan 12, 2020

Copy link to clipboard

Copied

Just easily Right click on you audio track then Render and Replace.

Good luck.

Screenshot 2020-01-12 at 15.20.58.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines