Cross Dissolve NOT Smooth

New Here ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

I've been having this issue since I first started with Premiere Pro (cs5) and it has kept me from using any dissolve transitions or the program altogether:

Dissolve transitions (specifically Cross Dissolve) will not end smoothly - there is always a jump at the last, seemingly, 10% or so of the transition. In other words, the dissolve goes from 100% opacity to 10% opacity of the previous clip. This is not a result of me having set those parameters in the effects controls. As well, it is not a playback quality/speed issue as you can advance frame by frame and see the problem. It also shows up in all timeline renders and final exports.

I've been hard pressed to find an answer anywhere. I had come across an OLD Creative Cow post with what I thought was my identical problem. In that thread it mentioned manually adjusting opacity keyframes with bezier controls. That was not the solution and the thread was left answer-less. It is a very noticeable difference in dissolve smoothness compared to After Effects or Final Cut and is not professional-looking.

Extending the length of the dissolve is no fix either. The problem persists in both Hardware Accelerated Mercury Extreme playback AND Software-Only settings. However, I have found intermittent success with Software-Only. BUT, that's kind of useless as editing without the Hardware Acceleration is a much larger step backward (absolutely a must when working with RED footage, DSLR or higher bitrate/resolution material).

I pray someone has had this issue too and can shed some light on a solution.

Some of my specs:

8 Core 2.8Ghz Xeon Mac Pro (early 2008 - 3,1)

12GB Ram

Geforce GTX 285 Mac Edition

RAID for video (there is no bottle neck here)

OSX 10.6.8

Premiere Pro CS5

Thanks for your time!

Views

35.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

Have you tried rendering a agement to see if the problem carries over to the export?  The preview monitor is not the best way to judge.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

Hi,

@SFL46:

Thanks for your response. Yes, this issue appears in final renders. Here is a link for an old video where you can see the un-smoothness at work. The jumps in the last 10%ish of dissolves are not a streaming issue (just FYI) - they are in my un-web-compressed versions too. I'll try getting a more recent clip up on my server for anyone to have a gander at.

http://vimeo.com/14536285

@Bill Hunt

Thanks for hoping in on this thread! Yes, I have adequate handles on clips with the dissolve. You can see on the video above that it even happens when fading text.

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

The only solution is to not use hardware MPE (GPU acceleration), and while rendering/exporting with software mode, be sure you don't use Maximum Render Quality. Both scenarios enable 32-bit linear color, which results in the stepwise dissolves (along with other issues) that you're seeing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

Thanks Colin,

It's a shame that the solution is a work-around. Thanks a lot for your input. I didn't know that the color space is altered and is affecting something like dissolves. I'll definitely be using this method in the meantime.

I'm still open to any other ideas for fixes people may have!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

It's not a workaround. That's just The Way It Is. There are no other solutions to this in Premiere Pro CS5 and beyond.

A feature request for more flexibility in deciding what is processed in linear color while still maintaining the other benefits of hardware MPE/GPU acceleration may eventually pay dividends, but for now, this is what we're forced to accept.

Ask for it here: Adobe Feature Request/Bug Report Form

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 10, 2013 Jan 10, 2013

Copy link to clipboard

Copied

I have only recently upgraded at Premiere CS6 (from CS3) using PC. I am experiencing this problem with cross dissolves not being smooth with the hardware MPE GPU Acceleration (CUDA) enabled. It was one of the first things which I noticed when I started using CS6. The problem goes away when the MPE software only is used. Are other users still experiencing this problem, and is there any hope of an improvement from Adobe?

Many thanks

Daniel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 10, 2013 Jan 10, 2013

Copy link to clipboard

Copied

Danielpremiere wrote:

I have only recently upgraded at Premiere CS6 (from CS3) using PC. I am experiencing this problem with cross dissolves not being smooth with the hardware MPE GPU Acceleration (CUDA) enabled. It was one of the first things which I noticed when I started using CS6. The problem goes away when the MPE software only is used. Are other users still experiencing this problem, and is there any hope of an improvement from Adobe?

Many thanks

Daniel

I still experience this problem with every single cross dissolve. It's more noticeable on certain contrasting shots that and I hardly notice the issue until I export and view the video outside of Premiere. But yeah, its still a crappy problem and who knows if it's gonna get fixed ever. The THIRD post in this thread has a great example from another user what the issue looks like. I do not have GPU acceleration enabled and I still have the issue so I don't think that's related, but that's interesting that it appears to go away when you disable that. If you export the video with and without CUDA enabled, do you notice a difference? Care to post it here?

Either way, I ended up creating my own opacity preset for fading in and one for fading out and had the keyframes NOT be linear which is the issue. Instead, I went with EASE IN and EASE OUT for each keyframe in my preset. I guess just plain old "bezier" would have been okay too but I took it a step further with EASE IN/OUT. Good luck! Oh, and fill out a "bug report" on this HERE.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

Daniel,

I assumed that you did, but wanted to get rid of that possibility early on.

I'll be reading this thread, as I think I might learn something too.

Good luck,

Hunt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 13, 2016 Oct 13, 2016

Copy link to clipboard

Copied

It renders that way.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 01, 2011 Sep 01, 2011

Copy link to clipboard

Copied

Just to rule this out, am I correct, that you have adequate Handles for the Dissolves? The only reason that I ask, is that depending on what the first Frames of the next scene, can appear, if the Handles are not quite long enough. This is NOT an Opacity issue, which is what your sounds like, but lack of Handles can cause a little glitch, right at the end of a Dissolve. Again, this is just to rule that out as a possibility.

Good luck,

Hunt

PS - there was an Opacity Bug (was that CS 3, or CS 4?), where just adding an Opacity Keyframe (though not making any change - just adding that Keyframe) fixed the issue. Had not heard of that in CS 5 / 5.5.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 14, 2012 Oct 14, 2012

Copy link to clipboard

Copied

DanielFrick wrote:

I've been having this issue since I first started with Premiere Pro (cs5) and it has kept me from using any dissolve transitions or the program altogether:

Dissolve transitions (specifically Cross Dissolve) will not end smoothly - there is always a jump at the last, seemingly, 10% or so of the transition.

Okay so I realize this thread is old, but I can't stand how normal cross dissolves (I tend to keyframe all opacity changes) have this unsmooth/abrupt start/finish.

His video in the original post is exactly what I was experiencing all weekend. Coming from FCP, the same basic cross dissolve is smooth with no jumps. I ended up going into every single one of the disolves and selecting EASE IN and EASE OUT for each and every opacity keyframe. With a huge project and tons of dissolves this took over an hour.

Is there anyway around having to do this manually one by one to every keyframe? Like is there a way to set it to always default as EASE IN or EASE OUT? I realize the above work around was to turn off maximum render quality during export. Not sure if that helps, but I don't like the idea of sacrificing export quality for simply having smooth transitions. Plus, its a year later and maybe CS6 has a better way now to handle cross dissolves so they don't come out so crappy. (I'm on a 2011 27" i7 iMac with 16gb ram and the AMD 6970M card)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 14, 2012 Oct 14, 2012

Copy link to clipboard

Copied

Are you saying that you are not using the Cross Dissolve Effect ?

ie. you are creating all your cross dissolves manually using opacity keyframes?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 14, 2012 Oct 14, 2012

Copy link to clipboard

Copied

shooternz wrote:

Are you saying that you are not using the Cross Dissolve Effect ?

ie. you are creating all your cross dissolves manually using opacity keyframes?

Yes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 15, 2012 Oct 15, 2012

Copy link to clipboard

Copied

So what happens if you use the  Cross Dissolve Effect?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 15, 2012 Oct 15, 2012

Copy link to clipboard

Copied

shooternz wrote:

So what happens if you use the  Cross Dissolve Effect?

It's hard to say. I only did it that way a few times. Looking at it now, those (using the effect instead of keyframes) don't look quite as bad.  Not quite as smooth as ease in/out but more smooth than the linear cross dissolve using keyframes. Just wondering I guess if there's way to always have it ease in and out without having to individually click on each keyframe and adjust. A keyboard shortcut? A plug in? Anything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 15, 2012 Oct 15, 2012

Copy link to clipboard

Copied

I would be interested in seeing a video of your manual cross dissolve and the Effect Cross Dissolve.

I have never found issue with the FX Cross Dissolve but can understand how one could get issues with a manual one.  (Apart from how time consuming it is and how messy the timeline must get - how do you manage the clip overlap?)

Can you post a screen grab of your Key frame window?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 17, 2012 Oct 17, 2012

Copy link to clipboard

Copied

shooternz wrote:

I would be interested in seeing a video of your manual cross dissolve and the Effect Cross Dissolve.

I have never found issue with the FX Cross Dissolve but can understand how one could get issues with a manual one.  (Apart from how time consuming it is and how messy the timeline must get - how do you manage the clip overlap?)

Can you post a screen grab of your Key frame window?

Looking closer the cross dissolve does have the same abrupt start and end that you see in the original post's sample seen here: http://vimeo.com/14536285

I originally said that it was better than linear opacity keyframing one track on top of another, but after a few tests its not. Hopefully you can see in his video what happens on these fades. After you see a few in a row I really start to notice the first and last 10% clip in/out unless its bezier or even better ease in/out.

But like I said in my previous post, I've now got a preset for ease in/out fades but its a keyframe preset. Is there a way to adjust the cross dissolve effect with ease in/out or create a new cross dissolve effect that you can drop on top of two clips back to back on one track?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 17, 2012 Oct 17, 2012

Copy link to clipboard

Copied

Thanx for posting.

I agree ...your cross dissolves are "ugly" and as you described...seem to go weird over final 10%

Never seen that  "issue"  before... in my work.

Are these butt cut clips on a single video layer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 17, 2012 Oct 17, 2012

Copy link to clipboard

Copied

shooternz wrote:

Thanx for posting.

I agree ...your cross dissolves are "ugly" and as you described...seem to go weird over final 10%

Never seen that  "issue"  before... in my work.

Are these butt cut clips on a single video layer?

I don't know because they aren't my clips. The original poster was someone different from a year ago but my clips look the same and yes I tested them butted up against each other and also on top of each other using the cross dissolve with the same results. Its not as noticable if the two clips are similar except in areas of high contrast. The presets I made with ease in/out are helpful for the stacked track editing I just wish I could apply it to the seqences that have all the video clips on one track (eg. multicam) with ease. No pun intended.

But according to Jim's recent response its not possible. Bummer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 17, 2012 Oct 17, 2012

Copy link to clipboard

Copied

http://www.youtube.com/watch?v=nZ3y7LxOdew&feature=plcp

Here are some standard cross dissolves in a little example of my work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 17, 2012 Oct 17, 2012

Copy link to clipboard

Copied

shooternz wrote:

Here are some standard cross dissolves in a little example of my work.

Great. Now I'm hungry.

Well, I watched that about 10 times and I think because its got a lot going on in each clip and because there isn't that much difference in contrast on a clip by clip basis this issue is not really noticable. I had to watch it 10 times to even pick up on possibly one instance...the last fade between the open can and what looks like a pill. That one seems to clip out quickly perhaps.

The thing is, not every cross dissolve is that noticable. Some just really stand out more than others. Not totally sure what causes it to be more noticable (maybe something light fading into a more dark shot I don't know) but its definitely there. If there's no way to adjust it to ease in more, I'll just stick with editing stuff on top of each other and use my custom presets that I made that ease in/out. Would be nice to adjust the effects that go on one track though for things like multicam, etc. Oh well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 18, 2012 Oct 18, 2012

Copy link to clipboard

Copied

Do a simple test.

Cross dissolve between a 70% grey card and a 10 % grey card. eg Mattes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 18, 2012 Oct 18, 2012

Copy link to clipboard

Copied

I did that. Not quite as obvious as when real clips are used. So maybe its not light to dark issue, I don't know. Like I said though, sometimes its less noticable and sometimes its very noticable like that guy's video. I know earlier in this thread someone suggested to the guy to not select max render quality upon export. Well, I'd rather not do that for 2 reasons: 1) That sucks to have to take away the "benefits" of selecting that box for the sake of cross dissolves  2) The effect can be seen in the actual timeline as well...although admittedly its much more noticable upon export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 18, 2012 Oct 18, 2012

Copy link to clipboard

Copied

FWIW

When  I do this test:

Create 2 second: Cross dissolve between a 70% grey card and a 30 % grey card. eg Mattes

....and I check it out in the waveform monitor..by stepping through every frame with the arrow keys

The luminance increments are exactly the same ...totally linear...through out the transition.

Tested with and without Mercury Hardware.

A Film Dissolve is not so linear

An Additive Dissolve is not linear and displays as to be expected from Add.

A Non Additive Dissolve ..does nothing on this material.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines