New Captions are cutting off characters, Edit Graphics workspace does not look like tutorial

New Here ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

I am having an issue with the new captions. I have imported an srt file to the caption track and everything is lined up on the timeline correctly. However, it is truncating each line of text, so you cannot see the whole caption. They look fine in the text box but do not appear on screen. All the video tutorials I can find show how to edit the size of the text box in the Edit Graphics panel. But mine is missing A LOT of the things they are using. See picture below. How can I make the entire caption file visable without completely redoing them with fewer characters in each line?

Screen Shot 2021-04-20 at 11.42.51 AM.png

TOPICS
Editing , Effects and Titles , Error or problem , How to

Views

758

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 20, 2021 Apr 20, 2021
Stan is spot on, CEA-608 has character limitations (https://en.wikipedia.org/wiki/EIA-608). If you intend to stick with Open Captions/Subtitles (since you are starting with an SRT), then best to create a Subtitle Caption track (which allows greater number of characters). You can simply reimport the SRT from the Text panel and when New caption track dialog appears, choose Format: Subtitle.  Unfortunately, we don't currently warn you when you get into specification cases like this, but it is on ...

Likes

Translate

Translate
Adobe Community Professional ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

Have you tried using the Captions workspace? You're in the Graphics workspace there ...

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

You created a CEA-608 Closed Captions stream. It is limited as to how many characters can appear on a line and more.

 

If you don't need closed captions, just right click in the track header area and change it to Subtitles - what used to be called Open Captions in Premiere Pro.

 

Then you'll see all the editing options you want.

 

If you are burning in, you'll be good to go. If you are creating a sidecar file, you need to know what format file export you will have.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

Stan is spot on, CEA-608 has character limitations (https://en.wikipedia.org/wiki/EIA-608). If you intend to stick with Open Captions/Subtitles (since you are starting with an SRT), then best to create a Subtitle Caption track (which allows greater number of characters). You can simply reimport the SRT from the Text panel and when New caption track dialog appears, choose Format: Subtitle. 

 

Unfortunately, we don't currently warn you when you get into specification cases like this, but it is on our radar. 

 

If you haven't found them yet, here are a few helpful links for new Captions in Premiere Pro 15.0.

https://helpx.adobe.com/premiere-pro/user-guide.html/premiere-pro/using/working-with-captions.ug.htm...

https://www.youtube.com/watch?v=xpdFSpL4lcY

https://www.youtube.com/watch?v=rcmDz7FDmRQ

https://www.youtube.com/watch?v=Cz7TOQCjbUM

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

What if you need to embed your captions into the export file? I am trying to embed into a ProRes file and the only way to do that from Premier is if the captions are set to 608. No other caption format works. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

LATEST

K Huff,

 

Yes, that is the status. From the user guide:

QuickTime embedded export currently only supports embedding CEA-608. MXF Op1a Formats can embed CEA-608, CEA-708, and Australian OP-47 (if 25fps). You will also need those track types in your sequence in order to embed. For example, if you have an SRT in sequence, that cannot be embedded. You must have a compatible format such as 608, 708 or Aus OP-47

 

https://helpx.adobe.com/premiere-pro/using/working-with-captions.html

 

Stan

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2021 May 02, 2021

Copy link to clipboard

Copied

Thank you so much for this comment! Simple fix--I just changed it to 'subtitle' from teletext and I didn't have the character cut off issue any more. Big thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines