Premiere Pro 2020 not opening projects

New Here ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

Hello! Currently I am trying to open up my premier pro projects. I am able to open the app on my iMac, but when I go to open a project, it will attempt to open, then it wont respond. I've reset my computer and restarted premiere a few times now. I'm unsure what to do next.

Views

25.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 26, 2020 May 26, 2020
Create a brand new project and import the old project into the new one via File > Import. Have patience, large projects take som time to import and one can get the impression that everything has freezed.

Likes

Translate

Translate
Explorer ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

The work around I have been using is to open a new untitled project.  Once it opens, I can either click "command + O" (mac) from premiere pro and navigate to open the project I want to open.  It opens up just fine and I close the untitled project and continue to work.  Or...once I have opened an untitled project and PP is open...I go over to my drive and double click on the project I want to open and it opens in PP just fine.  Then I have to go close the Untitled project so that I don't have two projects open at the same time while I'm working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

No "importing" into new projects needed.  Just open an untitled project.  Once the new untitled project is open...leave it open while you go double click on the project you were having trouble opening.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

Thanks!

I finished the bugged projects using a work around and strangely (or
rather, luckily) the problem hasn't appeared on any of the new projects
I've started since. I'm still not sure what actually caused the problem.
I'm just glad I don't have to deal with it anymore.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

I have been able to open projects in Beta 14.8.07 that won't open in release version 14.6.

Other remedies posted here haven't helped me.

 

(Mac OS 10.15.7)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

This work-around doesn't seem to work for me in the latest betas. But I've found I can open some projects using the auto-save backups.

 

Kind of an alarming situation, I must say.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

The "solution" for me was to switch off my external display in Preferences.

What on earth is that about?  My external display is used to proper color match my edit rather than use the rubbish Apple display I use for the timeline and tools.  

 

I thought Premiere Pro was a professional tool? I had no idea it was aimed at the amateur market.

 

Must be an Apple-Adobe mismatch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

No - I have this problem on windows with no "external" monitors (I don't use a laptop so techincally ALL of my displays are external, but I do not use Mercury transmit or any other such device to get external video playback)... so I doubt it's an apple thing at all. This is an Adobe problem, straight up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

I thnik I've found a solution that doesn't involve turning off merury transmit or creating a new project as a workaround. After going through preferences line by line I cam upon the "Restore open sequence when opening projects" option in the Timeline section. I unticked it, closed out of Premiere, launched it again and was abkle to access projects again without having to do either of the work-arounds mentioned in other posts. Give it a try and let me know if you the same success. It would be scary if it was that simple. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

Sadly, that makes no difference for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

But, the latest Beta does!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

This actually worked for me as well with this particular issue. Although today's battle was with Izotope audio plugins not letting projects open in v14.6 and v14.7. I ended up downgrading to v14.0 and now everything seems to be at least useable. Yikes. Out of the frying pan, into the fire. At least current project files will still open in older v14.x versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

Just have to thank you for posting this - almost a year ago! I have been having the same issue recently and this just worked for me. I have no idea why I only began having the problem this month when it looks like many have experienced the issue far longer... but very thankful this ended up working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Hi, fourwindfilms,

Sorry. What happens when you try to open the projects? Do you get the SBOD (spinning beach ball)? Or, do you get a warning dialog box indicating a crash? If the latter, can you share the crash report with us? 

 

Thanks!
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Screen Shot 2022-04-27 at 7.33.32 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

LATEST

I have shared the crash report each time it crashes, how do I share it with you on this thread?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

This worked for me, thank you for the fix. I am on the latest version 2022 and still it seems to be a problem for so many. I have tried everything under the sun...and then this. So happy I don't have to keep importing my project as sometimes I get up to version 20 and its a bit of a nightmare. Legend!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

I've experienced the same issue this morning, I can't open any of my old projects. I trashed the app and reinstalled that didn't work. However disabling Mercury transmit before opening any projects has just worked for me!  Please Adobe can you fix this bug?  thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 25, 2020 Dec 25, 2020

Copy link to clipboard

Copied

Try uninstalling any third-party plug-ins to see which ones are the problem. Then make sure you have updated to the most recent Adobe PPro version and the latest macOS update. Try also downloading the most recent version of third party software before reinstalling as well.

 
Christopher Wright

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 01, 2021 Jan 01, 2021

Copy link to clipboard

Copied

Having the same issue. On a 16in MBP. Support had me uninstall PP and reinstall. Did not fix the issues. Projects will open fine on other machines but struggles on this 16in. Turning off mercury transmit only fixes the issue 50% of the time. Can it be a bug with the type of footage? We typically cut on MXF files out of C300 MKII cameras.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

I'm having the same problem. Apologies, but I find this quite ridiculous. I'm running Prem Pro off a new Mac Pro with 96 gig RAM, and it won't open multiple projects?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

For what it's worth- the beta build allows me to open my projects. Has a lot of glitches because it's a beta but at least I can work!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

I've been having luck with the beta opening projects for me as well...although the notes for the beta make no mention of this problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2021 Jan 10, 2021

Copy link to clipboard

Copied

I am having this problem for 3 MONTHS now. Adobe Premiere is NOT reliable any more, especially version 14.
The NEW project I created in a newest version TODAY just doesn't open. IT happens everyday. The blue bar just hang there.
Adobe! THIS IS NOT ACCEPTABLE!! FIX THIS BUG!

Window 10 Pro, Intel Core i7-9700KF CPU @ 3.6 GHz, 8 Core, 64GB RAM, NVDIA GeForce RTX 2070 Super

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 10, 2021 Jan 10, 2021

Copy link to clipboard

Copied

If you haven't tried the beta, give it a shot. Working well for me and this project opening issue has not popped up in the beta.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 11, 2021 Jan 11, 2021

Copy link to clipboard

Copied

Yep, I agree it's annoying. If you're not willing to use a beta version, use the Adobe Creative Cloud app to uninstall 14.7 and roll back to 14.3.2, as suggested earlier in this thread. It works fine and allowed me to open the projects that were freezing. The fact that the beta version works gives me hope that I'll be able to get back to a current version when the next release arrives.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines