Delays on timelines when starting playback with a Blackmagic I/O device attached

New Here ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Dear reader,

 

Already for several years now I've experienced short playback delays when starting playback from a timeline on systems that have external I/O devices from Blackmagic Design. We are sending out a full screen video signal through Mercury Transmit to Blackmagic Design Mini Monitors hooked up to an external display. We are set up as Blackmagic Playback in the playback preferences pane. Audio is sent through adobe desktop video. Computers are mostly high-end 27 inch iMacs.

 

When starting playback it always gives us annoying slight delays before the timeline responds. (Either when starting by JKL or Spacebar shortcuts) If you switch off the blackmagic playback or switch it to a direct Desktop video monitor output instead, everything is significantly more responsive for starting playback.

 

Over serveral years the problem has been consistent on different versions of Premiere Pro and/or the Blackmagic Desktop Video drivers. I'm currently on the latest versions of both. I know it is likely idle hope, but has there ever been a solution or optimization for this problem?

 

I ask before expanding our other setups with even more BMD devices and external monitors. SInce it is also the only reliable solution for sending color accurate video output to an external monitor, I'd absolutely love to see improvements here. Are other devices or brands of I/O devices a solution for anyone? Can any of the engineers or Adobe people chime in on this?

 

Thx a bunch!

TOPICS
Editing, Hardware or GPU, Performance

Views

119

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Is the delay ~ half a second? That's been my experience using AJA IOXT devices. Our editors have just gotten used to the "delay" to the point they don't notice it anymore. I'm not sure if there's a "fix" for this, it might just be how it is.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Yes, half a second is definitely not an exception. I'm still hoping for a miraculous update one day at either Adobe's or BMD's side. But it is also my guess, given the years of troubles already, that it "is just the way it is". A bummer since other apps like Avid or Resolve don't share these issues.

 

My hope for this thread is to create awareness again or to find a hidden gem of information somewhere. As I can expect there are a lot of people using external displays this way and who are experiencing this behaviour.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Not much help but I'm on a PC using BM Decklink Studio 4k and have no delay at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

LATEST

I use the Intensity Shuttle USB and Thunderbolt version and have no delay. I did notice performance issues once and installing the ASIO4ALL drivers solved the stuttery issues. It was only a one time issue. I think the BMD driver download had issues more than anthing else. Having said that if you are using the BMD product for video output and the desktp for audio output ASIO for all might help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines