Premiere Pro 14.8 (and QT player): no playback (but Resolve plays back fine)

New Here ,
Jan 22, 2021

Copy link to clipboard

Copied

Okay, this issue is really confusing to me. I suspect it's not a Premiere issue, but maybe some brilliant souls here can figure out what's going on.

 

I'm running PP 14.8 on my iMac retina (specs below). When I load a project I can scrub through footage, but can't play back. The play button is active, but no scrolling, no audio, nothing. I've tried this with multiple projects and multiple video file formats (pro res 422, pro res proxy, h264 of various flavors). Same issue. THEN, I tried playing back the same files in Quicktime player. Same problem! They load, I can scrub, but no playback. And THEN, I tried loading up a duplicate batch of footage in Davinci Resolve 16.2...perfect playback. What? I also have a Macbook Pro, running the same OS as the iMac, and I opened the PP project on that system and it plays back just fine.

 

Anyone ever encounter this sort of thing?

 

Specs:

PP 14.8

iMac 5k Retina

Mojave 10.14.6

4ghz i7 processor

32gb ram

AMD Radeon R9 4gb

TOPICS
Editing, Error or problem, Performance

Views

35

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation