Highlighted

Video Limiter producing illegal broadcast levels

Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

I'm currently involved in a Avid-offline/Premiere-online workflow and we are consistently running into the same problem with the Premiere Video Limiter.

 

Captions and subtitles generated in Premiere are producing illegal sub-blacks and excessive-whites. This is despite setting the Premiere Video Limiter to conservative values. They look fine when viewed in the Premiere scope, but are illegal when they are viewed during the QC process.

 

Although I'm not involved in the QC process, this is what I'm being told is happening: Premiere is tagging our exports as "full range". This means that even if Premiere thinks it's producing legal values, when the exported file is viewed elsewhere, these legal values expand out and become illegal.

 

I admit I don't fully understand this, but does anyone here have experience with this problem and can advise me how to avoid Premiere producing these "full range" exports?

TOPICS
Effects and Titles, Export

Views

146

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Video Limiter producing illegal broadcast levels

Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

I'm currently involved in a Avid-offline/Premiere-online workflow and we are consistently running into the same problem with the Premiere Video Limiter.

 

Captions and subtitles generated in Premiere are producing illegal sub-blacks and excessive-whites. This is despite setting the Premiere Video Limiter to conservative values. They look fine when viewed in the Premiere scope, but are illegal when they are viewed during the QC process.

 

Although I'm not involved in the QC process, this is what I'm being told is happening: Premiere is tagging our exports as "full range". This means that even if Premiere thinks it's producing legal values, when the exported file is viewed elsewhere, these legal values expand out and become illegal.

 

I admit I don't fully understand this, but does anyone here have experience with this problem and can advise me how to avoid Premiere producing these "full range" exports?

TOPICS
Effects and Titles, Export

Views

147

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 04, 2020 0
Adobe Community Professional ,
Oct 04, 2020

Copy link to clipboard

Copied

Which format/codecs are you using? Perhaps as it's an Avid/Premiere workflow some form of DNxHD/R?

 

There are some Lumetri presets in the Lumetri Presets/Technical folder that are for legal to full or full to legal conversions. The LUTs used are found in the Program/Package folder for Premiere, Lumetri/LUTs/Legacy. The full to legal ones are all "FullToSMPTE ..." and in 8, 10, and 12 bit versions listed there in the name in the folder.

 

You could try adding Full to Legal in Export options dialog Effects tab, and see if that clears QC.

 

 

 

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 1
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

Thanks, Neil.

 

In the most recent delivery that failed QC, the files ingested into Premiere were Quicktime/codec: ProRes. Then the final master exported from Premiere was an MXF/codec: AVC-Intra 100.

 

I'm not the Premiere editor (I do the Avid offlines) but I'm trying to help get to the bottom of what's causing the problem. So I'll ask the editor what settings he's using in his Export dialog.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Adobe Community Professional ,
Oct 04, 2020

Copy link to clipboard

Copied

I modded my earlier answer to add the location for the Full/Legal and Legal/Full LUTs.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 1
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

Great. Very helpful.

 

Thank you, Neil.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Adobe Community Professional ,
Oct 04, 2020

Copy link to clipboard

Copied

I'm not getting it in the 14.x versions, but in some earlier ones I could at times get a problem with super-darks and ultra-whites with text, normally if any sharpening was applied in the image.

 

Also, are they applying the Limiter preset to the clip, to an adjustment layer over the sequence, or in the Export dialog's Effects tab?

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

I'm pretty sure that the limiter is being applied on an adjustment layer. Is that not advisable? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Adobe Community Professional ,
Oct 04, 2020

Copy link to clipboard

Copied

I was just curious how they were doing it. I would suggest also trying the option in the Export dialog itself.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Guide ,
Oct 04, 2020

Copy link to clipboard

Copied

when in doubt, use the tried and true method. one adjustment layer set to luminosity with levels 16-235

and another adjustment layer on top set to 'color' with levels 0-240.

this preset has been downloaded over a thousand times!

https://f1.creativecow.net/10774/premiere-pro-cc-20152-broadcast-safe-preset

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

Thanks, @chrisw44157881. However, the problem is not that levels are illegal in Premiere, but that they are illegal after export. So I'm not sure that swapping one sort of adjustment layer for another is going to make any difference.

 

Just to clarify: in Premiere levels are looking fine and dandy. But once the file is exported file it is being tagged as "full range" and this is pushing what look like legal levels inside Premiere to illegal levels when viewed during QC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Guide ,
Oct 05, 2020

Copy link to clipboard

Copied

perhaps the MXF/codec: AVC-Intra 100 is being exported full range because premiere interprets Prores as video levels, but AVC-100 as full. Try exporting from media encoder to Prores and using another encoder to get from Prores to AVC-100. Adobe Media encoder doesn't have a way to manually set legal vs full afaik. and Adobe's limiter plugin may have a bug on export, so see if manually clipping it makes a change too. I know shutter encoder supports AS-11 format in AVC- intra100.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 1
Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

That's an interesting thought. Thanks, yes, I'll look into this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Adobe Community Professional ,
Oct 05, 2020

Copy link to clipboard

Copied

And again, have them try the limiter in the Export tab and also try applying the full to legal LUT I posted about in the Effects tab of the Export dialog.

 

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 1
pulck LATEST
Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

Will do. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0