Text disappears when typing in text box

Community Beginner ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I'm getting this issue where when I make any changes to text within a text box, like typing within it, cutting/pasteing, editing, etc. the text disappears. Sometimes it'll come back if I click out of the text box. Sometimes it comes back if I switch between normal and preview mode.

 

It doesn't happen every time, but often enough to be incredibly annoying.

 

I'm running:

  • Mac OS 11.4
  • Macbook Air M1 2020
  • InDesign 16.2.1
TOPICS
Bug

Views

29.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 6 Correct answers

Adobe Employee , Feb 08, 2022 Feb 08, 2022
Hi all,  Sorry for the trouble this issue has caused. I understand how frustrating it is. Our engineers are working hard to fix this as soon as possible.  It is hard to believe that the issue is not fixed even after multiple user attempts. I can definitely assure you at it's a work in progress.   @roberteblesse I will try to answer all the questions in the best possible way. This issue is completely dynamic. There are different scenarios where users are facing this issue. We have worked with m...

Likes

Translate

Translate
Adobe Employee , Mar 02, 2022 Mar 02, 2022
Hi @Twall55, Please click this link (www.adobeprerelease.com/) and go to the "Available Program" section to join the InDesign prerelease. Then accept the Prerelease agreement and follow the steps mentioned below to install the prerelease v17.2.0.9: - Close InDesign - Go to Creative Cloud Desktop and look for Prerelease in the Apps section. (If you don't see it, then please check you are login with the same email ID you have signed in on the Prerelease website. If it still doesn't show up, t...

Likes

Translate

Translate
Explorer , Mar 08, 2022 Mar 08, 2022
Install the 17.2 pre-relase. It has worked well for me on a 2020 M1 MacBookPro! See instructions posted above or see the tips I posted above that helped with 17.1.

Likes

Translate

Translate
New Here , Mar 16, 2022 Mar 16, 2022
Finally!!! I installed the prerelease (17.2) and the bug that persisted for far too long has finally disappeared. After 9 months of hard work, I was finally able to do one day of layout without any bug. A real miracle!

Likes

Translate

Translate
Engaged , Mar 23, 2022 Mar 23, 2022
Not only did 17.2, reased this morning to North America, fix the text issue, it's also screamingly fast, especially opening files.OK, done. NEXT!

Likes

Translate

Translate
New Here , Apr 20, 2022 Apr 20, 2022
Hi Sarah, updating to 17.2 fixed the text issue for my wife. She hasn't had it happen once since then, so far.Have you updated?

Likes

Translate

Translate
replies 630 Replies 630
Explorer ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

I don't have the problem anymore since I bought a MacBook Pro 14" with 10 GPU

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

I'm having this problem, even tho I followed instructions with font book validation and updating to 17.0.

 

I'm running:

  • Mac 12.0.1
  • iMac M1 2021
  • InDesign 17.0

 

Is anyone else still experiencing this? It's making it very difficult to do any work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

Yes unfortunately. And i have a t2 chipo. Nothing works. Bloody annoying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

Could be that old fonts such as PostScript Type 1 fonts cause problems. Adobe already planned to stop support for these. I don't have the issue on a Macmini 16Gb RAM - 512 ssd. I only installed quality, and relatively recent OTF font. No TTF and no s.h.i.t.t.y free fonts. So far so good.

So solutions here but this could be the cause. Try removing dodgy fonts and emptying font cache.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

This is bullsh.. The problem acures also with OTF even with an clean font cache.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

Well, I never had the problem with that Macmini so far.
Good luck finding a solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

The problem is not the fonts. I've recently purchased two iMacs, one for
the office and one for home, and installed InDesign from day one on each.
Each computer uses different fonts and files, being one only Helvetica and
the second Gill Sans. So no dodgy fonts whatsoever.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

The issue of clean or dodgy font files misses the forest for the trees, I think.

 

Our fonts don't cause this issue with any of our other software packages (correct me if I'm wrong) only InDesign. Not Illustrator, or Photoshop, or After Effects, or any other Adobe software that manipulates type. (Adobe TypeKit fonts also disappear, and surely it doesn't get much 'cleaner' than that...)

 

Only InDesign has this issue, and I think the biggest frustration, apart from it not being resolved after the best part of a year, has been the absence of any direct acknowledgement of the problem or communication with the user base to let them know if there is any progress being made toward a solution, or what that progress looks like, or even an admission that this is a fundamental problem with InDesign that will take significant time and resources to address.

 

Something within InDesign simply doesn't play nice with M1 macs, and I don't think it's unfair for subscription-paying professionals who rely on this industry-standard software to expect more in the way of an explanation, or progress toward a solution.

 

To me, this feels like being given a sticking plaster/bandaid for my internal haemoraging. InDesign users are currently bleeding time and money...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

I spent an afternoon going over every setting possible. I just had to find a solution. Or start working ourselves towards a fix 🙂 

 

I found that activating 'Overprint View' removes the issue completely for me. No more disappearing text. If I play around with the 'Flattener preview' options the bug also seems to  disappear. So at Adobe, please have a look at how text is drawn on the screen? Or the transparancy. I don't know. It's probably not the font. I tested it in all kind of documents and everytime I turn on 'Overprint View' it's 'solved'. I still have to see it in action working on long documents for an extensive amount of time, but at the moment it seems to work. Does have an impact on performance. And colours are 'weird' when working on RGB documents of course. And I don't like to work where I don't see the bounding boxes etc... But for making hundreds of text corrections, without loosing my mind, it seems a good fix for now? Let's hope.... to be continued

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

You are right. I tested it and if i switch it off problem starts immediately. Swith it on and its okay. Brillant man

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

This is so frustrating!  I am not on a Mac and I'm not having success.  I'm working on a 320 page book and I'm stuck on page 15. I turned off Overprint Preview (It is different on a PC???) but it still doesn't show the text. When I go to Story Editor, the text is there, but it says it is overset.  When I look for the overset button, it is not there.  All the pages are threaded, but NO TEXT shows.  I am at the end of my rope on this, as I had gotten to the end of the document and just went in to change one font.  The author had done a TON of formatting in Word, which I was trying to undo by reassigning styles (varied indents and line spacing -- poets!)

I just want the text to reflow. Any advice?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Hi ConciergeMarketing,

your issue is something entirely different to what is discussed here in this long thread.

Overset text is not the topic here.

 

I suggest that you open your own discussion.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

Congierge you turned overprint preview off, it should be on. (see andersmak contributiion.) Maybe make an idml and try again (maybe in older version of Indesign? With me usually scrollling up and down resolves the issue. I get your frustration. I had the same with a 600 page book. Took days to correct it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

I've turned it on and off and on and off for 2 days. Tried everything except the idml. That didn't work either. Thank you so much.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

Turn off your mouse and keyboard. And turn off your computer. Uninstall Adobe. Worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

@ConciergeMarketing  Select all the text and check that No Break is on or keep with next/previous paragraph is on. Message me if you can't figure it out.

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

I wasn't getting it before, but now I am after I just updated InDesign.  It only happens on my M1 iMac, not my M1Max. 

 

M1 iMac running 12.1  16GB Ram, 2TB drive. 

InDesign version 17.0.1

 

Works fine on my M1 Max Macbook Pro (24 Core GPU, 32GB Ram, 2TB Drive) running 12.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

It's now December and still no fix?   Everything suggested so far is a temporary fix and the problem comes back.  Not just sometimes - all the time.  Every single time I type in a text box, it goes invisible until you nudge it left or right.  Then returns until next time you type.  Cost per month of this program in a professional setting is killing my business!  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 22, 2021 Dec 22, 2021

Copy link to clipboard

Copied

Unbelievable this, its been 6 months and theyve still not fixed it - im resorting to using illustrator more than InDesign now on my M1 MacBook! Im dreading upgrading my intel imac to the M1s now as InDesign is my daily driver - can you imagine having this isuue when designing 100 page + reports!! I might give Adobe a call and see what they say - better than ghost typing!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 22, 2021 Dec 22, 2021

Copy link to clipboard

Copied

Agreed. As much as i have enjoyed leveling up on this community forum, i think it's time we take it to the higher courts. We need to call, email, and submit support tickets directly from our Adobe $$$ subscription accounts. It's clear this community forum is just that, a community forum. This is not going to attract their attention. But if you call your support agent and threaten to cancel your subscription, i think the response will be heard.

 

I'm contacting Adobe now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

A post earlier in this discussion had a helpful tip - not a fix - but a way to refresh (redraw) the text without zooming or scrolling. The quick keys to refresh the text are Option - Command - /. I've found this to be more conventient usually, and that as time goes by working within a document, that my text issues decline.

 

Adobe, fix this problem. I'm already moving on to Affinity Designer. As soon as I'm comfortable moving my clients, I'll be cancelling my Adobe pay-through-the-nose subscriptions for our tiny agency.

 

Happy holidays everyone!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

This will speed things up a little - so thank you.  Yes, it should have been fixed by now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Thanks John. I'll give it a go. This is a huge flaw on Adobe's part. Disappointing to say the least that they haven't addressed it. I'll look into Affinity Designer as well. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

Hey guys, 

I think I might've found a solution. I deactivated all the fonts on Adobe. Initial running of Indesign looks promising, with the issue not occuring for some time now. Would love to hear if indeed this does help the problem. 

Cheers,

Vinny

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

A workaround, not a solution. I'm over it. Been using Affinity Publisher.

Keep us posted on how it works out for you, long-term.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines