P: Slow walking between photos in Loupe view

2 Votes
Explorer ,
Jul 03, 2022 Jul 03, 2022

Copy link to clipboard

Copied

I've been noticing a big performance decrease after updating to 5.4 both my iMac Pro and MacBook pro with M1 Pro CPU. 

After I open the app and start working in the beginning everything is alright, snappy and quick. After a while (5-10 min or less) I experience slow loading of photos - when switching from one to another; when zooming and when switching panels. Sometimes this lag is around 3-4 sec which is very noticable. The GPU is doing its thing because the graphics are not choppy, but there's just a delay in doing the above mentioned processes. 

Anyone else experiencing such issue on Mac?

Bug Investigating
TOPICS
macOS

Views

259

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jul 15, 2022 Jul 15, 2022

Log received - thank you. 

Status Investigating

Votes

Translate

Translate
16 Comments
Community Beginner ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Same problem here on an M1 Pro. It's absolutely horrible. Nearly unusable due to how slow it is.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Same issue on both of my PC's. Severely affects the work flow.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

The engineers have asked if you can open Activity Monitor as you use LrD and monitor what is consuming resources. 

A video screen capture showing LrD side by side with the Activity Monitor set to its Memory Tab would be a big help. 

 

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Here's my system info: 

Lightroom version: 5.4 x64 [ 20220607-0605-ab0fd72 ] (Jun 7 2022)
NGL Version: 1.29.0.5
WF Version: 4.4 89b063a
VF Version: 1.0.111
HIL Version: 40405
Operating system: macOS
OS Version: macOS 12.4 (21F79)
Application architecture: x64
Computer model: iMacPro1,1 / Intel(R) Xeon(R) W-2140B CPU @ 3.20GHz
Logical processor count: 16
Processor speed: 3,2 GHz
Built-in memory: 65 536,0 MB
Real memory available to Lightroom: 65 536,0 MB
Real memory used by Lightroom: 14 476,7 MB (22,0%)
Virtual memory used by Lightroom: 35 965,3 MB
Memory cache size: 16 126,1 MB
Internal Camera Raw version: 14.4 [ 1121 ]
Maximum thread count used by Camera Raw: 9
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 10626MB / 32767MB (32%)
Camera Raw real memory: 0MB / 65536MB (0%)
Displays: 1) 5120x2880

Graphics Processor Info: Metal: AMD Radeon Pro Vega 56 - 8 GB
Graphics Processor Detail: loaded: Yes, supported: Yes, compute: Yes, init: I4_GPU3, hard: success, soft: success, al: Yes, dl: No
OS Media Capability: true

Application Folder: /Applications/Adobe Lightroom CC
Settings Folder: /Users/stef/Library/Application Support/Adobe/Lightroom CC
Library Folder: /Users/stef/Pictures/Lightroom Library.lrlibrary

 

 

And here are the videos. I have made 2 - once with the memory tab and one with the cpu tab.

https://www.icloud.com/iclouddrive/08b7cM2xRWZpQHzx8R3Fxto5Q#Screen_Recording_2022-07-14_at_20.02

https://www.icloud.com/iclouddrive/065wTkG1z3LdG8HbG4HeLWfXw#Screen_Recording_2022-07-14_at_20.05

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Thanks - those were helpful.

 

Questions from engineering:

1) Ask if there is new hardware? i.e. New monitor. The specs say the resolution is 5120x2880
2) If this degradation is new to 5.4 (i.e. were earlier releases ok)?
3) The next time the performance problem occurs, have the customer generate a diagnostic log immediately after the degradation.
4) Do you have a lot of presets? Estimate for how many you've used/installed?

For LrDesktop Diagnostic Log

  • Go to Preferences
  • Account Section
  • Hold down the [Opt/Alt] key to make [Diagnostic Log] button appear.

Let me know when you have the log ready to ship to us.

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

1) no new hardware. I use the built in screen of the iMac Pro. But this performance decrease also happens on my Macbook Pro 14" with M1 Pro chip. 

2) Earlier releases were fine. Problem appeared immediately with 5.4. 

3) I have generated the log.

4) I have 400 presets. But I had them in previos versions prior to 5.4 and no performance issues. 

 

I am ready with the log file. Should I attach it in a post here? 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Thank you.

Share the log via Dropbox/Creative Cloud or similar.

If you don't want to post the link publicly, you can direct message me via the forum with the link. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Same issue here. workflow has slowed to a crawl.
Is there a way to roll back to 5.3?  I am unable to get any work done.

Votes

Translate

Translate

Report

Report
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Same problem.

 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

I wonder if this is a similar issue with what I am having. I have an issue due to the high (around 400 like you) number of presets, for me it starts to happen the second I open the presets menu.

 

Could you try to disable your presets from the Manage Presets menu then try and see if you are having these performance issues?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

Log received - thank you. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Investigating

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 16, 2022 Jul 16, 2022

Copy link to clipboard

Copied

Yes, this is certainly related to presets. If I never open up the presets menu, Lightroom behaves normally. Once I open it and scroll through a few preset previews, it slows to a crawl and will stay slow until Lightroom is rebooted.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Have the engineers identified the cause of this bug?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

Is this fixed in Lightroom 5.5?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

@EGingras I just tested and still having this problem. Luckily I have my iPad so I can at least work on things. Hopefully we get a fix at some point.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

LATEST

agree that the problem is releated to presets. Slowdown begins after using Recommended Presets and persists until restarting LR. Avoid recommeded presets and LR functions normally.

Votes

Translate

Translate

Report

Report