• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
10

P: Extra rulers appear on image when moving Photoshop from one monitor to another

Explorer ,
Jan 15, 2022 Jan 15, 2022

Copy link to clipboard

Copied

 

Bildschirmfoto 2022-01-15 um 12.47.45.png

 

Does anyone get this weird ruler placement in PS 2022?

 

 

[Subject edited by moderator. Was "Ruler tool is not working..."]

["PH" edited to "PS" for "Photoshop"]

 

Bug Acknowledged
TOPICS
macOS , Windows

Views

4.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 24, 2023 Feb 24, 2023

An update to rulers was made in the 24.2 release that should resolve this issue.  Please install the update and give it a try. If you previously checked the “Deactivate Native Canvas” checkbox in Preferences > Technology Previews… uncheck that box and restart photoshop.

Thank you

Votes

Translate

Translate

correct answers 1 Pinned Reply

Adobe Employee , Oct 18, 2022 Oct 18, 2022

Engineering is looking into this issue.

Status Acknowledged

Votes

Translate

Translate
41 Comments
New Here ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

Photoshop 23.1.0 - A second vertical ruler appeared at 30 inch mark; cannot move it. how to get rid of it without losing the two basic rulers?

RTKnud_0-1640801007277.png

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

@RTKnud 

 

Try going to Window menu > Workspace > Reset [Current] Workspace and let us know if that works.

 

Jane

Votes

Translate

Translate

Report

Report
New Here ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

Seems to have disappeared with a seconc Photoshop re-start

Votes

Translate

Translate

Report

Report
New Here ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

Thanks.  I saw that in another problem post and had tried it, to no avail.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Hello,

 

I'm not certain if this is a new feature I'm unaware of or a bug. However, when I use Photoshop 23.0.0 on my Macbook Pro (OS 10.15.7) a second set of rulers pops up (image attached). They go away if I shrink the viewable window to something pretty small, but obviously that's super convinient. These rulers also go away completely if I plug into a secondary monitor. It only seems to happen when I use the laptop on it's own.

 

Thanks in advance.

 

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Hi

Have you tried updating to version 23.1, that's the most recent version, something to try, enabling this option in preferences and restart Photoshop to see if it helps

2022-01-05 17_10_21-Adobe Photoshop 2022.png

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

Is this a bug? It keeps happening on my version of photoshop (which is up to date right now) and I have to hide the ruler in order to get it to go away. How do I fix this?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Hi there,

Sorry to hear that. Which version of Photoshop are you on? Could you try resetting the preferences of Photoshop and see if that helps? 

https://helpx.adobe.com/photoshop/using/preferences.html

 

Note: Make sure that you back up all your custom presets, brushes & actions before restoring Photoshop's preferences. https://helpx.adobe.com/photoshop/using/preset-migration.html


Regards,
Sahil

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Assuming you are using a recent/current Photoshop version, display issues can often be fixed by deactivating Native Canvas in Preferences.  This is unchecked by default, so resetting Preferences would not have helped if this does turn out to fix your issue. 

image.png

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 15, 2022 Jan 15, 2022

Copy link to clipboard

Copied

@Sonofmidgard 

 

I've branched your post from an unrelated thread about measuring with the ruler tool. I don't know why this is happening, but I have seen a couple of posts with similar screenshots. In this thread the OP restarted twice and that fixed it. Can you try that?

https://community.adobe.com/t5/photoshop-ecosystem-discussions/second-vertical-ruler-appeared-won-t-...

 

Jane

Forum volunteer

 

Votes

Translate

Translate

Report

Report
Participant ,
Jan 15, 2022 Jan 15, 2022

Copy link to clipboard

Copied

Hi man,

Seems to be the same as before - good for measuring length, and an angle
reader which acts like a protractor.

Draw a line by click and drag. Draw a second line from the second point
created in the first line, holding control. Now you have two lines and one
angle, both displayed on the Options bar at the top.

There is some literature around if you need help. Never really use it that
much, but sometimes an angle or length is necessary!

Regards,
Richard

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

@Sonofmidgard 

 

First: Restore your preferences using this manual method:
https://helpx.adobe.com/photoshop/using/preferences.html#Manually
Does it work correctly?
If that doesn't solve it, you can quit Photoshop and put the Settings folder back.
If it does solve the problem, I would like to get the folder of settings to try and figure out what is bad with them.

 

Second, if restore prefs doesn't work: Go to Preferences > Technology Previews... and check "Disable Native Canvas" - then restart Photoshop. Does the problem still occur?

Votes

Translate

Translate

Report

Report
New Here ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

The screen shot is self explanatory. On my M1 MBP I have a converted PSD file with artboards that the rulers will not position where they are meant to be.

 

Any suggestions?

 

Screen Shot 2022-01-18 at 7.58.56 am.png

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Please go to Preferences > Technology Previews… and uncheck the “Enable Native Canvas Rulers” checkbox.  Then restart Photoshop.  Thank you.

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Please see the attached screen grab. I don't know what happened to cause this. The rulers are crossed in the window. The usual rulers are still on the left and top of the window. Do I just restart my machine? Or is this some kind of feature I've never seen before and can reset?

 

Screen Shot 2022-01-21 at 4.34.05 PM.png

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Problem solved. Not so much solved as disappeared. So apparently something just glitched out. I restarted Photoshop and it was still there, which was when I posted. Restarted a second time and it was taken care of. Sorry for wasting people's time.

 

Rob

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Apparently I'm not done wasting people's time. Because the problem is back. I've restarted my machine. What do I do next? Restart Creative Cloud? Find some plist to delete? This has just ended my progress on work that was due weeks ago that was just about to get done.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

That's not normal. I've never seen that in all the years I have had Photoshop.

 

Here's  a few things to try:

Use a different Workspace. Try "Essentials".  Window > Workspace > Essentials  If it is already chosen, then select "Reset Essentials." If you are using your own custom workspace, try resetting that as well.

 

Under Edit > Preferences > Technology Previews, checkmark "Deactivate Native Canvas." Restart Photoshop.

 

And finally, it may be due to a corrupt settings file. You would need to Reset Preferences:

reset prefs 2020.png

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

@Rob the Slob 

 

Others are also reporting this issue of "ghost rulers" and the engineers are aware of it. See this thread and upvote it in the upper right.

https://community.adobe.com/t5/photoshop-ecosystem-bugs/p-ghost-rulers-appear-in-middle-of-image/idi...

 

One solution there is to go to Preferences > Technology Previews > uncheck the “Enable Native Canvas Rulers” >  restart Photoshop. Tell us if that works.

 

Jane

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

Before getting this reply, I tried in order: restarting Photoshop (twice), restarting the machine (once), and finally, uninstalling Photoshop and re-installing. For all my complaints about CC moving to a subscription model, it has made the last option much less involved, if rather drastic . . . but that seems to have fixed it. I've turned off "Enable Native Canvas Rulers."

My case may be related to connecting to and disconnecting my MacBook from an auxiliary display, which moves windows around in all apps. I don't know, just the wildest guess. Praying very hard this doesn't come back, because I really don't have the time right now for tech glitches.

Thanks very much, jane-e and gener-7, for the replies.

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

I asked about this in a separate thread here just yesterday. Wish I would have found this one first (I did search around before posting).

 

Anyway, I ended up uninstalling and re-installing Photoshop, a rather desperate solution that did work.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

You're welcome, @Rob the Slob .

 

Jane

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Thank you for reporting the issue.  We have been able to reproduce in-house and a bug has been logged.

In the meantime, the best way to avoid the issue is to go to Preferences > Technology Previews… and uncheck the “Enable Native Canvas Rulers” checkbox.  Then restart Photoshop. 

Votes

Translate

Translate

Report

Report
New Here ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

Hello folks, 

 

I'm attaching a screenshot here to explain what's happening with the rulers in Photoshop (Up-to-date).

This has been the case ever since I upgraded to the new Macbook Pro 16 with the M1 Pro chip.

It's only happening on my external 27" monitor. It seems the rulers keep the dimensions of the Macbook screen.

 

Would truly appreciate any help on how to fix this.

 

Thanks in advance!

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

Hi

Try disabling this option in preferences and restarting Photoshop to see if it helps

2022-03-25 10_18_32-Preferences.png

If that dosen't help try enabling Deactivate Native Canvas again restart Photoshop

Votes

Translate

Translate

Report

Report