• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
22

FAQ: How to fix saturated/over-exposed HLG/HDR clips in Premiere Pro v.22

Adobe Employee ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

With Premiere Pro v 22, new features around color management for H.264 and HEVC have been introduced. This FAQ will show you how to fix clips that appear overexposed or oversaturated due to these new features. Caution: iPhone shoots HDR by default. 

 

  • In case you don't want or need the HLG/HDR workflow and want to return to the standard workflow, please follow these steps to avoid oversaturated and overexposed previews.
    - Right-click on your media in the Project panel.
    - Select Modify > Interpret Footage > Color Management.
    - Set Color Space Override to Rec.709.
    - Sequence > Sequence settings, set Working Color Space to Rec. 709.
    Color Space Settings.jpg

 

  • In case you do want to edit & deliver in HLG/HDR, please follow the steps mentioned below. Also, see R. Neil Haugen's in-depth article for the full pro workflow: Premiere Pro 2022 Color Management for Log/RAW Media
  • Turn off HDR shooting on your iPhone by following the directions here. This allows you to return to a standard iPhone workflow.

So why do HLG files look saturated/over-exposed in Pr v 22?

In the previous version of Premiere Pro (v 15.x), HLG media was treated as Rec.709 & the sequence created from that media also used Rec.709 color space.


In Premiere Pro v22, H264 and HEVC are color managed, and the HLG media is treated as Rec.2100. So a timeline created from HLG media in v 22 will automatically be assigned HLG color space.

 

However, in v 22 opening a project created in the previous version (which had HLG media on Rec.709 timeline) results in HLG to Rec.709 conversion. This causes the clips to look saturated/over-exposed in the newer version of Premiere Pro.

 

Note: This only happens with projects (HLG media + Rec.709 timeline) created in the previous version. Newer project files will have the appropriate color space assigned and will show the correct preview.


How to solve this issue in v 22?
You may manage the color space of the entire timeline made from HLG clips.

  • Highlight the sequence & navigate to Sequence > Sequence settings.
  • Under the Video tab, set Working Color Space to Rec.2100 HLG.SumeetKumarChoubey_0-1635772126435.png

You may also color manage individual media files.

  • To do so, right-click on the HLG file in project panel & navigate to Modify > Interpret Footage. 
  • Under Color Management, set Color Space Override to Rec.709. This will create a preview that matches the color of Premiere Pro v15.x.
    SumeetKumarChoubey_1-1635772218241.png

How to correct saturated/over-exposed previews during H.264/HEVC export?

If you have edited in an HLG timeline & would like to export in HLG, please ensure that you use the following export settings.

  • Select your Format as H.264/HEVC.
  •  Navigate to Video tab > Encoding Settings.
  • Set Profile to High10 (for H.264) or Main10 (for HEVC).
  • Set Export Color Space to Rec.2100 HLG.
    Export Settings.jpg
  •  

 

 

 

 

 

 

 

 

 

Please note that the Match Source presets use Rec. 709 color space & might result in an incorrect preview if used to export a sequence based on Rec. 2100 HLG color space.

 

For the full HDR broadcasters workflow, see this page in the Premiere Pro User Guide.

 

Hope this helps.

- Sumeet

TOPICS
Editing , FAQ , How to

Views

142.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Nov 30, 2021 Nov 30, 2021

Karl's video may help you understand how the HDR workflow all works.

 

Votes

Translate

Translate
Adobe Employee , May 31, 2022 May 31, 2022

For users recording their footage on a Sony Venice camera, using the Modify>Interpret Footage workflow will not work for those clips!

 

Venice uses the older unmanaged workflow, with a Source Clip Effect that has a toggle switch, and LUTs to adjust from there. You can batch-adjust these clips with an effect preset.
To see what I mean, load a clip in the Source monitor, and then open the Effect Controls panel.  You should see something like this! 

 

115584650.png

 

You can remove the source effect from there.

...

Votes

Translate

Translate
replies 196 Replies 196
New Here ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

What you said here, is incorrect: "Note: This only happens with projects (HLG media + Rec.709 timeline) created in the previous version. Newer project files will have the appropriate color space assigned and will show the correct preview." My new files do not show the correct preview. They are EXTREMELY oversaturated!

 

I have imported new videos from my iPhone 12 pro max - filmed today - and the oversaturation is still occurring. The suggestion you gave, changing it to Rec.709 does not provide the adequate coloration so I chose Rec.2020, which seems to appear closer to the original clips but the color is still off.

 

I am concerned that I will have to make these adjustments for every clip. Is that so? Is anyone else having this issue with new clips?

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Here is another problem I found with the development of color.

INTERPRET Color Management PrPro v.22.0 | Pay atte... - Adobe Support Community - 12512772

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

What a complete mess. All my old projects are completely blown out and most people arent experts at using interperet footage or understanding why the source image is fine but the sequence image is horrendously blown out. 

Its taken me hours to work an old project out. 

 

Company logos are all a strange colour and the LUT presets I had are all over the place...!!!

 

Great for the high end editor... using the REC whatever but for us normal editors this is a HUGE issue

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

New update came out tonight and resolved this issue for me!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

Make a screenshot of the build version

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

I just realized all it did was fix the footage looking over exposed in the playback window, when I go to export it still over-exposes my footage. UGH

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

it turns out they didn't fix it

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

What are your export settings? If you've got an HLG sequence, you have to go down through some fairly specific settings to ensure a proper HLG export.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

Can you share what settings I should look at specifically to ensure a proper HLG export?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

You have to roll the Video tab options down until you see the option for Export Color Space. And it can vary from codec to codec.

 

Say for an H.264 export, you have to change several things to get anything but a Rec.709 allowed ... like (on many machines) setting the Performance to Software Encoding. Then set the Profile to High10.

 

At which point, the option to set the Export Color Space becomes available. And you can set for Rec.2020 or 2100 in HLG or PQ.

 

Neil

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

This saved my project. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Sorry, this isn't helping me.  I need to output 709 color space for viewing in a browser.  No matter what I set the sequence to for color space, the 709 output looks like garbage.

 

I'm importing footage from my 5dMk4, and the sequence has the Rec 2100 HLG working color space set automatically, and the footage looks fine in Premiere.  No matter what I set the export settings to, keeping the Export Color Space set to Rec. 709, it looks blown out.

So, what do I do here?colorSpace.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Remove this version of premiere and install the previous one v15.  That's what i did, no point struggling with this issue, it's utterly ridiculous. Let them fix it first then upgrade.

 

/J

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Screenshot 2021-11-23 222549.png

 enjoy ✌️

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Thanks for not reading what I posted.  I need to output in Rec. 709.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

What worked for me was to change the seq to Rec709 and I terperate the hlg footage to rec709 and then export with a 709 setting.  

I had assumed that I could edit on a hlg with hlg footage and export in 709 but that doesn't seem to work.   The only way I could make it work was as noted above.  Effectively manually changing it that makes it work like prev version of Prem where it ONLY had 709 support. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Thanks - that almost works, but the export is less saturated and rich (see image).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

In this case, it's your own fault, since you can't set the initial settings for what you want and get the result as it is at the output. Why shoot in HLG to end up losing on quality? Unclear

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Set the working (timeline) color space to Rec.709. And probably go to the Project panel, Modify/Interpret Footage to over-ride the input settings to Rec.709.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Karl's video may help you understand how the HDR workflow all works.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

It should already be clear. Why some face difficulties in determining the correct color space. Everything is painted in the Video. Kevin, just a moment, check if the function of interpreting a video shot in LOG using a developing LUT works in your Color Management??? There's probably a flaw on the part of the engineers.

Screenshot 2021-12-01 003618.png

Let me know.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

That option works as expected here on my Win10 rig. I can add LUTs without any troubles.

 

If this isn't working for anyone, it would be helpful if they listed their OS/hardware, media, the LUT involved and where it "lives" on the computer so we get enough data for troubleshooting.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Neil, I can say with confidence that the LUt from the Interpret footage panel does not work. The LUTs themselves are placed strictly along the previously specified path. Here are the screenshots. Please note that lut was applied ONLY on the timeline. And in the window, look what's going on. It does not display. I'm tired of talking about it. Engineers are going to fix it. If we created this function, let's make it humanly working, and not just be like ballast.

Screenshot 2021-11-10 094637.png

 

Screenshot 2021-12-03 234357.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

I've applied several without trouble via the "input LUT" option in the Modify/Interpret Footage CM section.

 

So ... what's happening with your rig is a puzzlement. Which ain't surprising given the current state of CM in Pr2022, which has way too many broken points.

 

Proxies ... do not follow any CM from the clip settings a user makes, and we have no way to manually correct them ... as just one of the major issues.

 

I re-read a PDF they put out a few months ago on CM in 2021. Ann Bens posted it, and I went back and re-read. Included in that was the statement that proxies would follow clip CM which they don't.

 

And that if you modded the clip CM Premiere would make appropriate sequences for that clip. Which it doesn't. Take an HLG clip and override to Rec.709. Right-click, "new sequence from clip" or drag to a blank timeline panel. Either way, you get an HLG sequence.

 

Scopes supposedly auto-readjust to sequence CM settings, but ... no, they don't. You have to manually reset them.

 

Yea, there's a lot of broken here.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines