Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


"Replace With Clip" not working

Explorer ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I just upgraded to Premiere Pro CC 2017. Much to my dismay, the "Replace With Clip" functionality is not working.

I've restarted Premiere and restarted my computer with no results. I'm certain I have the clip selected in the bin and the clip selected in the timeline.

I'm working on a PC running Windows 7 with plenty of RAM (16GB). I've never had this problem until I upgraded to 2017.

Here's a screenshot. The "Replace With Clip" item is greyed out in the contextual menu. My keyboard shortcut to "Replace With Clip from Bin" does not work either.

I use this function all the time and need to find a solution pronto!

Premiere Pro 2017 - replace clip unavailable.jpg

Views

20.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 20, 2017 Nov 20, 2017
thxapproved2: You are right; Replace With Clip works only if you select the clip in the main Project panel, not if that same clip is in a floating panel.This bug is not new to Premiere Pro 12.0 (2018), however. This problem existed also in ver. 2017.1. The last time it worked was in ver. 2015.1. Please file a bug report: Feature Request/Bug Report Form Here it works in 2015.1:Here it does not work in 12.0 (same problem in 2017.1):

Likes

Translate

Translate
New Here ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

Having the same problem here. In my workflow with previous versions, I could have ANY number of project windows open, displaying the contents of multiple bins. Premiere would remember the MOST RECENT clip i had selected in any bin, and allow me to perform a Replace With Clip > From Bin using that most recent selection.

Now, this no longer works. The "from bin" option remains greyed out unless a clip is selected in whichever bin window Premiere believes to be the "canonical" or "official" or "primary" project window. Even more frustrating, so long as any clip is selected in that "canonical" project window, this action will ignore ANY more recent selection in another bin.

This effectively makes is so that the Replace With Clip > From Bin ONLY works with one *SPECIFIC* bin. (which, BTW, premiere does not visually distinguish from all the other bins that are open...). As others have stated, this is a humongous pain when working with complex projects where we actually ORGANIZE our stuff.

This is even worse for me, as I work on highly templatized projects where I stay sane by automating as much tedium as possible using keyboard macros, so this change in behavior has caused me to go from a 2-click solution to a "multi-screen, scroll around and waste a bunch of time" approach. I really like it better when things just work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

For what it's worth, you can still ALT/OPTION+drag a clip onto another to replace and it works, regardless of how many bins you have open.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Same issue here. Replace With Clip > from Bin  not functioning. Number of bins open makes no difference.

Replace With Clip > from Source Monitor still works as before.

PP CC2017.1.2 (22)  Windows 7 Professional

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Have you tried resetting your workspace to a default one? That would resolve the issue related to open bins.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Thanks Jeff –While my issue has nothing to do with open bins it does temporarily solve the issue regarding Replace Clip With > From Bin being inactive. Obviously, I’m not going to revert to a default workspace just to make this feature active each time I need it; it should work with my workspaces as it always has before. I won’t mark this as “Correct” yet since it seems to be an issue with this CC version. I look forward to the fix!

Thank you,

Stephen McKay

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Reverting to a default workspace was simply to test whether or not the functionality did work under "normal" conditions. If it does, then there is indeed an issue with your workspace. You can try reverting back to a default workspace then recreate your desired workspace and resave as a new workspace. As long as multiple bin windows are not open, the Replace Clip With dialogue should work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Hi Jeff. Yes, a reset workspace does fix it but any changes to it or switching to any other of my workspaces disconnects the feature again.

I cannot work effectively with one bin available, however, so this isn’t an effective work-around for our workflow.

Hopefully this bug will be addressed in the next release.

-Steve

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

I am now having this SAME problem in V.12 Haberdasher (CC 2018).

Mine stems from the fact of using floating bins/windows. If I have the clip selected in the floating bin, it is not recognized.  Same is true for the legacy titler. If you do one of those "New Title Based On Current Title," it bases what bin the title shows up in based on the last bin you clicked in.  Well, if I have a floating window open and something highlighted, it doesn't recognize that either, as previously.  It works if you have it selected in the project pane.  Everything works perfectly when selected in the project pane.  It is only the floating bins/windows that are problematic.  Now, they suggested posting this in the BUG form... I have been doing this since the problem first showed up in cc2017 (first version), and the problem still persists.  I have diligently filled out a BUG request with each revision of CC 2017.  And here we are in CC 2018...

Attached is a screen cap of what is happening.  You can see where I have a floating bin/window open and a clip selected.  You can see where I have something in the source monitor. You can also see where I have right-clicked on the clip to bring up the context menu. You can also see where the "Replace With Clip... From Bin" is grayed out.  THAT is the problem.  I have a CLIP in the BIN selected.  But the software thinks not. Why is this not getting fixed?  Used to work just fine.. Not now. Frustrating.

FloatingWindowsProblem.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

The issue stems from having multiple bins open. For whatever reason, bug or not, Replace With only works with a single bin open. Yes, it used to work with multiple bins open in the past. Not any more.

The solution is if you want to use Replace With, you must use it with one bin open. Or, you can use ALT/OPTION and drag a clip onto the clip you want replaced. This works from any bin.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Thanks for the tip on the ALT+Drag, but I also tried closing any other instance and the "Replace With Clip..." still does not work.  It does work with the ALT+Drag, but not any other way than selecting it in the main project window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

You have the same bin open twice.

Make sure there is but one open.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Tried closing the bin in the project window, and it still did not work.  Thanks for the suggestion though!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Are you on the latest version of premiere (2018)? I had issues with replace with clip as well there when having mulitple projects open. The only stable way I could get it to work was to only have the one main project window open, no instances of other bins 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

I sure am. The latest. Only one project open as well.

The problem is, I want to have other bins/windows open.  We always could do this before, and it is an ideal working situation.  To have to keep navigating the project window is constrictive at best.  I want to be able to open the bins as large as I want (clip view) and then close when I am through.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

I tried to replicate this problem. It doesn't matter (to me) how many bins or Project panel windows are open; once I've selected a clip in a bin, the command is not grayed out. Have you selected a clip first in a Project panel before right-clicking the clip in the sequence and trying to choose Replace with Clip? (I'm using Premiere Pro 12.0 on macOS 10.2.6.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Hello Stefan.

I think you're missing what I am trying to do.  Yes, what you described will work. If I select the clip in the PROJECT panel, it works flawlessly. HOWEVER, it used to work when I would select a clip in a bin OUTSIDE the project panel. You know, where you double-click on a folder in the project panel and open it as a free-floating window?  That is where it will NOT work.  It used to. I would like it to do so again. It was VERY convenient.

Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

thxapproved2: You are right; Replace With Clip works only if you select the clip in the main Project panel, not if that same clip is in a floating panel.

This bug is not new to Premiere Pro 12.0 (2018), however. This problem existed also in ver. 2017.1. The last time it worked was in ver. 2015.1. Please file a bug report: Feature Request/Bug Report Form

Here it works in 2015.1:

screenshot_1514-2015.1.png

Here it does not work in 12.0 (same problem in 2017.1):

screenshot_1508-2018.0.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

I cannot reproduce in 2018 (12.0) mac. It works as expected.

I did not use floating windows.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

Ann: You have to use floating windows to reproduce the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

Oh, no wonder I could not repro the issue. Sometimes it's the small details as I rarely edit with floating panels. They drive me insane.

Cheers,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

Sorry you don't like them.  Some of us have a different workflow

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

Floating windows has never worked. Dont think its a bug but by design.

If you have floating windows it means the clip is twice presented: once in the main project window and once in the floating window. If you select a clip that is not in the floating window it works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

Trust me. It did work, and then has not since CC2015. I would have no reason to lie.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

https://forums.adobe.com/people/Ann+Bens  wrote

Floating windows has never worked. Dont think its a bug but by design.

Ann: As I wrote in an earlier post, I confirmed that it works in ver. 2015.1 but not in later versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

Unfortunately I cannot test 2015 anymore.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines