Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Unbelievably slow audio render times!

Explorer ,
Aug 05, 2013 Aug 05, 2013

Copy link to clipboard

Copied

I've been dealing with his for a while now on this documentary I've been working on. When I export my timeline which is right around an hour, it takes around 2 HOURS just to render audio previews before it will export! The bulk of my timeline is a single track with no effects at all. Video renders faster than the audio! The only thing unusual about my project is it is largely composed of longish multi-cam sequences - about 30 sequences ranging from 30 mins to 90 mins. It's appears PP is rendering audio for every bit of my source sequences even though only a few seconds or minutes of each one is actually being used. I don't know what else could be happening.

I was thinking that since some of the audio was recorded at 44.1K maybe that was a problem and some of the sequences had several tracks of audio so to solve this I went through every sequence and rendered out a stereo mix at 48/16 and deleted the old audio. That seemed to help for a while as with CS6 I was getting a very annoying "rendering required audio files" message every time I hit play until I rendered the audio which as I said takes a really long time. Also I can render this but if I close Premiere and re-open I have to render it all over again. It is not keeping the audio render files. Premiere CC is better about playing back without the render message but it still needs to render for export. I have no idea why it would need to render audio from 48/16 source files.

I have reported this to Adobe but just thought I'd put this here to see if anybody else is having issues. If any audio rendering should ever be required in this day and age it should be extremely fast. This problem has really brought exporting to a crawl for this project.

screenshot2013-07-28at12.24.29pm.png

Adobe CC, OSX 10.8.4 on a 12 core Mac Pro with a GTX 570 32GB ram, and BM Studio. My RAID is a 3 disk internal raid with 3 3TB disks in RAID 0. The video renders reload properly. The situation would be better if the audio renders reloaded at least but why it needs to render "audio previews" for such simple audio is beyond me. And as I mentioned I went through quite a bit of trouble to make it as easy on Premiere as possible by replacing all of the 44.1 audio with 48/16 wavs.

Views

49.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , May 26, 2014 May 26, 2014
I found this on another forum:There were MANY other problems that came up on this project and as a result I was put on the pre-release group with Adobe, but the cause for the issue described above was due to the audio bitrate for the project not matching the bit rate of the audio clips. It has a resample them as a result. This seems to have solved it for me.  I opened my audio files in another program, re-sampled them, and then put them back in to Premiere. EDIT:  I can confirm that this worked....

Likes

Translate

Translate
replies 101 Replies 101
New Here ,
Aug 15, 2013 Aug 15, 2013

Copy link to clipboard

Copied

I am having the same problem with a fairly high end rig...  i7-3930K, 32Gb RAM, GTX 780 with MFE on, OCZ Revo system drive, SSD scratch drive, 3 7200RPM project disk and 1 7200 disk where I write my rendered files to.  With my old projects and multiple videos and separate audio recorded at 96K never have a problem after importing from CS6 to CC.  With a new project that had 3 video sources and one audio source I used PluralEyes 3 to sync the files. Worked great, but when I went to render the final video which is 47 minutes long, the video took maybe 10 minutes and the audio and hour…  

Help!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2013 Sep 01, 2013

Copy link to clipboard

Copied

I have had this problem too ever since upgrading to CC from CS6.  I always use nested sequences for syncing up my system sound, so I have not tested if this bug or 'feature' is premiere feeling the need to make audio previews for nested sequences vs other ways of syncing sound with video clips.  I did an experiment. One sequence had 192 sequences, but only 33 within the work area for rendering.  When I went to render, premiere wanted to render 192 audio previews.  When I copied just the work area to its own new sequence, premiere wanted to render 33 audio previews. So annoying that it wants to render a 'preview' for every sequence on the timeline, not just only what is in the work area. Why is that, Adobe?! Do you understand how much editing time this wastes when I can't be using my machine?  I think from now on, I will be sure to keep a fresh sequence only for rendering out from. 

And I too can confirm CC renders audio slower than video.  Just got my new core i7. The video encodes soo much faster than my old rig, but the audio seems to be stuck in molasses.  Would really love to hear an answer from the high software paid engineers at Adobe who get health insurance why they have taken audio rendering back 20 years.  What do we have to do to not get this annoying glitch?  Not use nested sequences? That makes keeping sync soo much harder if that's the case.  

Message was edited by: Kevin Monahan

Abusive language. Please do not use profanity.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 28, 2014 Jan 28, 2014

Copy link to clipboard

Copied

For me, when I use Sequence->Render Audio in Premiere Pro CC, there is a huge difference in rendering time depending on whether the audio tracks are locked or not.  This is obviously a bug, because clicking the lock icon on/off shouldn't affect anything about the audio itself.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 28, 2014 Jan 28, 2014

Copy link to clipboard

Copied

Which is it? Do you get faster renders with locks activated or locks deactivated?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 29, 2014 Jan 29, 2014

Copy link to clipboard

Copied

Just to give a few more details, the project is 100 minute film with 22 audio tracks, and stereo master output.  The audio is fairly complex, but no nesting.  With all tracks unlocked it takes less than 5 minutes.   With all the tracks locked it went for almost 2 hours before I cancelled it; I've never had the patience to see it all the way through. 

After rendering all audio with the tracks unlocked, if I then switch even one track to locked, it will re-render, even if that newly locked track has no audio on it.  Again, no sound is being moved or modified in anything I am doing. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2014 Feb 21, 2014

Copy link to clipboard

Copied

We have exactly the same issue, the audio render files never save and when we want to export the sequence it takes 20 minutes to 'render required audio' before the export starts. Its a fairly simple sequence audio-wise, 6 audio tracks, with some reverse speeding on some audio tracks, video footage is RED, no difference if I nest video it still needs to render audio on export. I've not been using Premiere Pro for long, migrated from FCP7 so no great depth of knowledge of it as yet. I thought to 'nest' the audio but seems that isn't an option. Super annoying issue, only have it in this 1 project, all other projects we have no issues like this - surely it can't be the reverse-speed effects?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 21, 2014 Feb 21, 2014

Copy link to clipboard

Copied

Hi,

I looked into this a little closer. Are those of you with this problem using multicamera editing? If so, when you set up the Multicamera Source Sequence, is Audio set to "Switch Audio" in Sequence Settings? See image below.

When Switch Audio is used, all source audio tracks are available in the nested sequence and since multicam is enabled for the audio portion of the nested sequence, audio belonging to each video track needs to be rendered separately.  So if you have 4 cameras, it will take 4 times as long to render than if you had multicam disabled on the audio portion of the nested sequence.

I think that is why when I suggested flattening audio, the rendering time was as expected. 

For locking tracks causing longer audio rendering times, or if you would like to see the "Switch Audio" feature designed differently, please file bug reports: http://adobe.ly/ReportBug

Sorry for any trouble this has caused you.

Thanks,

Kevin

Screen Shot 2014-02-21 at 8.03.46 PM.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2014 Feb 22, 2014

Copy link to clipboard

Copied

My instance, noted above, does not involve multi-cam or any nesting of any kind.  I have filed a bug report.  Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2014 Feb 22, 2014

Copy link to clipboard

Copied

Let me start by saying I am only a hobbyist and do this more for my son and niece since they are musicians and play live in a number of venues.  I am not an electrical or audio engineer (I am an aeronautical engineer) so what I am about to say is based only on what seems logical to me…  First rendering audio should simply be faster than rendering video given the amount of digital data that needs to be processed.  That stated, I know that the Mercury engine using CUDA to process video vastly speeds the rendering of video.  Regardless, using today’s CPUs (i7 3930K in my case) should and does more than make up for the additional processing power for rendering video using CUDA. 

It seems to me that there is a bigger problem than whether or not we are flattening, nesting or locking our tracks.  It shouldn’t take as long as it is taking for some of us to render audio!!!

I only experienced this problem one time.  I am not even sure what I did to change the outcome on the same project that I have since edited and rendered many times.  But now the audio renders very quickly (less than a minute).  I will say that in almost all cases my music videos have different audio sources (44.1KHz, 48KHz 16bit, 48KHz 24bit, and 96KHz 24bit) and that I set all my sequences to 96KHz since my master audio sources are recorded at that.  I use an external firewire RME Fireface 800 using RME ASIO divers to handle all audio.  I do find that this setup can be stubborn in that there are times PPro CC doesn’t know what to do regarding my audio so simply won’t allow me to play any track.  When this happens I simply remind PPro CC of my settings by going to Edit/Preferences/Audio Hardware then check that the Adobe Desktop Audio is set to ASIO FireFace and click on ASIO Settings to check that the buffer size and sample rate are correct.  If they are not I read the flash from the RME and all is good. 

But I diverge, there is a problem Adobe and it needs to be fixed.  This never happened to me using CS6…

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 08, 2014 Mar 08, 2014

Copy link to clipboard

Copied

Hi Kevin. You may want to re-read some of this thread. Numerous people here are saying that flattening the audio didn't do it and some are not even using multi-cam. And as I mentioned in one of my posts, I per-rendered ALL of the audio into a stereo track in all of my multi-cam sequences in the correct sample rate to make it as easy as possible on Premiere but still had the same issue. So can I ask again? Why would Premiere need to "render" an entire 60-90 minute multi-cam timeline when I'm only using 30 seconds of material from it?

And the OMF export on this project was epic failure. It took 90 mins to attempt it but then crashed. I XML'ed it to FCP and it did it in 90 seconds and had no issue with 2GB limitation.

I would hope alarm bells would be going off in the hallways at Adobe over this but from your posts it doesn't sound like it. The thing is this stuff is bread and butter to all editing these days and it's something that people do day in and day out and it needs to be bullet proof. I can't imagine the reaction of having a paying client in the room under deadline and moving to the simple task of OMF export and having to wait 90 mins and then have it crash. Would you want to be in that room trying to explain that?

I think Adobe needs to realize that Premiere is still getting it's but kicked by a program that's been dead for years now and and hasn't been updated since. And also I think Adobe needs to realize that pretty much nobody expects Premiere audio to be "better" than Avid/FCP but they do expect it to be as good and as fast. So when I hear all audio gets converted to 32 bit or whatever I think people need to realize that if this impacts performance then it needs to be an option or just kill it because nobody cares.

I really hope Adobe doesn't just brush this off because I for one have been in a lot of pretty high end facilities and the conversation comes up of Premiere and the thing I hear over and over is it's just not there yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 03, 2014 Apr 03, 2014

Copy link to clipboard

Copied

The Reason for me was:

- Mixdown all the audio tracks to one WAVE or MP3 file

- Re-Import it to the multicam sequence

- Delete all the audio tracks of the sequences, that are used in the multicam sequence (muting is not enough...)

- Export the multicam sequence.. and voi-là.. my sequence was rendered in 3 minutes instead of 2h30...

And at last, report this bug to adobe.. It can not be, that "professional editing software" causes such issues.. It's a shame, that adobe knows this issue since over half a year, but does not fix it until this day..

Hope this soultion works for you too guys...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 05, 2014 Apr 05, 2014

Copy link to clipboard

Copied

I am using multi-cam, only 4 cameras.The audio is not set to switch. In fact the camera audio is muted and I am using a seperate stereo mixed track of the band.

Every time I export a single song (from a set work area) Premiere renders 'required audio file'. It even says it is rendering six Audio Previews. I am sure it is re-rendeing the whle of my imported stereo audio as the single track has been cut into segments for each song.

I can't charge the client for this rendering as it is a technical issue. A song that should take about a minute to export is taking over half an hour.

This has not happened with any previous version of Premiere, even with very complex projects.

By the way, I don't seem to be able to dynamically link to Audition to refine my audio tracks. The link is greyed out in the menu.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 05, 2014 Apr 05, 2014

Copy link to clipboard

Copied

BTW I am using a high end i7 Windows 8 machine with RAID 0 disks and an Nvidia  Quadro 4000 video card.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2014 Apr 14, 2014

Copy link to clipboard

Copied

Arrrrg, what is up Adobe? Serious, what is taking so long? This issue is over 6 months old and still not resolved?  I can't tell you how many Premiere updates I've downloaded, and none fix this problem?!  That last update was to more smoothly integrate Lightroom and RAW into Premiere? Who cares about Lightroom when using Premiere?  Why isn't this fixed, we pay good money for this every month!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 18, 2014 Apr 18, 2014

Copy link to clipboard

Copied

Hi Viva Minolta,

Sorry this issue is frustrating you (and others on this thread) so much. I talked with engineering and they said that the workaround given by Lou Colt in post 24 was probably the best way to deal with the issue for now.

Basically, they said that if you have a multicam sequence that is used often with many cuts, then it may be best to pre-render the underlying multicam sequence.

If this is an unacceptable workflow, again, feel free to file a bug report: http://adobe.ly/ReportBug

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2014 Apr 18, 2014

Copy link to clipboard

Copied

Hi Kevin,

Thank you for your efforts, but the situation is still unacceptable.  If this was some sort of super advanced real-time 3d raytracing feature that was brand new, I might cut you people a little slack. But this is SOUND for film.  That technology has been around since the 1920's!  The idea of synchronizing sound and picture has been implemented for over 90 years, yet Premiere chokes when it tries to render a multi-cam sequence with cuts? 

Its even more frustrating because your  real-time 3d raytracing implementation actually works admirably well.  So what is wrong with rendering AUDIO?! 

============================================

Edited by moderator to remove personal attacks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 19, 2014 Apr 19, 2014

Copy link to clipboard

Copied

Hi VivaMinolta,

I read the original version of your post, and I understand you're upset. Not much I can do but ask again that you file a bug report: http://adobe.ly/ReportBug

Please also check that you are not creating a multicamera sequence using the "switch audio" function as I reported in post 29. That function drastically increases render times.

Concise bug reports are the best way for us to deal with bugs. I hope others on the forum also write a bug report. Thanks for understanding.

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 08, 2015 Aug 08, 2015

Copy link to clipboard

Copied

This problem seems to be new to CS6, as in CS3, I could render a 5 minute MPEG2 clip of a 110 minute concert video in about 40 seconds. On CS6, it sits there "Encoding <name of timeline>" while hard dense disc activity is evident. This process takes 42 minutes. Then the video render begins and that takes seconds.

For working on concert videos with multiple cameras and 5.1 surround audio tracks, best still to use CS3, as it has a HUGE rendering speed advantage because this audio preview rendering does not happen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2015 Nov 14, 2015

Copy link to clipboard

Copied

Great tip Kevin.  Simply hitting Flatten on the multi-cam helped! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 06, 2016 Jan 06, 2016

Copy link to clipboard

Copied

Add me to the list of frustrated and confused. I have a relatively simple 4 camera multicam source; all cameras are the exact same video/audio specs, and I have confirmed my sequence settings, render settings and audio are all the same sample rate when exporting. Exporting always brings up the dreaded "Rendering Required Audio Files" issue, which takes waaaaaay longer than rendering the video footage. I have deleted ALL audio in my multicam source sequence, and only have 3 pieces of audio footage in my sequence. Flattening the multicam sequence hasn't stopper Premiere from the "Rendering Required Audio Files" nonsense.


Any suggestions on what else to try???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 14, 2015 Feb 14, 2015

Copy link to clipboard

Copied

Welcome to Adobe's CC, where you, the user, are the SW tester. Adobe laid off all their SW testers, and rely on us to find the bugs. Are you enjoying your monthly CC subscriptions yet? 😉 Think about that every month when they charge your CC (hey, that looks a lot like the initials of Creative Cloud! Go figure).

I'll stick with CS6 until I can find an alternative. Renting SW is just not my thing. It's too bad they've alienated so many people, like you, who grow increasingly frustrated at this Agile-style, seat-of-the-pants, SW engineering methodology being used now, which is touted as 'continual upgrades'. More like continual-troubleshooting-and-frustration-trying-to-get-anything-done-with-Adobe-SW kind of thing. It would be nice if every 12 months they 'froze' a version of CC and boxed it up and sold it in a perpetual license. They could do this and continue relationships with customers like me who refuse to jump on the CC fiasco. Most other companies who have initiated similar subscription SW services like CC, also have a perpetual license option as well. Adobe is missing a lot of revenue trying to convince people that CC is the future. Too bad, really.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 19, 2014 Apr 19, 2014

Copy link to clipboard

Copied

I'm also sorry Adobe doesn't have a higher sense of urgency in dealing with such a fundamental issue as this. 2 hours to "render audio" from a one hour sequence? And it doesn't even save the render but does it all over again next time Premiere is started? And you just see this as an annoyance or frustration? Hello? Some of us here work in high pressure situations. I'm glad everything is so nice and friendly in corporate land there.

I would encourage Adobe to work with some more seasoned editors on some of these issues. I for one could tell you exactly how to set the audio up in Premiere that pros would love and would be easy on beginners as well. The first step would be to realize that 90% or more of audio sources in editing are MONO - lav1, lav2, shotgun - and that the computer has no way of knowing which tracks you will actually need, and so you need to make it easy to do whatever you want it to do not have the program make all kinds of assumptions.

I've been playing with Premiere for over a year now and simply do not get the logic of the way you guys have approached track mapping. For example the other day I had a mono track on audio1 and another on audio2 but the mixer showed 2 tracks on 1 and 2 tracks on 2? And instead of pan pots I had "balance pots" that would not center pan my simple mono tracks but instead just fade them in and out as I panned from left to right. ?????  FYI pan pots are to place mono tracks inside a stereo mix. - and that's just the beginning. But simpy put there is simply no reason to not have a rock solid, bullet proof audio engine at this point in time. Zero. 10 other programs have already done this.

And yes I have sent these suggestions in.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 21, 2014 Apr 21, 2014

Copy link to clipboard

Copied

The render times is a new issue. It has never been a problem with any previous version of Premiere, until CC. There was no render time at all previously.

Not even when I had 24 camera angles to mix!

Raymond

Pi Production Services

Specialists in Concert and Event Videos

http://vimeo.com/user1799517

www.myspace.com/pi_productions

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 21, 2014 Apr 21, 2014

Copy link to clipboard

Copied

The issue I was having I did see in CS6 as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2016 Apr 17, 2016

Copy link to clipboard

Copied

I had the same issue.  Matter of fact, I did an export of a 3 min sequence and it said 27 hours to render.  What?  Before I found this thread, I determined it was audio. I exported video only and it was very quick. Exported audio, and it started off saying 20 hours, then quickly dropped down to about 2 minutes. 

Earlier this week, I started an export of a 20 min Green screen sequence with single track of audio.  It said 2 hrs when I started the render. Then it kept going up, up, up and it ended up taking 17 hours to complete.  I discovered the next morning it was still going and had about 8 hours left, so I left it alone.   After it finished, I exported the same sequence with NO audio and it rendered in 30 minutes.

They need to fix this right away.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines