• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

ACES Display Color Space do not work on already created compositions

New Here ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

  • Issue - I'm converting an existing project I was working on using ACES with the OCIO plugin to the new native AE implementation, but despite the footage color spaces being set correctly (exr 2065-1 sequences), AE doesn't map correctly to sRGB, space that I have selected from the dropdown "Display color space" of the composition. However, if I create a new project from scratch, with the same footage, and do the same settings, in a new composition, this time it behaves as I would expect. Another piece of information that can be useful: in the footage viewer it looks correctly mapped, this problem occurs only in compositions.
  • Adobe After Effects version number: 23.4 (Build 53)
  • Operating system: Windows 11
  • Steps to reproduce - 1. Open an old project that uses the OCIO plugin to do color management with ACES / 2. Remove all instances of the OCIO plugin and delete any related adjustment layers. / 3. Configure the project to use the native implementation of OCIO-ACES / 4. Interpret the color space of the footage (exr sequences in 2065-1) / 5. Check the composition using sRGB as display color space
  • Expected result - It should look like the color space mapped correctly from ACEScg which is my working color space to sRGB which is my display color space.
  • Actual result -  When you change the display color space in the existing composition, no matter what you choose, it doesn't do anything and the footage doesn't look right.
Bug Investigating
TOPICS
Troubleshooting

Views

425

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Jun 15, 2023 Jun 15, 2023

Hi, Thanks for sharing the project file. 

We are able to reproduce the issue at our end also, and will include the fix for same in next update.

Thanks.

Votes

Translate

Translate
9 Comments
Engaged ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

I'm finding the whole OCIO implementation laughable. As soon as I switch to it AE becomes unusable. Either black screen or or freezes on a one frame. Joke.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

Hi,

After Effects caches frame, please purge the caches to see if that make a difference.

Steps you mentioned above should works, if possible please share the oiginal and converted project to check if something is missed there.

Thanks,

Votes

Translate

Translate

Report

Report
New Here ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

Hi! Thanks for the reply. Unfortunately the cache purge didn't work. 

 

I am sharing a link to the project with one exr frame in ACES 2065-1. In the composition it looks bad mapped to sRGB, but in the footage viewer it looks good. It's worth mentioning again that this only happens in old projects, not in projects created from scratch in this version.

 

Example project: https://shared-assets.adobe.com/link/4e643c2b-19db-4637-6a8e-5e454bfee037

 

Thanks.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

Hi, Thanks for sharing the project file. 

We are able to reproduce the issue at our end also, and will include the fix for same in next update.

Thanks.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

Per @Chetan Nanda's response, updating the Status of this issue to Investigating.

 

- John, After Effects Engineering Team 

Status Investigating

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

@chrisbrearley, would you mind creating a new thread detailing the issues you are seeing with OCIO? It seems different than the issue being reported in this thread, but worth investigating.

 

- John, After Effects Engineering Team  

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 29, 2023 Jun 29, 2023

Copy link to clipboard

Copied

Hi @IrinaIllera ,

We have included the fix for display issue in After Effects Beta build.

Please help to check the fix in beta build.

Thanks,

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 08, 2023 Aug 08, 2023

Copy link to clipboard

Copied

I am still having this issue as of Aug 08, 2023. Any previous project started that is then changed over to the ACES color management has issues with the display color transforms. Any selection does not update the viewer. Oddly it't not every piece of footage though I'm not sure if it only impacts footage that was already imported before changing color management to OCIO but that is likely the case. Dragging a newly imported clip (after switching to OCIO) into a new composition works as expected but dragging that same piece into a comp created before the change causes it to fail the same.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 08, 2023 Aug 08, 2023

Copy link to clipboard

Copied

LATEST

Hi @Christopher Power ,

Please share details on After Effects version you are using. 

If possible please share a sample project also so that we can check if something still amiss witth older projects.

 

Thanks,

Chetan Nanda

Votes

Translate

Translate

Report

Report