• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

3D scene issue: Auto-Orient along path on a map causes my aircraft to jerk during turns

Enthusiast ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

Not sure what I'm doing wrong here. But I have a 3D scene with a world map and an aircraft following a path (red line) along that map. After applying auto-orient along path to my aircraft, the plane faces the wrong way. So I set the Z rotation manually to 51º to make sure it's pointing in the direction of travel. But the problem is that after applying auto-orient,  the aircraft develops this unwanted jerking motion now and again as it turns. See pics of my project below and attached animation. Thank you very much in advance to anyone who can help me troubleshoot this issue. 🙏🙏🙏 

 

https://www.youtube.com/watch?v=DiRGPFBk6YA 

 

Screenshot 2024-03-06 at 9.31.04 AM.pngScreenshot 2024-03-06 at 9.31.16 AM.png

Screenshot 2024-03-06 at 9.37.01 AM.png

TOPICS
Error or problem , How to

Views

156

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

You must smooth your path as much as possible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

Check the tangents of your keyframes. this happens when there's overshoot and the look-ahead in the auto-orient function uses those off path coordinates to calculate its stuff. Also generally work on optimizing your path. You probably could lose a bunch of the keyframes...

 

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

The first thing I see that can cause problems is that the plane layer, the shape layer path revealed by trim paths, and the Map are all 3D layers. I would change them all back to 2D layers until you get the motion problem solved, then pre-compose them all and make the Pre-comp 3D to add some perspective to the moving map.

 

It looks like you have overcomplicated the trip path. Start by selecting the path in the timeline, choosing the pen tool (g), and then delete points that are close together. Hold down the Alt/Option key to change the pen to the Convert Vertex tool and collapse all the curves. Simplify the path as much as you can and carefully use the Convert Vertex tool to put the path back in place. 

 

If there are a lot of keyframes, it may be easier just to use the pen tool to create a new path on top of the old one with as few keyframes as possible. 

 

When the path is simplified and cleaned up, set a single path keyframe, cut it, then select the Plane path, delete all keyframes, and Paste. I always set a single path keyframe when I want to convert to a motion path because it tells me that I have copied the path correctly.

 

That should fix your problem. 

I probably would have used a null for the motion path instead of directly pasting it to the plane, then Shift + Parent the Plane to the null to snap it into the same position. Then, you can simply rotate the plane to make it perpendicular to the motion path. 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

Airweb, Mylenium, and Rick, thank you all so much for your help. I will follow through with all your suggestions. What seemed odd to me about the moment where the jerky motion occurs is that it's not on a particular keyframe but between keyframes:

 

Screenshot 2024-03-06 at 2.50.49 PM.pngScreenshot 2024-03-06 at 2.51.08 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

The top left corner of the Null and the anchor point of the plane should be over the line.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 08, 2024 Mar 08, 2024

Copy link to clipboard

Copied

Hi Rick, still trying to troubleshoot my issue. I should have mentioned initially that my reason for wanting to keep the camera, null, aircraft and voyage in the same comp was to be able to frame and lock the null-parented camera to the moving plane.  If I drop the map, plane, and voyage into a 2D comp and then pre-comp them into a 3d scene wouldn't the null-parented camera no longer be able to lock onto the plane since it couldn't see the plane directly?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 08, 2024 Mar 08, 2024

Copy link to clipboard

Copied

Just a quick follow up. Without removing any points, I solved the jerky motion of the plane by placing two corrective Z Rotation keyframes at the point where the jerkiness occurred. The plane now turns smoothly without jerking or flipping.  

Screenshot 2024-03-08 at 8.59.01 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 08, 2024 Mar 08, 2024

Copy link to clipboard

Copied

LATEST

The two corrective keyframes I placed very close to each other seem to have eliminated the jerkiness. But Airweb, Mylenium, and Rick, thank you all very much for your feedback and very helpful suggestions. I'll be sure to keep your recommendations in mind regarding smoother paths and how to properly stage these scenes. 🙏🙏🙏  

Just thought I'd include this follow up video that shows the jerkiness removed after placing the two corrective keyframes:

 

https://www.youtube.com/watch?v=bv-xePLFA3Y

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines