AE rendering slow (read post)

New Here ,
May 12, 2022 May 12, 2022

Copy link to clipboard

Copied

I am trying to render in After Effects, and I find that it is going extremely slow. At the start of each frame, my computers's CPU and GPU usage spikes to normal, then immediately falls to near 0% for like 20 seconds. It does this every frame, making the rendering process take much longer than it need to. I'm only rendering around 350 frames in a .png format with only keylight, advanced spill supressor, and a few color key effects. This makes no sense to me. I am running AE off an SSD, however my files are running off a HDD. 

 

Specs:
Ryzen 3950x 16 Core

Rtx 3080

64gb Ram

NVMe M.2 SSD

2tb 7200rpm

TOPICS
Error or problem , Performance

Views

113

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2022 May 12, 2022

Copy link to clipboard

Copied

And what footage? What output format? Is multiframe rendering active? What are the keylight settings? What the other effects? Overall this sounds not out of the ordinary, but I have a hunch that you may have issues with hardware acceleration where the program optimistically loads a frame, tries a bunch of times with GPU acceleration and multiframe rendering and then ultimately falling back to single-core CPU processing. This could be caused by a single overcranked setting in Keylight for instance, which is quite a resource hog to begin with. So for what it's worth, you may not be able to fix or improve this completely. There just may be some potential for tiny optimizations and at least avoiding this time-wasting back and forth between CPU and GPU modes.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2022 May 13, 2022

Copy link to clipboard

Copied

Thanks for getting back to me, and sorry for the late reply. My footage is an image sequence from a Canon camera (res is 4480x6720). The resolution is high, but my computer is substainially more powerful than my work's, and I've never ran into problems. Mulit-frame rendering is active. Output format is .png, rgba, million of colors+, no compression. 

 

I have 4 color key effects before my keylight. After that I have an advanced spill suppressor.

 

My keylight settings are:

Screen Gain: 100

Screen Balance: 35

Clip Black: 10

Clip White: 75

Shrink/Grow: -.5

Screen Softness: .2

Replace Method: Hard Colour

Everything I didn't mention is default

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2022 May 13, 2022

Copy link to clipboard

Copied

LATEST

I disabled mutli-frame rendering, and for some reason, that has made it a lot faster. I'm looking at around 2.5s a frame compared to the like 20s it was prior. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines