After Effects active camera isn't actually the active camera

New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

First post here. I'd like to start off by saying I'm at my wit's end with this.

 

I have a 3D sequence that uses a camera with keyframes for movement. For some reason, the active camera (which should be camera 1) isn't actually camera 1. It's just an unknown point of view.

 

The 3D reference axis says it should be moving like camera 1, but when I scrub (or try to render for that matter) it just doesn't move. The camera is enabled.  Is there a way I can change my render to camera 1 rather than the active camera?

 

Screenshot attached.

Thanks in advance! 

 

 

TOPICS
Error or problem

Views

63

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Mar 09, 2022 Mar 09, 2022

I realize that I was showing 2 different views at the same time. I was doing that to demonstrate the issue. Regularly they would both move at the same time. 

 

It was definitely an AE bug as I have been doing things this way for years without issue. 

 

In a fit of rage, I turned the text objects 3D one at a time, even if it wasn't visible and was only being used for the source text. on the first 2 nothing happened, but when I made the 3rd one 3D it resolved the issue. I then turned 3D off on all of

...

Likes

Translate

Translate
Community Expert ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

None of your layers are 3D layers so we assume you are using a third party plugin to create 3D text. Probably you can change the camera inside the plugin selecting the Comp Camera instead the plugin camera. Also, if you create any 3D layer, you will have a drop-down menu on the bottom of your composition panel to change the camera to whatever camera you want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

Camera 1 is the only camera I see in the timeline, so it is the Active Camera. Select the left comp panel (Active Camera), and that panel should preview. The right comp panel is active. Only the active comp panel will preview.

 

Jose Panadero is also correct, I don't see any 3D layers in your timeline, but there is at least one effect applied to Layer 3 (Title), so you must be using a 3rd party effect to make the text layer 3D.

 

When you have problems with a layer, it's a good idea to select the layer, press the 'u' key twice to reveal all modified properties of the layer then embed that screenshot instead of dragging and dropping it in the Drag and Drop tool so we can see what is going on. You can drag images to the reply field, copy and paste, or use the toolbar to embed images in your post.

 

You might also want to consider spending a little time with the User Guide

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

LATEST

I realize that I was showing 2 different views at the same time. I was doing that to demonstrate the issue. Regularly they would both move at the same time. 

 

It was definitely an AE bug as I have been doing things this way for years without issue. 

 

In a fit of rage, I turned the text objects 3D one at a time, even if it wasn't visible and was only being used for the source text. on the first 2 nothing happened, but when I made the 3rd one 3D it resolved the issue. I then turned 3D off on all of them and everything returned to normal. I don't know what caused this to happen in the first place, as the issue just sorta popped up. 

 

Thanks for your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines