After Effects causes high VRAM Usage on GPU

New Here ,
May 16, 2022 May 16, 2022

Copy link to clipboard

Copied

Hey,

so After Effects is not performing very well on my PC. Sometimes its so bad that my PC Frezzes and i have to power reset it. I ran some checks and the Problem is that when After Effects is open my VRAM Usage Jumps from 300 mb in use to 7,8 GB in use. I check and it looks like After Effects is using almost all of my VRAM on my GPU. That causes the System to Frezze. 

PC Specs

CPU : Ryzen 7 2700x

AIO : Corsair iCUE H150i ELITE CAPELLIX 360MM

GPU : RTX 3070 Gaming OC

RAM : Corsair Vengeance RGB Pro 16 GB 3200MHz

 

Here are to Screenshots of the Problem

 

Adobe After Effects VRAM.PNG

Without After Effts

Adobe After effects vram2.PNG

 

I dont know why After Effects does that and it only happens when i render the Project with my GPU, the second problem it that it doesnt even peform good. When i render with the Software encoder its smoother then with my GPU. Sometimes even effects dont render with my GPU and i had a problem with a Project where i coudnt render it using my GPU because it Media encoder either failed or got stuck at a Frame.

 

Thanks for reading this and for any Help

(English is not my first language so pls dont just say that its bad i know)

TOPICS
Error or problem , Freeze or hang , Import and export , Performance

Views

170

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 25, 2022 May 25, 2022

@Olivier5EB7 I might have found a solution for you problem, my issue was resolved when I downgrade my NVIDIA drivers to this version https://www.nvidia.com/download/driverResults.aspx/175403/en-us 

I hope that helps you as well 😉

Likes

Translate

Translate
Adobe Employee ,
May 16, 2022 May 16, 2022

Copy link to clipboard

Copied

Hi Olivier,

 

Welcome to the community and sorry for your issue.

We'd love to help you troubleshoot. Would you mind sharing the following details:

  • What's the exact version of After Effects you're using? 
  • What happens if you disable the Multi-Frame Rendering (Edit > Preferences > Memory & Performance > uncheck Enable Multi-Frame Rendering). Does it lower the GPU usage? Does it improve the performance?
  • Share details of the project you're testing it with. What kind of media, effects, and third-party plug-ins you're using?

We're here to help, just need more info.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

Hi Nishu,

 

I use the newest Version (22.4) from the Creative Cloud App

Here is a screenshot with Multi Frame Rendering disabled 

Adobe After Effects VRAM 3 .PNG

 

The Video Content is on a Samsung 870 QVO 4TB SSD, I use Flow,Twitch, Sapphire and CONTINUUM as Plugins with alot of Position and Scale Keyframes. 

 

,Olivier

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

Hey Olivier, try to go in your After Effects preferences and click Enable Mercury Transit in the Video Preview section.

It worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

Hi Mathieu,

I dont think it worked for me. I turned it on and the VRAM Usage didnt drop 

Adobe After Effects VRAM 34.PNG

But thanks for your Help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

It actually didn't. I thought it did for a bot, but no luck...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

Your system is imbalanced - too many cores but too little RAM - GPU is good on its own. Also, AE looks at the required calculations it needs and some effects and transforms can be performed on either the GPU or CPU. With such an imbalanced system, you will have a core or thread with too little memory to do heavy-compute stuff without having to utilize the harddisk as cache and this will likely be done very often. I suggest you invest in more RAM - ideally 2GB-4GB RAM per thread is desired. HTH. 

Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Toolkits

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

What has my RAM with the VRAM of my GPU to do?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

LATEST

@Olivier5EB7 I might have found a solution for you problem, my issue was resolved when I downgrade my NVIDIA drivers to this version https://www.nvidia.com/download/driverResults.aspx/175403/en-us 

I hope that helps you as well 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines