• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

After Effects Text disappears when switched to a 3d layer

Explorer ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

Hi,

I'm experiencing this issue with After Effects. I'm building a title with Plexus 3, it's applied to a text layer under the settings of a path. I'm using the Latest Version of After Effects CC 2018 Version 15.0.0. On Mac OS X High Sierra.

The only things that are in my layers is the Camera, the text with Plexus and the text without plexus. I have a the camera pulling out of Plexus forming the outline of the text. I want to have the text with no effects applied to it to fade into text with plexus while the camera continues a slowing pan back. Every time I turn the text layer, without plexus, into a 3d layer it disappears. At this point I'm sure what to do.

Whenever I go back to the beginning the timeline when the camera zoom is closed in on Plexus, I do see the text in the background, but it's really big and super blurred. I can change the color but you can't even tell it's text.

If anyone can provide feedback or if you need to know anything else please let me know

Thanks

Views

4.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

It has been a while but I think Plexus requires OBJ files or mask paths. If your 3D Text layer disappears it could be in the wrong order or the camera might not be pointing at it. Try opening up 4 Views, select the 3D Text layer and see where it is in AE's 3D space. If it is where you expect it try moving it above or below the Plexux layer or moving your comp camera.

Screenshots with the modified properties of all layers revealed (press the U key twice) are helpful in diagnosing problems like this. Four comp views are helpful in diagnosing 3D layer layout problems.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

Plexus is on a Mask path with the text. When I open the 4 views option, I only see the text (without Plexus) in the Front view but none of the other views show it. I have it layered Camera (at the top), text with plexus, and text without plexus. I've tried moving the layers around but nothing works.

I've included a screenshot of all the layers revealed below in the 4 views option.

AE screenshot.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Valorous Hero ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

I am doubtful you should be applying Plexus onto a Text Layer. Instead, I believe you should apply Plexus onto a Solid with a Mask of the Text.

Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Toolkits

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

I opened up a new comp, added a text layer, duplicated it, Set the dupe text layer to 3D, Added Plexus to the 2D text layer, added Plexus and a path object, changed the color of the path object, increased the replication to 8, and then increased the Point size to 4. The final step was to offset the 3D text layer a bit on the Y axis so it would not be buried in the middle of the Plexus effect.

No disappearing 3D text layer, no problems yet. I even tried rearranging the layers. If you repeat the test using the exact settings I have here:

Screen Shot 2018-01-17 at 8.01.09 PM.png

If the Plexus version matches (most recent), your AE version is up to date, and you don't have something funky going on with your GPU or preferences that I can find, then you should file a bug. It looks like we are both on a Mac (OSX 10.13.2).

I could not see anything obvious in your comp that would cause the 3D text layer to fail and you can see from my example that I only modified 5 properties in the entire comp. I even tried turning off Accepts Lights and Accepts Shadows. If you try and duplicate my comp, and it should only take about 5 minutes, and it works then I've missed a workflow error in your project. If it does not work then file a bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

That's a lot of replicated layers. Is there a way I can only do it with one layer or two. My computer doesn't have the Ram and graphics to run past 4 replicated layers. I'll try what you have and see if it works and let you know. Do you think it could be the Camera settings? I have my camera motion starting slow, then it pulls back fast, and comes gradually to a slow stop. I have the camera looking dead on as well. It's sitting directly in front of the text. I have my camera settings at: One node camera, set to 50 mm, with the default settings that are in there already.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

Thanks for your response,

Unfortunately the using plexus that way doesn't solve the issue. It's not with plexus, it's with the text behind it that matches up with the text layer with plexus applied to it. The Camera keeps a smooth back shot and gradually comes to a stop. I need the text to be following the cameras motion so I can fade it into the plexus ending text shape. Resulting in it looking like Plexus becomes the solid text.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

LATEST

thank you i was searching for a solution for this issue for a long time and you solve it

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines