• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Bug when combining essential graphics no scale with link to compositions

Engaged ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

Hi

Using a composition as a property in essential graphics doesn't always work when scale is set to "no scale". In most cases it doesn't work.

I have included an example I have a main comp "01 main" and a master comp "02 master comp".

  • In the master comp I have one layer which is a third composition called "03 square".
  • I use that composition as a master property by dragging that layer to the essential graphics panel. I call the new property "Animated comp".
  • I then set "Default scaling" to "No scale".
  • I add "02 master comp" to "01 main" and drag a fourth comp "04 hexa" to the "Animated comp" property in the timeline.
  • Nothing changes visually. This WILL work for any of the other three default scaling options, but not for no scale. I have tried to purge the cache, didn't do a difference.

 

- Jakob

Views

57

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 12, 2024 May 12, 2024

Copy link to clipboard

Copied

Can you install the latest version of After Effects and see if the issue persists?

Let us know. I am moving this thread from Bugs to Discussions for now.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

LATEST

Hi

No, it still doesn't work. I'm in the latest AE v24.4.

"03 square" has a size of 200x200 px.

"04 hexa" has a size of 600x600 px.

When I drag the "04 hexa" comp to the "Animated comp" property in the timeline, it creates a folder "Media Replacement Comps" and in that a comp called "Animated Comp_04 hexa 2". But the size of that new comp, "Animated Comp_04 hexa 2", is too small. It is the same size as "03 square" which will not be enough for "04 hexa". This is why it will look like nothing changes. The "04 hexa" is essentially cut to be a square.
In other words. When "No Scale" is selected and the comp is replaced, the comp created should be the same size as the  new source, not the original.

 

This is a bug. Let me know if I need to elaborate further.

All the best

Jakob Wagner

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines