• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
7

Dynamic Link Afetr Effects -Premiere Pro recurring media offline problem

New Here ,
Oct 16, 2020 Oct 16, 2020

Copy link to clipboard

Copied

Hi!

 

I have a Premiere Pro timeline with  many linkes After Effects compositions (about 8 comps).

 

Whenever I'm working in After Effects to change something and I save the project, ALL linked compositions in Premiere Pro go Offline. I need to relink them, and I can relink them no problem, becasue the project hasn't gone anywhere and hasn't changed name, but I lose my render files in Premiere and constantly relinking is being a total drag for my workflow.

 

Does anyone know if there's a fix for that?

 

 

TOPICS
Dynamic link , Error or problem

Views

9.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jun 11, 2023 Jun 11, 2023

Having the same issue, yet it only started today. Its been working fine until now. 

Votes

Translate

Translate
Community Expert ,
Oct 16, 2020 Oct 16, 2020

Copy link to clipboard

Copied

All of the dynamically linked comps in Premiere Pro should ideally be in the same AEP (project) file. If that is not the case I've seen things get lost if you have a bunch of project files. I always start the dynamic link process by opening AE first, then keeping AE open as I add new shots converted to comps. 

 

If my AE dynamically linked comps are at all complex and it takes several seconds a frame to render, I always undo the replace with AE comp in Premiere Pro, label the clip and change its color, then render the comp to a production format (not MP4 ever), import it into PPro and drop the rendered file right above the original shot. This is a lot faster in the long run because every time you change a comp that is dynamically linked to Premiere Pro the previews have to be re-rendered using AE in the background and that's always slower than just rendering the file. The more complicated the Comp the more likely you will have preview and rendering issues in Premiere Pro.

 

Most of my VFX work is done a shot at a time so I hardly ever use Dynamic Link. I just open AE, save the file, create a 10-second comp the same size and frame rate as my Premiere Pro sequence, then copy the shots in Premiere Pro and Past them to the new comp in AE. This creates a new comp in the Project panel for every shot in the timeline that I selected. It is a lot faster than creating a comp from selected and undoing the action in Premiere Pro. The original comp is just a placeholder and is never rendered. The only thing it does is set the frame size and frame rate for the new comps created from the selected footage.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

I am having the same issue. I have am AE project with 8-10 dynamic link compositions from a premiere project. Everytime I wish to change something or add a new composition into the project from premiere and save the AE project, all of my dynamic links become offline in premiere. It's super easy to link them back up but like Bernat says, I have to re-render all of my comp clips in premiere which is proving to be quite frustrating and time consuming! I am only seeing this issue from October onwards within this forum - could this be an issue with a previous update?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

Same issue here, is there a fix?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

I'm having the same issue.  All of my linked comps are in the same AE project, the projects isn't being moved or renamed, it's simply being saved.

 

Seems like a pretty awful bug if you ask me and is a pretty boring interruption to my workflow.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

Same issue here, and it appeared on all computers when my employer upgraded from 2019 to 2021. Even one simple comp from one AE-project makes it happen, so it's not about the complexity in comps or number of comps or number of projects linked.

 

Running Premiere 15.2.0, AE 18.2.1 and macOS Catalina 10.15.27

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Hi all,

We're sorry about the experience. Where do you save your Premiere Pro and After Effects files?

Which OS do you have? Are your media files saved on cloud?

Let us know. We're here to help.

 

Thanks,

Shivangi

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

MacOS 11.5.2

Brand new Premiere and After effects.

I have the same issue!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Drive is the local Mac internal SSD

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Hi Shivangi!

Thanks for responding. All my files, both projects and media, are saved on the usual hard drives in our production network. I will forward this thread to our technicians.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

I might have found a work-around:

For me it seemed to be the command "Replace With After Effects Composition" that resulted in all links breaking. Try finisihing your compositions in AE and then go back to Premiere and use "File > Adobe Dynamic Link > Import After Effects Composition" to import the same compositions and put these on your imeline instead. That made my links healthy!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

No, it is not related to that on my side and I always link like import AE comp 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

Thanks for sharing the workaround. We'll test it at our end too.

 

-Shivangi

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

An other workaround I found out.

1. Close Pr, close AE. 

2. Open Pr project --» It will say media pending

3. Open AE and wait a bit

 

With this I can make it work even with multiple AE files linked (the presence of the bug is not depending on that).

But every time I save on my AE file or I relink every asset (no auto relink working right now) or I redo this process...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

Thanks for sharing the workaround. We'll test it at our end too.

 

-Shivangi

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Same problem here. Everytime i change a single thing and save, dynamic links in premiere are offline. Is there a fix available?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

Same very frustrating issue.  Mac 11.6  After effects V18.4.1. Had this prpoblem in the version preceeding this one as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

You might want to try this:

After your AE comp is set the way that you like in Premiere's timeline select the AE comp and go to the top of the interface and go to clip/render and replace/choose a format. This will change the AE comp to a video which will be more stable. The video is saved by where your project is saved. If after that you need to make changes in AE you can highlight the video in Premiere's timeline and go to clip/restore unrendered. Highlight the comp in your project panel/right click/edit original.

Dynamic link is extremely powerful!

I hope that this helps

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

I have been experiencing the same issue intermittently. It seems to happen more often on projects that I have reopened and had to update because Premiere received an update at some point. The only way I've been able to resolve it is to click and drag the comp from After Effects into Premiere, and then "Replace With Clip From Bin" and delete the old dynamically linked comp. It's really inconvenient and I hope there's a better solution around it. Rendering and Replacing is a fine solution but not always the best with time sensitive deliverables.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I have the same problem. Latest update on everything. PLEASE fix this soon Adobe.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

Same here. I get tyred off adobe....always the same.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Same Here

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

Same issue on Mac and Windows system I'm using. AE Links fall offline in Premiere as soon as you save the AE project.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

Any word on this? This has been plaguing me as well now since the latest few updates. Anytime I save a dynamically linked AE project, it offlines in Premiere. The fastest solve then seems to be closing the Premiere project, and reopening it. We really need a fix for this!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2022 May 05, 2022

Copy link to clipboard

Copied

Same issue on top of Premiere hanging when importing AE project. Comp imports when dragged directly from AE, but any save in AE causes the clip to offline.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines