Entire screen goes black when I play back animation

Community Beginner ,
Aug 21, 2022 Aug 21, 2022

Copy link to clipboard

Copied

I've started using Adobe After Effects for the first time for a course. I'm having problems when I use it on my home computer. When I play back my animation (space bar), after a few seconds the entire screen will turn black, as if the monitor has been turned off. After a second or a few seconds, the screen will stop being black and I will see my animation (and the rest of the screen display), then after a few seconds it will go black again. It will keep flicking back and forth like this until I stop the animation (space bar). How do I fix this so I can do my work at home?

 

What I'm using:

 

Adobe After Effects

Version 22.5.0 (Build 53)
6% used of 7.9 GB
429 Plug-ins

 

PC SPECS:

Processor: Intel(R) Core(TM) i5-9400T CPU @ 1.80GHz 1.80 GHz
Installed RAM: 8.00 GB (7.87 GB usable)
System type: 64-bit operating system, x64-based processor

Windows Edition Windows 10 Home, Version 21H1

 

TOPICS
Error or problem , Performance , Preview

Views

73

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 21, 2022 Aug 21, 2022

Copy link to clipboard

Copied

Try 

- Purge disk cache

- Reset preferences

- Play around with GPU acceleration

- Update GPU drivers

- Remove third-party plugins one at a time and see if they are causing issues

 

Your system is also pretty underpowered. The minimum RAM to run AE is 16 GB. Also you didn't leave your GPU so no idea if that's good for AE.

 


~Jake

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

My GPU is: Intel UHD Graphics 630

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 21, 2022 Aug 21, 2022

Copy link to clipboard

Copied

Turn off GPU acceleration and use RAM previews. The behavior you describe is a typical sign that your GPU just doesn't have enough juice and the driver crashes over and over or the actual hardware can't handle the strees and causes errors. Of course that doesn't rule out that things couldn't be fixed with a driver update and tweaking soem settings as @Jqke already said...

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

My GPU is: Intel UHD Graphics 630. Unfortunately when I looked up how to turn off GPU acceleration, no option to do so appeared on Graphics Settings or Advanced display settings.

 

I also can't find out how to use RAM previews. I used these directions:

 

  1. Open up After Effects.
  2. Go into your AE Preferences. Click on After Effects > Preferences > Memory & Multiprocessing.
  3. Change ‘RAM for Other Applications’
  4. Click ‘Ok’ And you’re done! You should see an increase in your rendering speeds in After Effects.

 

"After Effects > Preferences > Memory & Multiprocessing" doesn't exist on my version of After Effects, only "Edit > Preferences > Memory and Performance". There was no setting for "RAM for Other Applications". Is there any other way to use RAM previews?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

RAM for other applications is in Edit > Preferences > Memory. Can you attach a screenshot of that window? And RAM previews just consist of pressing the spacebar. Allocating more RAM will help make it go faster.

 

Intel doesn't make good GPUs. That's why you'll find them in mobile computers. I don't think they have a GPU acceleration option anyway, so no need to worry about that in my opinion. You can double check by just going to File > Project Settings. Have you tried updating your drivers anyways? Might be more of an NVIDIA thing but driver updates tend to fix a lot of preview related problems.

 

 


~Jake

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2022 Aug 23, 2022

Copy link to clipboard

Copied

Here's a screenshot of Edit > Preferences > Memory ["Memory & Performance] on my version:

AfterEffects_screenshot_memory1.png

AfterEffects_screenshot_memory2.png

 

Project settings:

AfterEffects_screenshot_projectsettings.png

Should I switch to "Mercury Software Only"?

 

I did try updating my GPU driver, but it said I already have the best driver for my device installed:

gpu_screenshot.png

And I checked for updates but unfortunately it didn't make a difference:

 

gpu_screenshot2.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 23, 2022 Aug 23, 2022

Copy link to clipboard

Copied

LATEST

This is what you have to adjust to allow AE to render faster with RAM previews

Jqke_0-1661268449080.png

It looks like you have it at the smallest it goes. That might be an issue. The minimum RAM for AE is 16 GB. While you only have 8.

 

Definitely try to turn off GPU acceleration. That could be causing the issue. To do that just switch from Mercury OpenCL to Mercury Software Only. 

 

Did you try my other suggestions above? Clearing cache? Removing third-party plugins? Those could all be causing an issue.

 


~Jake

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines