Help! 3D Camera Tracker stuck at "Solving Camera"

Community Beginner ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

I've attempted it many times but it always just gets stuck at "Solving Camera". I left it my computer on overnight while it was on "Solving Camera" and woke up in the morning to "Solving Camera". Someone please help me as I want to get into 3D editing.

TOPICS
Error or problem

Views

96.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 17, 2015 Aug 17, 2015

‌Some shots will not solve. Have you tried others or tried trimming the existing shot?

For a shot to successfully camera track there must be a significant number of items in the shot that do not move. Things like buildings, furniture, roads. A sidewalk full of people or a field of wheat moving in the breeze, or water in a lake will not track well or at all times. Some codecs are harder to analyze than others. Without a lot more details about your shot and your workflow it is hard to say what is g

...

Likes

Translate

Translate
Adobe Community Professional ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

Nobody can tell you anything without proper system info or other technical details. We don't even know your version of AE, much less anything about your composition, footage used and so on.

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

Sorry.

I have Adobe CC, latest version, running on a PC with windows 10, 6GB RAM, Intel 2 core 2.4ghz cpu, AMD Radeon 7750 HD (pretty sure).

I thought maybe there was a simple setting I'm missing, I have no clue, plz help me out.

Footage used was 720p 30p and 1080p 24p mov

I hoped this helped!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

When you day "latest version", do you mean 13.5.1? Try it with CC 2014 (version 13.2.1) and see if it works properly. CC 2015 saw a major change in the architecture of AE, so sometimes to troubleshoot, it helps to try in the older version.

If you don't have the older version, read this: How to Find and Install Previous Version of Adobe Apps in CC 2015 | Adobe Customer Care Team

Note: you're using a very small amount of RAM for AE. Officially, the minimum recommended amount is 8 GB of RAM. I'd suggest at least 16 GB.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

‌Some shots will not solve. Have you tried others or tried trimming the existing shot?

For a shot to successfully camera track there must be a significant number of items in the shot that do not move. Things like buildings, furniture, roads. A sidewalk full of people or a field of wheat moving in the breeze, or water in a lake will not track well or at all times. Some codecs are harder to analyze than others. Without a lot more details about your shot and your workflow it is hard to say what is going on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

Aha thnx, I see what the problem was, my shots were either too fast or shaky, I just tried a shot now with a slow steady pan and it worked! Sorry if I wasted your guys time, as I am pretty nooby to all this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

No problem! We were all there once.

I'd recommend going through Adobe's help documentation on features like this. It often links to incredibly useful tutorials and has some rather helpful information as well.

However, if you're new to AE altogether, I'd suggest starting here: Getting started with After Effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

‌ok, I'll check it out, thnx!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

Also, how long does it take to finish the "Solving Camera" stage? Mine took about a minute on a 6 second vid.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

That depends on the shot, the kind of codec involved, and your computer's specs. If you're using a long-GOP codec (such as H.264) on a machine with specs as low as yours, that seems perfectly reasonable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2016 Mar 08, 2016

Copy link to clipboard

Copied

I'm having the same problem with a shot that is a car POV driving over a bridge.8 hours later the 10 second shot still says "solving camera" making me think it won't. Given what you've said above, is there any way to know whether or not it will ever happen? How long should I wait before I give up knowing it will never solve? Could you perhaps put a message in there that informs me when it has failed so I'm not waiting forever?

Thanks,

Rich

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2016 Mar 08, 2016

Copy link to clipboard

Copied

richa84643219 wrote:

Could you perhaps put a message in there that informs me when it has failed so I'm not waiting forever?

None of us work for Adobe; we are just users like you. So none of us can do that for you. If you want Adobe to add or change a feature, file a feature request: Feature Request/Bug Report Form

richa84643219 wrote:

I'm having the same problem with a shot that is a car POV driving over a bridge.8 hours later the 10 second shot still says "solving camera" making me think it won't.

Try transcoding your POV shot to an intermediate file format rather than using the h.264 file straight from the pov camera.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2017 Dec 02, 2017

Copy link to clipboard

Copied

Hi!

I tried it on AE CC 2014 for 3D tracking with Mettle SkyBox. On this version 3D racker worked relatively well.

Now I installed the latest version of the AE from Creative Claud along with the integrated Sky Box. Now the tracker hangs on the stage of the "Solving camera". On the site of Mettle Sky Box this text is written:

SkyBox Composer uses the native After Effects camera tracker, which usually works well, but is not able to solve everything. In order to track successfully there must be a significant number of items in the shot that do not move. Also - there is a known issue with the camera tracker in After Effects CC 2015 and WIN.

Please try the following:

1. Try to track in CC 2014 - the camera tracker works better.

2. Try to track on Mac OS, if available - the camera tracker works better.

If you are working in WIN in CC 2015, please file a report directly with Adobe.

Having decided the "Solving Camera" I need to go back to CC 2014 version? If it is right, how do I re-install the old version of CC 2014?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2018 Jan 27, 2018

Copy link to clipboard

Copied

at me did not work a footage in a tutorial the same footage worked why?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

LATEST

 

16411742292547312707334889977866.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines