illustrator file dimensions change when importing to after effects

Community Beginner ,
Oct 17, 2019 Oct 17, 2019

Copy link to clipboard

Copied

I'm trying to import a logo which has been created in illustrator into After effects so that I can create shapes from the vector to animate.

 

However, which ever way I import the .ai file the dimensions change on my composition, it becomes very tall! the logo .ai file and the after effect compositions settings are the same size. On import I am selecting 'composition - retain layer sizes'..... please advise?

 

Thanks

TOPICS
Import and export

Views

1.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Oct 17, 2019 Oct 17, 2019

Copy link to clipboard

Copied

Import is as 'composition' only. Maybe there is a leftover in the AI far outside of the artbord.

 

*Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 17, 2019 Oct 17, 2019

Copy link to clipboard

Copied

No that still didnt work.... however I just created a square in illustrator and imported that (so that I could use screen grabs without showing my clients logo).. it worked fine, went to drag the logo.ai file which was already in my project and it's now working.... weird! I have no idea what's gone on but it's not fine! ha thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

Solution.

I was having the same issue. When you are creating a new illustrator document try setting the document Raster Effects at 72 ppi.

 

A previous document had the raster effects set to 300 ppi and it was all sorts of wrong when I brought it in. I haven't tried verifying this with a second attempt  😛   good luck. 

 

- dan 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Make sure the import sequence is switched off.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

LATEST

Unless you are extruding a Shape layer with the C4D rendering engine, actually animating a vector path, using shape animators, or using a vector path as a motion path, there is absolutely no reason ever to convert a vector layer to a shape layer. Make sure that it is necessary. Shape layers have a native Anchor Point value of 0, 0. Vector layers converted to shape layers have an anchor point value of half the layer size and width. This makes copying vector paths to other shape layers or masks or motion paths problematic, but it can be solved by adding a null, parenting, then resetting the null's position to 0, 0. If you are faced with that problem, I have some links to instructions I have given for solving that problem.

 

danielc88124214 Document Raster settings have nothing to do with the size of an imported vector layer. They only control how far you can scale up a vector layer with raster effects like drop shadows before the effect starts to fall apart. You cannot efficiently convert AE shapes with Raster Effects, Gradients, Blends, Brushes, or any other effect into Shape layers. 

 

Document settings should be in Points or Pixels, Snap to Pixel should be turned on, and you should check the position of all thin lines using Pixel Preview in AI before importing the file as a composition to make sure you do not have antialiasing problems with thin lines, and your AI document cannot have multiple artboards unless there is one great big one below the main artboard. The main artboard should almost always be the same dimensions in points or pixels as the Comp. If you plan on scaling down any of the layers with thin lines, they should be a minimum of 2 pixels wide for a scale of 50% to avoid color shifts and anti-aliasing problems. 

 

There are about a dozen other recommendations that I have for creating problem-free AI files to be used in video production.

 

It sounds like you have solved your import as a comp size problem. I have seen cache problems or momentary glitches pop up before but have not experienced any of those problems with the current release of AE.

 

If you create the AI document with standard non-square frame sizes like HDV 1440 X 1080 or NTSC or PAL, After Effects will assume that the file is non-square pixels and distort the image. You can find the problem by checking the Info in the Project Panel with the file selected. If you see non-square pixels, you can fix the problem by properly interpreting the footage as Square Pixels.

 

I hope some of this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines