Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Language Setting not available in Preference> Type in CC 2020

Community Beginner ,
Jan 31, 2020 Jan 31, 2020

Copy link to clipboard

Copied

I tried pasting unicode Indian Language fonts in After effects CC 2020, and also copying and pasting from text programs, but they are all displayed wrong.

According to previous solution for this problem, these are the steps suggested - 

1. Go to Preferences>Type

2. Select ‘South Asian and Middle Eastern’ in ‘Text Engine’

3. Select ‘Indic’ in ‘Languages Selection’
But in CC 2020 Version, there is no ‘Languages Selection’ option in Preferences>Type.

So I can't change the formatting of my Indian language fonts to 'Indic' - which is required for correct displaying of Indian Unicode fonts. 

Please help me.

This option was available in previous versions of After effects as specified in the article link below -

https://blogs.adobe.com/creativedialogue/video/create-text-layers-in-indian-languages/

TOPICS
How to, User interface or workspaces

Views

3.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Dec 29, 2020 Dec 29, 2020
Hey, I figured this one out after a series of uncesseful attempts. Basically, change the text editor type to South Asian and Middle Easten (Edit >Preferences >Type> Text Engine). After which you need to have the font of the required language. Copy paste the text into a layer and usually the text might be jumbled up (not combined properly) All you need to do is, go to Paragraph window, right click on the panel name, and select, Reset Paragraph.  That should do it. Worked for me for languages like...

Likes

Translate

Translate
Adobe Community Professional ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

If you change the language settings from Creative Cloud Desktop tool, can you choose the language you look for?

 

https://helpx.adobe.com/creative-cloud/help/change-install-language.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 09, 2020 Feb 09, 2020

Copy link to clipboard

Copied

No, that does not solve problem. This is pertaining to wrong display and formatting of Indian language fonts, when I copy paste them from different text editor or directly type inside After effects with text tool.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2020 Jun 28, 2020

Copy link to clipboard

Copied

I have similar problem. Hope Adobe fix this soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Hey, 

You need to change the text editor type to South Asian and Middle Easten (Edit > Preferences > Type > Text Engine). After which you need to have the font of the required language. Unicode is preferable I think. Copy paste the text into a layer and usually the text might be jumbled up (not combined properly). Select the text and go to Paragraph window, right click on the panel name, and select, Reset Paragraph. That should do it. 

Hope this helps! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Thanks for the suggestion. Will definitely try it out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2020 Aug 31, 2020

Copy link to clipboard

Copied

At first, we thought we had this problem too, with setting Malayalam text for AE 2020. We adjusted the settings (Edit > Preferences > Type > South Asian and Middle Eastern). The Malayalam text appeared, but the characters were not combining correctly. Later, only after making a new composition, we see that Malayalam text (and all its character combinations) are correct.

 

Can you please try this: 1. Install an OpenType font that supports complex scripts (we used Noto Sans Malayalam) 2. Adjust the settings to South Asian and Middle Eastern 3. Close and re-open AE, and start a new composition, using your correct font.

 

Hopefully after these steps your text will appear correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 02, 2020 Sep 02, 2020

Copy link to clipboard

Copied

Hi tdfilmstudio1,

 

Sorry for your issues.

Did you try the suggestions provided by jasonk3? Did they help? If not, would you mind sharing screenshots that shows the issue? Also, what happens if you type the Indian language instead of pasting it? Does it work fine?

Let us know.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Hey, 

I figured this one out after a series of uncesseful attempts. Basically, change the text editor type to South Asian and Middle Easten (Edit >Preferences >Type> Text Engine). After which you need to have the font of the required language. Copy paste the text into a layer and usually the text might be jumbled up (not combined properly) All you need to do is, go to Paragraph window, right click on the panel name, and select, Reset Paragraph. 
That should do it. Worked for me for languages like Telugu and Tamil. 
I didnt face any problem for Hindi, but you can \check the boxes Hindi Digits and Ligatures in the Character panel too if nothing seems to work. 
Hope this helps for Indian Languages! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Thank You, that worked really well

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2021 May 30, 2021

Copy link to clipboard

Copied

LATEST

Thanks! Your solution worked for me as well!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines