Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


(MacOS) Rendering slows/pauses when AE is not forefront or screens go to sleep

Community Beginner ,
Mar 14, 2019 Mar 14, 2019

Copy link to clipboard

Copied

Is anyone else experiencing this? Sometime after my screen saver runs for a bit (it's not immediately tied to the screensaver), my screens go to sleep, or even just switching to a different application, After Effects 2019 slows rendering to a crawl. Just starting this thread in Chrome (5 minutes) created a three minute pause where AE didn't render anything. As soon as I switch back to AE it'll render a few frames, and keep rendering...till a few minutes after I switch back to any other application, where it slows/stops again.

Last night I set a number of sequences to render, all of them 2 seconds long. I set the screen saver to turn on after 1 hour, and display sleep after 3 hours, and made sure no other apps were open. Based on the frames rendered, an hour and a half after I left my computer (so not necessarily directly tied to the screensaver) After Effects dropped to about 3 frames every 4 hours or so. It took between 1 and 19 minutes to render each sequence...except after the monitors locked, it spent 14 hours barely rendering at all. Once I unlocked the displays, it finished that one sequence in a matter of minutes. It's now slowing down or pausing rendering every time I switch to a different program (I currently have four apps open - After Effects 2019, Chrome with 6 tabs, Activity Monitor, and Versions for SVN).

When at the forefront, After Effects is only using 1 or 2 out of the available 12 cores, and about 56GB out of the available 64GB RAM (according to the activity monitor it has about 11GB in compressed memory). CPU usage drops to about 1-2% of a single core when AE is not forefront. I assume this is what's happening when the screens lock as well (since it technically doesn't technically entirely stop rendering...it's just incomprehensibly slow).

Hardware: 2013 Mac Pro — 2.7 GHz 12-Core Intel Xeon E5, 64 GB 1866 MHz DDR3, dual AMD FirePro D700 6144MB, 1TB SSD

Software: MacOS High Sierra, version 10.13.6 (latest update for this version, I can't upgrade to Mojave yet due to other software requirements)

After Effects: CC 2019, 13.0.3 (latest update)

Any ideas? I've never had issues with MacOS throttling background apps before (I just rendered a bunch of 3D assets the other day in a different app without a hiccup), nor have I had issues before with AE killing itself when it's not the centre of attention...which appears to be what's happening now?

Views

4.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 21, 2019 May 21, 2019
Thank you all for the information, that's very valuable. Here is the update: we have confirmed that for some output modules, the machine would still switch AE to AppNap mode. We have put a fix for it and will be available in the coming release: 16.1.2. In the mean time, you may want to try the Workaround I posted on Apr 18.Thanks,ThomasAfter Effects Engineering Team

Likes

Translate

Translate
Community Beginner ,
Mar 14, 2019 Mar 14, 2019

Copy link to clipboard

Copied

Thankfully I was able to save my project back to AE v15 (CC 2018), and it's rendering in the background just fine (albeit still single-threaded, at least it doesn't pause itself constantly). Question still stands...anyone else having issues with AE v16 (CC 2019) not being able to render?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 15, 2019 Mar 15, 2019

Copy link to clipboard

Copied

Same issue here on an iMac 2017 and I have the pmset command set to no sleep in the terminal app and have also tried the caffeinate terminal command it still pauses. Pmset -g will show that After Effects should be keeping it from sleeping, but that does not seem to be the case. 1 minute project was supposed to take about 2 hours to render (ouch it is the same with metal or open cl), but when I left it overnight it had paused when the display turned off (no screensaver).

Screen Shot 2019-03-15 at 9.40.30 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

Hi guys,

Weird! I don't think this should happen. Let me check this with the After Effects team internally and get back to you.

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2019 Apr 12, 2019

Copy link to clipboard

Copied

Hi there,

We are having the same/similar issue.

We have an After Effects project that should take 10 minutes to render and it can take up to two hours if OSX turns the screens on to power saving mode.

After Effects:

Version 16.0.1 (Build 48)

Mac Pro:

OSX Sierra - Version 10.12.6

Mac Pro (Late 2013)

This is happening on multiple machines. I'll test the project on CC 2018 to see if it is isolated to a cc 2019 update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2019 Apr 14, 2019

Copy link to clipboard

Copied

Same issue.

MacOS 10.13.6

AE 16.1.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2019 Apr 15, 2019

Copy link to clipboard

Copied

Same issue. Exactly as the OP described. Long pauses in frame renders when the app loses focus or the display get put to sleep. I have a brand new machine (bought it about 90 days ago) with all fresh software.

Mid-2018 Macbook Pro

10.14 Mojave

AECC 2019 with the latest update

Using the C4D render engine

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2019 Apr 15, 2019

Copy link to clipboard

Copied

i also face face this issue, on CC2019

iMac with Mojave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

As a bandaid, I have set the display not to sleep when rendering and turned down the display brightness to save it from any burn-in risk...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

Hi all,

Is this happening with the After Effects Render Queue as well as Media Encoder?

I've spread the word across our engineering teams. So, the more info we have to decipher this, the better.

Let me know.

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

Render Queue for me. I wonder if anyone has tried the Mac SMC reset procedure to see if that helps as well...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

AE Render Queue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2019 Apr 18, 2019

Copy link to clipboard

Copied

Render queue for us.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

AE Render Queue.

Happened again tonight, left a render that should have taken a couple hours. Came back after 5 hours, cleared the screen saver, it was stalled at 70 frames. The render then started to move again on its own. Super frustrating as I have another render I was hoping to run overnight. Client won't be happy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

I can send this project file if it helps the engineering teams with repro.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 16, 2019 Apr 16, 2019

Copy link to clipboard

Copied

i don't think it's related to a specific project, i think it's a general bug, for me when i want to keep my Mac overnight, i change the energy setting/turn display off to never and reduce the screen brightness, it's the best solution till now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 18, 2019 Apr 18, 2019

Copy link to clipboard

Copied

Thank you for reporting the issue. This sounds like related to App Nap at first sight.

Under certain conditions, such as when an app is not visible on the screen, App Nap automatically puts the app into low power state.

Based on various inputs here, most people encountered it when rendering with RenderQueue and After Effects was not at foreground or screen went to sleep. I also noticed some mentioning about 3D workflow and C4D Render Engine. However, so far we haven't been able to reproduce the issue and we will keep trying.

By design, AE will not switch to App Nap mode when there is active rendering in RenderQueue. That being said, we have observed behavioral changes on App Nap depending on macOS version. There might be certain macOS setup or other reasons that cause AE switched to App Nap when shouldn't.

To Verify if AE got switched to App Nap Mode:

1. Open Activity Monitor.

2. Switch to Energy Tab.

3. Check After Effects and CineRenderAE (if C4D used).

When there is active rendering in RenderQueue:

- Preventing Sleep is expected to be 'YES'

- App Nap is expected to be 'NO'

Screen Shot 2019-04-18 at 2.31.12 PM.png

Possible Workaround:

If you have confirmed that AE got switched to App Nap when there is active rendering in render queue. Here are the steps to shut down the App Nap feature entirely. Note this will shut down App Nap not only for AE, but for all application.

1. Open Terminal

2. Type in "defaults read NSGlobalDomain NSAppSleepDisabled ". It should return '0' indicates App Nap is enabled.

3. Disable it by typing in "defaults write NSGlobalDomain NSAppSleepDisabled -bool YES"

4. Type in "defaults read NSGlobalDomain NSAppSleepDisabled ". It should return '1' as App Nap is disabled in step 3.

----

To re-enable:

Type in "defaults write NSGlobalDomain NSAppSleepDisabled -bool NO"

Please do let us know if this fix the issue for you. We are still investigating possible fix if that being the case.

Thank you,

Thomas

After Effects Engineering Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 29, 2019 Apr 29, 2019

Copy link to clipboard

Copied

Hi all,

Has Thomas's suggestion worked for you all?

Let us know.

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2019 Apr 29, 2019

Copy link to clipboard

Copied

Is the Adobe After Effects process only suppose to show up in Activity Monitor for a few seconds and then disappear? That is the behavior I'm seeing.

I am trying it now. In Activity Monitor under the Energy tab, Adobe After Effects is not always listed at first so I moved to the CPU tab and saw it and then switched to the Energy tab and it appeared for a few seconds.  App Nap: No Preventing Sleep: Yes

I have not tried the terminal settings change yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2019 Apr 29, 2019

Copy link to clipboard

Copied

I did have to use the Terminal commands to disable App Nap. Then AE would continue to render when the display went to sleep instead of pausing. Works!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2019 May 21, 2019

Copy link to clipboard

Copied

I have the same problem on both my iMacs (2012 and 2019). During long renders, the computer falls a sleep despite the correct settings in the system preferences.

Yesterday I noticed though, that when I render to Prores the computer stays awake and finished the complete render of 9 hours. Rendering the same project to a PNG sequence makes my computer fall a sleep after 20-30 minutes.  When I render to Prores "Preventing sleep" is set to "Yes" in the Activity Monitor. When I render to PNG sequence it is set to "No".

Not sure why this happens. I am glad I found this workaround, but I really would like to see this problem solved. Never had any problem with rendering overnight in the last 10 years and I really depend on these renders.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 21, 2019 May 21, 2019

Copy link to clipboard

Copied

Thank you for confirming. We have put a fix and would be available in the coming release: 16.1.2.

- Thomas

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

Thanks for confirming the update patch. Hopefully it will resolve this issue.

I can confirm that we are having the problem on ProRes export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 22, 2019 May 22, 2019

Copy link to clipboard

Copied

Thanks for the update! Looking forward to this new release.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 21, 2019 May 21, 2019

Copy link to clipboard

Copied

Thank you all for the information, that's very valuable.

Here is the update: we have confirmed that for some output modules, the machine would still switch AE to AppNap mode. We have put a fix for it and will be available in the coming release: 16.1.2. In the mean time, you may want to try the Workaround I posted on Apr 18.

Thanks,

Thomas

After Effects Engineering Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2