• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Problems With Shape Layer Pixelation on Apple Silicon (AE 22.x, 23.x 23.1x Beta)

Explorer ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

Hello.

I have been noticing a nasty bug that has been in every version of After Effects since the 2022 release, and it has been experienced on all the Apple Silicon computers I used, specifically:

  • Mac Mini M1 (late 2020)
  • Macbook Pro 16" M1 Max 64GB (late 2021)
  • Mac Studio M1 Ultra 48-Core 128GB (mid 2022)

 

The problem seems to be with shape layers.
I'm encountering all sorts of problems when I work with shape layers, specifically the fact they look pixelated even when at 100% view, which is unacceptable.
I have been using After Effects for 12 years, therefore I know how shape layers work and the rasterisation.

For example these are some shape layers in a 1080p comp (non precomped), and even at 100% view they look horribly pixelated:

Screenshot 2022-11-11 at 00.33.47.png

If this only showed up in the viewport, it would be bad, but not tragic...however I get this horrible pixelation even in renders.
There's just something wrong with shape layers.

If I work with 4K comps (I'm usign a 4K screen) they rasterisation looks ok, but I don't always work at 4K.
Do you have any idea what I could check inside AE?

Preview is on full, quality is on full (not draft), and I tested it both with and without hardware accelerated comps.
I really don't know what to do.

Thank you very much.

Views

107

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

It looks like you have the Layer Quality set to Draft.  

 

Do you have a project that you can share?

 

Shape Layers look fine on my end.

 

 

Layer Quality Switch set to Draft for Shape LayersLayer Quality Switch set to Draft for Shape Layers

 

Layer Quality Switch set to Best for Shape LayersLayer Quality Switch set to Best for Shape Layers

 

 

 

 

WarrenHeaton_2-1668132606091.png

 

 

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

You mean this setting?
Screenshot 2022-11-11 at 03.07.03.png
Anyway I notice it varies between each project.
Despite having the same settings, some projects have this problem, otehrs don't, but I can't figure out what's causing it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

Do you have a project file that you can share?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

Dumb After Effects.
For whatever reason it decided to set a "luminescence" blend mode which was causing this artifact.

I never use that blend mode, I don't even know what it does.

Anyway, since I'm here (by the way thank you), have you noticed any lackluster performance when using shape layers on apple silicon? I have all the performance aids enabled (hardware accelerated comps, multi-frame rendering, 80% of the ram dedicated exclusively on After Effects, 300GB of space dedicated to disk cache).
Most of my peers in the industry are either on windows or on intel, therefore making it hard to find a point of reference.
In my experience I found the M1 Ultra performance disappointing, given the 20cores and the encoders it has; I'm sure it flies with Davinci Resolve, Final Cut and Logic, but After Effects doesn't work as well as it should on such a machine.

I'd love to know what a community expert thinks regarding to this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

LATEST

It was a Blending Mode?  Good catch.  Thank you for sharing that you found the issue.

 

After Effects does not change Blending Modes on it's own.  Most likely, you pressed the keyboard shortcut for cycling through Blending Mode options without realizing it.

 

As far as performance goes, the M1 Max edges out the 16-Core 3.2GHz Intel Xeon W in just about everything in After Effects.  Making sure 3rd party plug-ins are M1 compatible has required some patience, but the After Effects team seems to be on top of working through campatiablity issues with developeers pretty well.  The M1 is still new tech.  It will be interesting to see what kind of render times we see wiht the M1 Extreme (or whatever Apple calls it).  If someone needs something really, really fast right now, check out the render times being reported for the lastest high-end AMD processors.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines