"Geometry options > Extrude" does not show up on imported AI file

New Here ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

Hey i do not have the option to extrude this path i have imported in from Illustrator. I have followed many step by step tutorials on how to use illustrator paths in after effects but i cannot progress past the point of "extrude" becuase that option does not show up. I can even edit the path in after effects so i know it is not a bitmap image it is a vector path. Why cant i extrude them?

Views

14.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

First thing to check: make sure the Illustrator file is RGB and NOT CMYK.  Change it to RGB if necessary.

That one simple thing is the cause of many woes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

i changed it to RGB resaved under a different file name and i still dont get the option to "extrude" under geometry. I even made a completely new file in illustrator with random shapes, and there is still no option to "extrude"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

Did you do these two steps?

1. Enable the 3D checkbox for the layer

2. Switch to the CINEMA 4D Renderer in the comp settings

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

If geometry options do not show up then you are in the wrong rendering mode. You have to switch to C4D rendering or if you are a glutton for punishment, Ray-traced rendering.

If the geometry options do not include Extrude then you are looking at pixels instead of vectors. It is entirely possible for an Illustrator layer to come in as pixels if you have added raster effects to the layer in AI. Things like drop shadow, blur, and a bunch of other effects are rasterized when the file is imported into AE and the layer is converted to pixels without any warning or notification. You can quickly check this by making sure that the Continuously Rasterize switch is on and then scale up or move the camera closer to the layer. If the edges go soft then the AI layer contains raster effects and has been turned into pixels. If the layer is pixels the only option is to bend the layer.

Just in case you don't know, you can always find the material and geometry properties of a layer by selecting the layer and pressing the A key twice. Any rendering engine you select in the Composition Settings other than Classic will show up in the top right corner of the Active Camera view in the Composition Panel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2018 Apr 15, 2018

Copy link to clipboard

Copied

I am having the same problem. The imported AI file is RGB, 3D box checked, render mode is C4D, continuous raster is on and Extrude still does not show up as an option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 15, 2018 Apr 15, 2018

Copy link to clipboard

Copied

Tray going to Layer > Convert To Shape Layer. Then do the same process on the new Shape layer. Does this work?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2018 Apr 15, 2018

Copy link to clipboard

Copied

That worked for me. Thanks. The path was Layer/Create/Create Shapes from Vector.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 15, 2018 Apr 15, 2018

Copy link to clipboard

Copied

Glad it helped. Can you please mark the answer as “correct” to help others who experience the same issue. Thanks 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2020 Mar 05, 2020

Copy link to clipboard

Copied

You can only extrude shapes and text.

Which means that your Illustrator layer must be converted to shape layer (Layer/create shapes from layer).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2020 Mar 05, 2020

Copy link to clipboard

Copied

Oups… "Create shapes from vector" !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 21, 2022 Aug 21, 2022

Copy link to clipboard

Copied

LATEST

I have the same issue.  My Create Shapes from Vector option is greyed out so this solution will not work.  Are there any other solutions that get the extrude option to show up under geometry?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines