Red Giant Trapcode causing 'Display Acceleration Disabled' Error message

Community Beginner ,
Jan 01, 2022 Jan 01, 2022

Copy link to clipboard

Copied

After I had started using Red Giant Trapcode effects the error message 'Display Acceleration Disabled' started appearing. Along with this, there has been noticable lag in the preview. I've tried a majority of the common fixes for this error and nothing has worked. Just wondering on if there is any fixes besides removing the program and After Effects all together. (After Effects 2022)

 

 

 

-Jay

TOPICS
Crash , Error or problem , Freeze or hang , Performance , Preview

Views

114

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 02, 2022 Jan 02, 2022
Update/Fix: Reinstalling Drivers fixes the glitch. Using the most recent RG Trapcode Version is also suggested. 

Likes

Translate

Translate
Adobe Community Professional ,
Jan 01, 2022 Jan 01, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

(Follow Up): I've tried everything on the FAQ, deleting %temp% files, and also uninstalling After Effects and Trapcode plugin. I also tried to recreate this on a different computer as well, to better understand how to fix it. On the other computer (after installing the same version of RG Trapcode and also opening the same project file) the 'Display Acceleration Disabled' error message did not appear but the preview was similarly glitched as it is on my computer. (Noticable Preview rendering to where you can see it render from top to bottom. Was not present before recreating it.) I've only seen one reddit post without a follow up having a similar problem with RG Trapcode but if this does happen to you the only likely way to fix this is a clean Windows Install. I'd also try avoiding the RG Trapcode version 15.0.1. The last thing I will try to do is reinstall After Effects on a seperate drive, but I doubt it will work to be honest.

 

 

 

-Jay

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

P.s. Also the rendering glitch is way worse on more demanding projects. The preview renders from top to bottom a lot more obviously and also it gets to a point where it just turns into black and white.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

P.S. (again) upon closing any project the error message: 'After Effects error: An unspecified error as occured. (512) ( 25 :: 16 )'

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Can you please share your system info? Like OS and version, CPU, RAM, GPU vRAM, Ae version and Trapcode version? Thanks. Also a screen grab of your issue will be helpful.

 

Also, have you requested a support ticket with Maxon/Red Giant? The reply rather quickly: https://support.maxon.net/hc/en-us/requests/new

FAQ: What information should I provide when asking a question on this forum?
https://community.adobe.com/t5/after-effects-discussions/faq-what-information-should-i-provide-when-...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Pc Specs:

 

Computer 1(My PC):

Type: Tower Pc

OS: Microsoft Windows 10 Home Ver.: 20H2 OS build: 19042.1415

Mobo: A320M-HDV R4.0 (AsRock)

CPU: AMD Ryzen 3 2300x Quad-Core Processor

GPU: AMD Radeon (TM) R9 390 Series

Memory(RAM): 16.0GB

Drives(2)

           Disk 0: WDC WD10EZEX-08WN4A0 (1TB)

           Disk 1(Windows Partition): Samsung SSD 980 PRO 1TB

 

Computer 2(Test PC😞

Type: Laptop 

OS: Microsoft Windows 10 Home Ver.: 21H1 OS build: 19043.1415

Mobo: 85E5 (HP)

CPU: Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz

GPU: Intel(R) UHD Graphics 620

Memory(RAM): 8.0GB

Drives(1):

           Disk 0(Windows Partition): SanDisk SD9SN8W-128G-1006

 

AfterFX Versions: 22.1.1 and 18.0

RG Trapcode Version: 15.0.1

 

Note: Couldn't supply a screen grab from the computer since OBS gave an error message of: 'If you are using the NVENC or AMD encoders, make sure your video drivers are up to date.' This error message wasn't present beforehand and I'm still using the same AMD drivers version.(Since AMD discontinued the drivers for my GPU in March 2021:/) this error message is most likely because of the same reason that AfterFX stopped working. (Makes me believe that the fix might have to be reinstalling video drivers completely) I do plan on contacting Maxon about the issue once I try to reinstall the drivers.(Will Follow up on if it works and also Maxon's reply)

Side Note: I also believe that the reason the Laptop didn't display the AE error 'Display Acceleration Disabled' is because it isn't using an AMD or Nvidia graphic card.

 

Description of Screenshot: When in motion it is very visible screen tearing, which is sometimes interrupted by a frame of black or white in more demanding projects. 

 

 

-Jay

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

LATEST

Update/Fix: Reinstalling Drivers fixes the glitch. Using the most recent RG Trapcode Version is also suggested. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines