• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Render and replace, render but don't replace

New Here ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

Hi everyone!

When i'm trying to render and replace a After effect composition inside Premiere Pro, the clip is rendered but it's not replace, i have to manually put on top of the After effect compositin, but when i watch other people's tutorial, it work perfectly fine and the After effect composition is automatically replaced.

How can i fix this ?

TOPICS
Dynamic link , Error or problem

Views

1.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

Without more specific info about your project, your system and so on we can't realyl tel lyou much, but it seems you misunderstand the function. The render & replace usage only works within AE itself, not outside it. You could e.g. render a pre-composition and have its usage replaced in the project, but the project itself doesn#t know that the original comp was used in a Premiere sequence via DynamicLink.

 

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

I'm on macOS Ventura 13.1and the latest version of Premiere Pro and After effect

as you can see, https://www.youtube.com/watch?v=sMwtLXy45js&t=161s&ab_channel=Olufemii

this is what i'm trying to achieve, and the after effect composition does not turn into a clip on my timeline.

In the example that i provide bellow i previously did the "render and replace" process, (just like on the tutorial), the composition got rendered but the on the timeline the red bar stayed the same wich means that the after effect composition is still on the timeline.

And as you can see on the example I provide you, I have to manually search for the rendered file and place it on top of the After effect comp.

I'm trying to avoid this extra step and have it automatically replaced.

 

https://drive.google.com/file/d/1y2fiqRpOvFPMcfj4VvkvLV4ZbDi1jX4K/view?usp=share_link

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2023 Jan 28, 2023

Copy link to clipboard

Copied

If you have not opened the Edit/Template/Output Module menu and fouled up the settings, all you should have to do is use the Composition/Pre-render menu and choose a folder to save the rendered file. 

 

Any nested composition (pre-comp) selected in the Project Panel or open in the timeline will be added to the Render Queue. The Output Module will be set to render a High Quality With Alpha movie and replace the nested comp in every composition it is in. You should never render an MP4 to use as a production master, and there is no need to fiddle with the Output Module presets unless you have an expert's knowledge of video standards, formats, and compression.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2023 Jan 29, 2023

Copy link to clipboard

Copied

Hi thank for your answer but that didn't change anything the composition got rendered but it still hasn't automatically change the After effect composition to the rendered clip on the Premiere pro timeline.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2023 Mar 13, 2023

Copy link to clipboard

Copied

@Matthieu2405484496h8 I am running into the same concern currently. Were you able to find a workaround that I could use as a guide to resolve this concern?

 

Thank you in advance 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

LATEST

I found it depends the location the project has. Sometimes I worked the project on my internal ssd and the render and replaces works fine but when I do the project on an external ssd instead, specially a G-drive, the render and replace, render but not replace. I dont know if maybe its about the disk format.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines