• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Rendering Issue

New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

When I render with a transparent background (format animation and RGB + Alpha) it comes out all blue hued and the video is super choppy. Is there a way to fix this?

TOPICS
Error or problem , Import and export , Performance

Views

609

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I assume you're referring to the Quicktime - Animation codec? That's pretty outdated at this point. 
If you look at the Output Module presets in Render Queue, "High Quality with Alpha" will use ProRes 4444. Have you tried this one? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

This fixed the choppiness, but not the transparent background.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Silly/obvious question, but since I can't see your project - you definitely don't have anything in the comp itself that would be fighting with the transparency? A layer using Blending Modes, for example? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I do not. I don't know if this makes sense but even when i change the comp background to white it still renders with a black background

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Are you able to share some screenshots (the full UI, as detailed as possible), and/or the project file? It's a bit hard to troubleshoot this without more context. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

if you need more let me know

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Lots of variables at play here, since you're compositing a bunch of other gifs together.

For the sake of argument, try creating a new, empty composition. Add some simple shapes or text and try to use this same exporting method. If that comes out clean, then the problem lies in the timeline you've constructed.
If not, then it's a more general exporting issue, and we can investigate that. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I tried rendereing random shapes and it still didn't work 😞

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Ok, that's a data point, at least. 
The first thing I'd check - are your video card drivers up to date? 
Can you post your system specs & which specific version of Ae you're using? (Help > About After Effects)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Thought - what are you using to VIEW this file you're creating? 
Are you able to post your exports using a file-sharing service?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

I've tried opening it in various video applications on windows. heres the video link https://drive.google.com/file/d/1jQavUNvKgOJ4OefM4HA0OvegMieswBX9/view?usp=sharing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

This plays smoothly on my system. The alpha channel works correctly and there are no blue artifacts of any kind.
Screenshot 2023-11-09 091848.jpgScreenshot 2023-11-09 092006.jpgScreenshot 2023-11-09 091933.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

hmm so do you think it's just the player i'm using? because even when I try to convert it to a gif it has a black background. Thank you for all your help by the way!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

Would you mind just making the video a gif for me? Seems like you have it figured out and it might be the easiest way to get this figured out. I attached a bitter sized video if you wouldn't mind. 🙂 https://drive.google.com/file/d/1esAHdUwSx8K44XuQWM5S50QAjDBCrykY/view?usp=sharing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

I do think your player is the issue (or the playback codecs on your system), yes. 

Have you tried some of the online gif encoders like ezgif.com or giphy? 

If that doesn't work, I don't mind making it for you, if you are clear about the exact specs you need.
So you're looking for a gif? Specific frame size? Have a specific file size limit? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

I've tried ezgif, converto, adobe express and others and all have given me a black background. I would appreciate if you could make it 1000 x 1000 px, the file size doesn't matter, frame rate 16-20. Thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

The more recent file you provided does have a black background baked into it, which would be why that one wasn't working out for you. A good way to check alpha in your exports is to import it back into After Effects, and check to make sure you can see the transparency grid behind it. 

 

Screenshot 2023-11-09 123233.jpg


This makes for a pretty large file (in gif terms), but it's here, along with an optimized version that's a bit smaller. 
https://www.dropbox.com/scl/fo/kc37qt6rjvzq5jj3hwgbv/h?rlkey=da622zqo8rehoe2vm7x8qf344&dl=0

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

Ohh I see. I guess when I resized it, it created a background on it. Either way thank you so much for all your help! I really appreciate it!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

LATEST

No problem. Hope everyone enjoys dino nuggie. :cat_face:‍:dragon:

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines