Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Saber plugin can't export in transparent mode

Community Beginner ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Hi, I was trying to export my video in transparent mode, have tried many ways,but it still turned out showing background colour. I did turn on the transparent mode in the saber render setting, video output chanel in rgb and alpha mode,no solid colour, so when i preview the video is in transparent mode, but when i export it , it showed my composition background colour. 

TOPICS
Import and export

Views

735

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Do you see the transparent grid in the Composition when you toggle the transparency grid in After Effects? 

 

Saber plugin can be exported with Alpha chnanel and it works fine for me when exported in Quicktime > Animation > RGB + Alpha. 

Vishu Aggarwal
Adobe Certified Instructor, Professional and Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

yes, I can see the transparent grid, I did exactly the same method as yours but couldn't work for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Can you be more specific about what format you're exporting to?
Are you using any blending modes on the layer that has Saber applied?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

not using any blending mode, I exported in different way, png work fine , is in transparent mode, not working when exported to quicktime, aftercodes

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

This and your other responses makes me think you might be trying to export into a format that doesn't actually support an alpha channel. If a PNG sequence works correctly, that means AE/Saber isn't the problem, it's the format you're choosing. 

If you can be extremely specific about what format & settings you're trying to export to, we can give you more precise help. "Quicktime" isn't enough, as there are hundreds of different flavors of Quicktime.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

I just want to export to a video, so I can create GIF in photoshop. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

I applied exactly the settings you're using (from what I can tell from your screenshots), and this works as expected, giving me an exported video file with alpha. Previewing it in a program capable of seeing the alpha channel (like AE or Photoshop) shows that's indeed the case. 


To clarify, is the gif creation step where you're actually having trouble maintaining the alpha channel? 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

hi, after I tried to create a new AE document and import the previous composition and export , it finally ged rid of the background. but when i create gif by importing the video file, the final outcome still show a white border around, as shown in the attached image in canva . Is it because of the smoke effect? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

Gif doesn't really have the ability to handle transparency well. It's a 30+ year old format that probably should have died long ago. 😉 Essentially, pixels in a gif are either all the way on or all the way off, so anything like glow, smoke or similar effects that rely on partial transparency just aren't going to work well in this format, unfortunately.

 

Is Canva able to import an image sequence? That's the route I'd try.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

LATEST

You should change in the saber plugin option. Under "Render Settings" > change "Composite Settings" from "Black" to "Transparent".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines