Slow work of After Effect Tracking motion

New Here ,
Jan 09, 2019 Jan 09, 2019

Copy link to clipboard

Copied

Hi All,

I would like to check if this is happening to me only or this is the product work in general.

I have After Effect 15.1.1 version and PC Win 10 / 32Gb RAM/ Samsung 960 M.2 SSD / i7-7820X / GTX 1070 8Gb.

When I'm doing a tracking of a small area and tracking of a slow movement it takes more than a minute to move from frame to frame. I do not see any CPU usage or memory usage while tracking, looks like it does nothing all the time and only the last second create a point and move to another frame.

Maybe I have some misconfiguration, however, I did not found anything or any kind of settings related to a tracking mode specifically.

Note: I did try it on the 4k video, Full HD video and even on 720p video, the result is exactly the same. Each frame tracking done in between 60 to 80 seconds.

Do you have any suggestions about it?

Thanks

Views

7.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 09, 2019 Jan 09, 2019

Copy link to clipboard

Copied

2 suggestions.

re-set preferences... On Mac hold down cmnd/option/shift while the app is opening orr on Windows hold down cintros/alt/shift while the app is opening.

Also try going to Edit/Preferences/ Media and Disk Cache (on Windows) or After Effects/Preferences/Media and Disk Cache (On Mac)

And use the options to clean the cache.

I hope that this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2019 Jan 09, 2019

Copy link to clipboard

Copied

Thanks for a fast reply, I have done all the steps you said and now it takes about 15-20 sec per frame.  I believe this is the maximum I can get from this software.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 09, 2019 Jan 09, 2019

Copy link to clipboard

Copied

The speed of the tracker depends entirely on how big the feature area and search area are. The codec of the original footage can also influence the time it takes to analyze a frame. MP4 compressed movies are interframe compressed so the CPU has to figure out where the pixels go in the in-between frames and create them before they can be tracked. Visually lossless formats don't have that issue. Every frame contains all the data in a frame, so every operation in AE that is looking at the pixels in the frame will be faster when you use formats that are not using GOP compression (Group of pictures). All MPEG compression uses some kind of GOP compression and it not very suitable for production.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2019 Oct 15, 2019

Copy link to clipboard

Copied

I had a similar issue.

 

I was able to resolve this by choosing a much smaller area to track. I initially thought I'd chosen a pretty small area to track, but once I halved the size, everything processed way faster.

 

Very slowVery slowWay fasterWay faster

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2020 May 07, 2020

Copy link to clipboard

Copied

Hi. I have similar issue in cc2020, 17.0.5 build 16, but reducing the tracker search area only improve speed a little. I' ve tried to reset prefs but didn't help. I'm lost with this, because in an older machine with cc2018 tracking motion is really faster. Please a need some help. Could it be related to the graphics card drivers, or maybe to any plugin i have installed? My nvidia drivers are up to date, is there maybe any concrete version of the driver working better? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Im also having an extremely hard time here, I'm 2 hours 22minutes in on a 0:05:00 second clip where all I'm doing is tracking a face and I've currently only tracked 0:01:06 getting pretty annoyed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

This unbearable times of the tracker has nothing to do with the search area size, in my case after a clean reinstall of windows 10 and after effects cc2020, began installing one by one every driver and program and trying the tracker after every single install. After this i found that what has been causing this problem was the program Acronis True Image 2019. Only needed to deactivate the Real Time protection and voila! Tracker worked perfectly again. Hope your problem is the same, otherwise you'll need to investigate what program is causing you the problem. If you are using a pen tablet check the drivers too, in my case the Wacom Bamboo mte450 driver was causing a little slow down on after effects too. Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Same issue here. I also reinstalled Windows 10 and formatted all my hard disks. complete fresh start. First thing i did was tested the tracker and its just as slow as before.. after installing my gpu driver its still slow. I dont have any programs installed. this is driving me crazy i invested in a 2,5k video-editing desktop and then stuff like this happens.. do you have any tips?

Thankyou

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2020 Jul 01, 2020

Copy link to clipboard

Copied

 

Wow, Spot on - thanks a bunch Gasanfar!  I have the same issue with Acronis True Image 2020, but once I turned off active protection my AE motion tracking speeds are back to normal.  I initially had a feeling that active protection might slow my computer down a bit, but I totally forgot about it and probably would've never thought these two issues were related. 

 

You saved me a ton of time troubleshooting - thanks again!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

Gasanfar
WTF, exactly this was the problem..
Thank you a lot, this saved my day!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 16, 2021 Jan 16, 2021

Copy link to clipboard

Copied

I had the same issue. I have a fast processor, fast GPU, plenty of ram. AE motion tracking was slow as molasses. None of my resources were being taxed.

 

I also have Acronis True Image, I disabled active protection, and BOOM. Problem solved. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

Thank you SO MUCH for posting this. I had the exact same issue. You just saved me hours! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

You're welcome, glad to be of any help!
Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

@Gasanfar, you are a life saver. I think Acronis would have been one of the last things I would have blamed. Unfortunately just disabling protection did not help for me. I had to kill processes all the time or as I did afterwards, just uninstalled Acronis.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

LATEST

Confirm! I had to disable all Acronis services and reboot computer. No more problems with tracking.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2021 Jan 17, 2021

Copy link to clipboard

Copied

I'm so glad this has helped all of you,  it took me several days and effort to find out this silly thing breaking my brains with AE.

Cheers!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines