Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Smooth my wiggle!

Enthusiast ,
Feb 03, 2009 Feb 03, 2009

Copy link to clipboard

Copied

Hey all!

I am wiggling a Null position as an emitter for Particular. However, the resulting wiggle is pretty jaggy.

I found Dan's smoothing function:
temp = thisComp.layer("Null 11").transform.position.smooth(1);
[temp[0], temp[1]]

But it only make my streaks smaller, not smoother. They are just as angular as before.

Photobucket
TOPICS
Expressions

Views

27.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 03, 2009 Feb 03, 2009

Copy link to clipboard

Copied

The problem isn't with wiggle() per se, it's that the wiggle is getting sampled too infrequently to give you a result that is representative of the motion of the emitter. The emitter's position is being evaluated on every frame, but the emitter is moving so much between the frames that a lot of information about the motion path simply never gets sampled.

The only way to get that information onscreen is to reduce the frequence of the wiggle. This will necessarily make your particle animation run slower (you'll also need to increase the lifespan of your particles in inverse proportion to compensate). Then you'll have to nest your particle layer and the emitter null (plus any other layers on which Particular depends) and use time remapping to speed up the animation proportionally.

Also, you might already know this, but Particular allows you to use a light as an emitter control without having to muck around with expressions to tie it to Particular's emitter properties.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 22, 2009 May 22, 2009

Copy link to clipboard

Copied

You could also try increasing the frame rate of the particular comp to 99 fps, then drop this into another comp with your desired frame rate.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 24, 2009 May 24, 2009

Copy link to clipboard

Copied

Good suggestion!  I'll try it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2009 Nov 28, 2009

Copy link to clipboard

Copied

You can also try:

seedRandom(time*5);

wiggle(0,100);

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 29, 2009 Nov 29, 2009

Copy link to clipboard

Copied

hi

if you have V2 of particular just turn on Position Subframe>10xSmooth that's all 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

LATEST

Assiste essa aulta no tempo que deixei o link  https://youtu.be/XR0wlcNK19Q?t=407

MotionDesign #AfterEffectsCC #AnimationNesse tutorial, Gabriel Felix ensina 23 expressões no After Effects!Gabriel Felix - https://www.instagram.com/gabriel...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines