• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

X and Y axis rotation doesn't work on pre composed layers

New Here ,
Apr 21, 2022 Apr 21, 2022

Copy link to clipboard

Copied

Hi So I am using the 3d mode in after effects on some of the layers in my composition. The layer I want to rotate on the Y axis is not moving with the Y or X axis, even though it rotates fine on the Z axis. I tried doing the same thing within the precomposition and the regular layers (which i imported from photoshop) rotate on all axises just fine. What can I do to enable the precomposed layer to function the same as a regular layer?

TOPICS
Error or problem , How to , Resources

Views

2.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2022 Apr 21, 2022

Copy link to clipboard

Copied

Sorry I realised I wasnt very clear here. The precomposed layer does not rotate at all on the X or Y axis, only on the z axis. A regular layer that isn't a precomp works fine so I don't think it's an issue with enabling 3D mode

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 21, 2022 Apr 21, 2022

Copy link to clipboard

Copied

Without seeing your timeline and the modified properties of the problem layers, there is no way to know what is going on in the comp. Collapse Transformations will make the Camera and lights in the main comp affect the 3D layers in a nested comp. 

 

We need to see both the switches and modes panel, and having the problem comp selected in the Project panel will help. Please select the problem layers, press the U key twice to reveal all modified properties, then take a screenshot of the entire UI. Then copy the file and paste it to the reply field on the forum or use the Toolbar to embed the image so we can see it. Maybe we can help you figure out what is going on. 

 

A fully expanded flow chart could also be helpful. I am seeing no unexpected behavior. 

 

* The "Drag & Drop here..." area is buggy and should not be used to share images. Please use the toolbar or just drag your images to the reply field.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2023 Feb 02, 2023

Copy link to clipboard

Copied

I stuck with this issue too, so I resolved it with settings to the 3d all the inner layers of precompose.  (Jump incide of precompose and click on cube icon for earch layer inside) and it allowed me to rotate x & y the whole precompose.
Still not sure if it's the best solution, so if someone have a better one — will be happy to hear. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 02, 2023 Feb 02, 2023

Copy link to clipboard

Copied

I remember this post at the time, and I'm still not sure what the problem is.  It sounds like the OP is/was hoping to rotate the precomposed layer on the Y axis, but was unable to.  A precomposed layer in 3D space is the equivalent of a video in 3D space.  In order to see the layers of the precomp rotate in 3D, you need to use the collapse transformation option.  But if the layers in the precomp are 2D, then there would be nothing to see. 

 

If I've got the wrong end of the stick, please can you post screenshots to illustrate the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 17, 2023 Aug 17, 2023

Copy link to clipboard

Copied

LATEST

What has worked for me — Go into the precomposed composition and turn on the 3D Layer box on all the layers. This will enable the 3D customizations on the precomposed layer (back out). 

I ran into this same issue and this solved it for me in seconds. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines