CUDA / GPU Render Not Working

Explorer ,
May 21, 2020

Copy link to clipboard

Copied

Hi, When rendering in Ae 2020 on my Windows 10 PC (Nvidia RTX 2060, I7-9750, 32gb) the GPU is not being used and the render times are super slow.  I've updated my GPU Studio Driver from Nvidia's site and added my GPU to the retracer.txt file.  Still no change.  Any suggestions to get GPU rendering to work here in Ae?   
 
johnn42789336_1-1590049832606.png

 

 
johnn42789336_2-1590049832607.png

 

TOPICS
Error or problem, Import and export, Performance, Preview

Views

1.2K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

After Effects seems to recognize RTX 2060. Just in case, would you check (or change) Manage 3D setting in Nvidia control panel?

 

3D Settings > Manage 3D setting > Program Setting tab > Choose Adobe After Effects > CUDA - GPU

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Crewman1 AUTHOR
Explorer ,
May 21, 2020

Copy link to clipboard

Copied

I did this.  There were 2 choices 1) Use global settings (RTX 2060) which is the default and 2) Use these GPUs (RTX 2060).  I changed it #2 but still no change, just using the GPU 2-3%.  Is that normal for 2D animation project?  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 21, 2020

Copy link to clipboard

Copied

After Effects doesn't use the GPU in the same way that you see it used in, say, Premiere. You don't enable an option and everything automatically becomes faster.

 

Several parts of AE are GPU-accelerated and many effects are, but many more aren't. Read this article for a bit of info about GPU acceleration in AE: https://helpx.adobe.com/after-effects/using/basics-gpu-after-effects.html

 

You don't need to add your GPU to a text file, that was related to a part of AE that doesn't even exist anymore called the Ray-traced 3D Renderer. The fact is, After Effects doesn't use the GPU as much as you would like it to, but it gets faster with every release are more functions are rewritten to use the GPU. There are a number of ways to improve playback or to be efficient with 2D animation and that includes not previewing at full resolution in your Comp panel, skipping frames during preview (expand the entire Preview panel to see all the options you have available), disabling certain effects until final render, turning off motion blur (although in certain circumstances Motion Blur is now rendered on the GPU), and many other things. 

******[Please use the "Reply" button under the FIRST POST to ensure replies sort properly.]******

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more