How to get an equivalent of the ‘Continuously Raster’ function on the precomposed layers ?

Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Hello to all.

I have a recurrent problem using vector layers, precomps and cameras.
I want to precise before that :

  • 100% of my work in AE provides from vector/illustrator layers
  • I check ‘Continuously Raster’ for each layer, but not for precomps
  • The camera I create are one node cameras, with depth of field inactivated
  • The problem is the same if, instead of using a camera, I create and use a scale property on a general precomp that which includes all of my layers (so it is not a problem of camera, but a general a global understanding that escapes me !).

 

So the problem is that I get blur on all my layers that are in precomp if I use a zoom effect on my scene.
The precomposed layers are not clear as thez should be, as the others layers (not precomposed) are for instance.

It seems to be normal : there is no ‘Continuously Raster’ on these layers - as it works différently for these precomposed layers.

So my question is : how to get an equivalent of the ‘Continuously Raster’ on the precomposed layers ?

I join a graphics to be more explicite :

aftereffectsflouobjetsanimes_02.jpg

 

Thank you for your help !

 

 

TOPICS
Error or problem

Views

389

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Did you try turning off the continuous raster layers inside the pre-comps ... and then turn it on for the pre-comp layers in the main comp (so they should be all switched on in main comp)? 🤔😮

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Thank you for your answer.


* I forgot to say I used puppet tool on several layers (but not for all : for some precomp layers I used only scales or position changes)


Your answer : Yes I did that. But turning it on for the pre-comp layers in the main comp creates new strange things (the scales are not the same, for instance), so this is unusable.

 

I think there is an idea (that I remember I read last year) like : creating a new precomp on each layer, individually. And activate 'continuous raster' only on these new precomp (or on the layers inside ?). But I don't remember exactly, and my tests are not ok yet...

Adobe help center explains that : "Don't animate the position or scale of a continuously rasterized layer with layer transformations if you also animate the layer with the Puppet tools." and "You can precompose the shape layer and use the Puppet tools on the precompose layer, or you can use the Puppet tools to transform the shapes in the layer."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

- Yes I have tried puppet pinning a precomp of layers before and it blurred 😮 In your case i would take the layers out of the precomp into the main comp and parent to a null object which will move the entire character and animations around.

(create new null and position it on or under character then parent the character layers to body and parent body to the null object layer... you can color code each character layers to keep it tidy)... that is wht i would do for now

 

- is the blur happening without the camera? 

 

This is a good video

https://www.youtube.com/watch?v=J3ApvB8sqD0

 

In this tutorial we're going to talk about the Collapse Transformations and Continuously Rasterize switch in After Effects. Download the Project File: https:...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

hello an thank you for your answer.

Indeed, this solution of "nul camera" reminds me something (I've already used it in the past).
But here unfortunatly it doesn't really change the blur.
Here is a capture :

aftereffectsflouobjetsanimes_03.jpg

 

And without a camera, i think it's ok, no blur...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

I meant to use Null Objects (Layer - New - Null Object)

 

- And bring your character layers out into the main comp .... so you have NO pre-comps

 

- The Null Object can move your character like a group - my null object here is the red box - it will move/scale/rotate the character layers

 

Don't need a pre-comp for this 🤔

 

Null-1.gifNull-2.gif

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

If I use pre-comp, it is :

- to group the 2, 3 or 4 layers that compose some of my characters ! (example : right and left arm, right and left foot, body = 5 layers !)

- to simplify my board.

If I put every layer on the same level, I would get around more than 200 layers !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

I know that pain! 😂

If you go into your pre-comp of a blurry character - hit CTRL +K to bring up composition settings - go into advanced tab and check box - Preserve Resolution When Nested -

Does this change anything?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Hey I think i may HAVE replicated what you are doing ....

 

If you click on the Continuous Rasterize switch for your character pre-comps

THEN - double click into the pre-comp and enable the 3D SWITCHES  there also

 

🤔

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

I didn't know this feature : very interesting. However no effect on my "blurry problem" 😞

 

I think that I was wrong a few before : without camera it is the same problem. The camera just ampligy it (when zooming).

I created a very simple new file : a vector tree (with a trunk, 3 branches and a foliage of 3 circles) in a field. Difficult to make simplier...

For the moment what I see is :
- impossible to use the puppet tool on the tree if the '‘Continuously Raster’ is checked (if I succeeded in this before, it was because I checked the '‘Continuously Raster’ after using the puppet tool !)
- If the '‘Continuously Raster’ is unchecked (at the level "tree" OR the level "branch, trunk,..") the tree is blur

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

"amplifying it (when zooming)" 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Yes I get you ... I have puppeted my characters before and noticed the very same thing!

 

You know what I did... I exported my character layers as a Quicktime - Animation - RGB and Alpha

I bring that in and puppet pin that instead

This is what I do all the time when I need to puppet a pre-comp

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Oh my...  And I know what my client will ask me tomorrow : "could you change just 2 or 3 things about this person who applauds a little strangely for my taste, that yclist that goes too quick, and that painter that is too fast ?" 😄

 

In its help, Adobe notices this: Do not animate the position or scale of a continuously rasterized layer with layer transformations if you also animate the layer with the Puppet tools. The rendering order of continuously rasterized layers (such as shape and text layers) is different from the rendering order of rasterized layers. In addition to this, you need to know more about it.

And Adobe adds: You can precompose the shape layer and use the Puppet tools on the precompose layer, or you can use the Puppet tools to transform the shapes in the layer

What do you think of these(perhaps)  tracks ?

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

To be honest i never use shape layers! 😂 I cannot understand them at all. They give me serious nightmares ... here is my process.....

 

Here is pre-comp with puppet pins....

puppet-1.gif

It BREAKS when you want to move it!  😣😂

 

puppet-2.gif

 

So I trim the timeline to a couple of frames .... and export as a Quicktime - Animation - RGB and Alpha

puppet-3.gif

puppet-4.gif

Now I bring in that movie clip into the timeline instead of the precomp  -  to stretch the clip the length of the time line - right click it - select TIME - ENABLE TIME REMAPPING and just drag it to the end of the timeline.

This movie layer doesn't use continuous rasterize as it has a specific size - so if I want to zoom I will make sure the artwork is LARGE before exporting the movie clip.

 

Maybe that does not fix your problem? But I don't know how to puppet pin a pre-comp without quality problems.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

- Of course you could puppet pin the shapes themselves and maybe pre-compose them later on?

 

- Or you could have the main comp timeline and viewer open looking at your character in the scene... then open a SECOND viewer and second timeline for inside the precomp and puppet pin animate in there?

🤷‍:male_sign:😂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

I thank you very much for your help.

I found back a half of my characters : the one that were not animated by the puppet tool are ok now :  I am ashamed to notice that I had deselected their ‘Continuously Raster’ function (I treated them like the one animated by puppet tool : as I thought their problem was the same one) 😞

 

So, Im glad to find them back. I have only 4 characters left with the puppet tool. I think I will see tomorrow if I can't draw them in another way, to avoid this tool and to animate these characters in a simplier way...

Ro Hackett I thank you very much for your help. I will see your last solution tomorrow too. (Time for sleep, I'm exhausted ! 😄 )

Bye bye

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Hello and have an happy new year here.

I'm coming back because I have the solution to work on vector layers, with a puppet effect on it without cancelling the 'continuous raster' function on it : you need to work with an adjustment layer, over the vector layer.

- Create an adjustment layer over the vector layer.
- Precomp the 2 layers
- Apply the puppet on the adjutment layer, (not the vector layer)

- Of course don't forget to put the 'continuous raster' on the vector layer

 

And that's all !

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

LATEST

Nice! 😂

I will try and look at that some time. 🤔

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines