• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Premiere Pro Transcription Not Identifying Separate Voices

Explorer ,
May 22, 2023 May 22, 2023

Copy link to clipboard

Copied

I've been using the auto-transcription tool a lot lately, and the update makes the interface look better but now the separate speakers are not being identified.I have "Show Speakers" selected and I also went through the extra step of clicking "Generate Static Transcript" under which you can select "Separate Speakers." The only speaker being shown in the generated transcript is "Unknown." If I change the name of this Speaker, it changes every line to that speaker.

 

 

Bug Unresolved
TOPICS
Editing and playback

Views

8.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 12, 2023 Jun 12, 2023

Hey, thanks for everyone's replies and sharing of similar issues! TLDR: I re-imported the clip and auto-transcribed and it worked. Maybe that will work for you too. And maybe it had something to do with needed to clear the cache, because no matter how many times I've tried hitting re-transcribe on the first instance of the clip in my project, it would not separate the speakers.

 

More details:

 

- I'm transcribing a clip, not a sequence. BUT, I had first tried putting only that clip into a sequence

...

Votes

Translate

Translate

correct answers 1 Pinned Reply

Adobe Employee , May 22, 2023 May 22, 2023

"Unknown" either means you had the setting to identify speakers disabled or the AI model can't clearly hear the speakers and tell them apart.  You should see "Speaker 1", "Speaker 2" etc.  Try re-transcribing your source clips.

  1.  Be sure you are in the Tect-based editing workspace - Window > Workspaces > Text-based editing
  2. Find the source clip in the project panel and load it into the source monitor by double clicking
  3.  In the text panel, make sure you are on the "Transcript" tab.  Choose "Re tra
...

Votes

Translate

Translate
24 Comments
Adobe Employee ,
May 22, 2023 May 22, 2023

Copy link to clipboard

Copied

"Unknown" either means you had the setting to identify speakers disabled or the AI model can't clearly hear the speakers and tell them apart.  You should see "Speaker 1", "Speaker 2" etc.  Try re-transcribing your source clips.

  1.  Be sure you are in the Tect-based editing workspace - Window > Workspaces > Text-based editing
  2. Find the source clip in the project panel and load it into the source monitor by double clicking
  3.  In the text panel, make sure you are on the "Transcript" tab.  Choose "Re transcribe" from the overflow menu (three dots)
  4.  Make sure to check the option to separate speakers
    Is the audio recording clear?  Are the different speakers clearly audible and have different-sounding voices?  Sometimes voices that sound similar get lumped together.  If all else fails, you can identify the speakers manually.

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

I'm getting the same issue.

 

According to Francis's reply, "Be sure you are in the Tect-based editing workspace - Window > Workspaces > Text-based editing"

 

Now, I'll do that, but not sure why it should make a differene.  If I activate the "text" window in general I feel like I should be able to do what I want within my customized workspace... but, we'll follow the directions and see what shakes out.

Votes

Translate

Translate

Report

Report
Community Expert ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

@gabbic0104 @Path 88 Productions 

 

I think @Francis-Crossman is just trying to make sure you will see what he expects. There is more than one way to get there.

 

If you see a dialogue that allows you to specify speakers, then it increases the chances that you problem is related to which track the dialogue is on or other issues (audio quality).

 

Screenshots might help.

 

Stan

 

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

In my particular instance right now:  Stereo track, studio recording of a 1.5 hour interview.  Interviewer and Interviewee on track 1 and track 2 respectively.  Took about 30 minutes to transcribe.  When finished both speakers (male & female) both showed up as "Unknown" and I was unable to change the speakers names.

 

Re-transcribed the same interview and it worked the second time.

 

Kind of an issue burning the extra 30 minutes to re-do stuff when/if it fails the first time.  Need a solid solution that makes sure Premiere is not going to get it wrong.  So, I'll follow Francis' advice and see if that paves the way to a consistent result.

 

I have 30 days of interviews to plow through....

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

Also, anyone getting fluxuating transcribe times?  Adobe touts 10x, but I'm around 5x, rough estimate overall, and sometimes more like 3x.  Is it dependant on system resources and will multi-tasking affect the times?

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

So this is a 90 minutes interview that took 30 minutes to transcribe.  It failed to seperate the voices even though "show speakers" is tick-boxed.

 

Screenshot 2023-05-24 at 1.09.28 PM.png

 

Screenshot 2023-05-24 at 1.12.11 PM.png

 

So...yeah, now I'll "re-transcribe" again.  As you can see, pretty time consuming when it fails.  Cool service, but I can't figure out how to get it consistent.

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

Don't know if this is a clue or not, but when I launch the Transcript function when the "show program monitor transcript" icon is activated, this is what I see...a selected AI Transcription is underway.  However, as you can also see, when the "show source monitor transcript" icon is activated, Premiere says "No Dialog Found".

 

So, this UI is a bit confusing to me.  Am I using it wrong?  I don't know.

 

Now, on the other hand, everytime I've attempted a re-transcription when the "Show Source Monitor Transcript" icon was activated and an actual clip was in that window, the transcription has worked.

 

Screenshot 2023-05-24 at 1.30.45 PM.png

 

Screenshot 2023-05-24 at 1.31.15 PM.png

 

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

Sepreating Speakers during a transcription seems to work when I launch the transcription from this window:

Screenshot 2023-05-24 at 2.24.54 PM.png

However, Seperating Speakers Seems to fail and give me the "Unknown" problem when I launch the transcription from this window:

Screenshot 2023-05-24 at 2.24.43 PM.png

I'll conclude by acknowledging that I'm running a system with two extra monitos, if that factors into the issue at all.

Premier Vers. 23.4.0 (Build 56) 3.5 GHz Quad-Core Intel Core i5, Radeon Pro 575 4 GB, 64 GB 2400 MHz DDR4

 

Works:

Screenshot 2023-05-24 at 3.07.27 PM.png

 

Doesn't work:

Screenshot 2023-05-24 at 3.08.09 PM.png

 

Votes

Translate

Translate

Report

Report
Participant ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
New Here ,
May 24, 2023 May 24, 2023

Copy link to clipboard

Copied

Dear Francis-Crossman, the updated transcription interface has new bells and whistles that make it more confusing, and I'm getting the same problem as the others. All my speakers are identified as "unknown" which didn't happen in the previous version on the same exact interviews.

 

In addition, when I try to re-transcribe, that menu item is gray-out and therefore unavailable.

 

When I select Source Monitor transcript, it successfully separates out the speakers, but I'm not sure how to deal with that when an interview has more than one clip. I believe there are several bugs in this new interface that need to be fixed.

Votes

Translate

Translate

Report

Report
Community Expert ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

@Path 88 Productions,

 

Thanks for the screenshots and especially the video. Very helpful.

 

This is a challenging workflow. It only takes a detail or 2 and you are quickly into the weeds. But it can just as quickly get back on track. While you get it sorted, work with short clips. I have noticed long transcribe times, but I am not working with material as long as yours.

 

Separating Speakers.

 

Sometimes, you have used the 3 dots menu to confirm that "Show speakers" is checked. This setting, however, only tells PR to show the speaker designations in the transcript window. It does NOT mean that speakers will be identified during transcription.

 

And then when you used the transcribe button in the "untranscribed sources" prompt, it did not have speakers set.

 

When you get the "Create source media transcription" dialogue, you get the actual "Separate speakers" option. And then it works.

 

I have not discovered exactly when it does not show the dialogue and whether it sometimes ignores the speaker separation if you set it in preferences.

 

In any event, check Edit -> Preferences -> Transcription and be sure you have speaker separation set there. If it shows "Select an option," it is not set. You can set it there by turning on "Automatically transcribe clips," setting speakers to "Yes, separate speakers," and then turning off "Automatically transcribe clips."

 

Editing Speakers.

 

If you have speaker separation on and manually or through the auto-transcribe create a transcript for a Source media file (i.e. a clip, whether in a sequence or not), you can edit speaker names as long as you are viewing the transcript in the Source Monitor view. If you are in the Program Monitor/timeline view, you do not have the 3 dots to the left of the speaker name and get a hover message "To edit speaker names, make changes in the Source transcript." Just double-click the clip (to open in the Source Monitor), and you can edit the speaker name in the transcript.

 

Also note that if you select the timeline/Program Monitor, and click the 3 dots in the Transcript tab, you can pick "Generate Static Transcript." This is the "old" style transcript. For this one, you can edit the speaker names when the timeline/Program Monitor is active.

 

No Dialogue Found.

 

> when the "show source monitor transcript" icon is activated, Premiere says "No Dialog Found".

 

This primarily happens any time you select Source Monitor view and there is no source open in that monitor. Or the source that is active doesn't have dialogue. Or it doesn't have it on the first audio track - Source Media transcription only looks at audio track one. For this purpose, "track 1" is your stereo track, not just one of the channels.

 

There is a workaround for the track 1/source issue.

 

Follow Active Monitor.

 

There are situations where you want to turn this off. But my preference so far is to leave it turned on. All this does is to set the view to whatever monitor you were in last. So, for example, if I want to edit speakers and I am in the timeline with a clip that has a source transcript, I am seeing the Program Monitor/timeline view of the transcript - and the speakers will not be editable. I just double-click on the clip, it opens in the Source Monitor, I switch to the Transcript tab - where Follow Active Monitor now shows the source view, and the speakers are editable.

 

Yes, a lot to unpack...

 

Stan

 

Votes

Translate

Translate

Report

Report
Community Expert ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

@jonskurprods,

 

My post to @Path 88 Productions may help with some of your questions.

 

Yes, multiple clip source transcriptions pose special challenges. See my post here:

https://community.adobe.com/t5/premiere-pro-discussions/ai-transcribe-for-multiple-tracks/m-p/138145...

 

Let us know what you come up with. Lots of directions to take this.

 

Stan

 

Votes

Translate

Translate

Report

Report
New Here ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

Hello I'm having the same issue.  Anything larger than 10GB can significantly slow down the system and consume memory. However, I believe in this concept by Adobe.  

Votes

Translate

Translate

Report

Report
Participant ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

Woa.  Thanks Stan.  That is alot.  I'll have to pour over that closely.  Seems a bit needlessly complicated, but as long as it functions reliably somehow at the end of the day...

Votes

Translate

Translate

Report

Report
Participant ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

FWIW, after all my posts here, I basically stepped back a version of Premiere and started using that.  Too much muck to deal with on the 23.3.0 version.  Anyone reading this in the future just realize that this itenteration of Premiere is a bit buggy on the transcripts.  Also the UI, but that's for another thread.

 

I do see why Adobe is implementing transcripts in this fashion, as it'll allow trascribed words to carry across multiple sequences when they are attached to a source rather than a timeline, but needs a touch of coding refinement before I rely on trascribing in this version of the app.

Votes

Translate

Translate

Report

Report
Participant ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

A big issue I have is that I'm working with off-board .wav audio recordings that go uninterrupted for hours.  Like, 4 hours each.  Unfortunately, the actual part I want trascribed might only be 15 minutes. 

 

Ideally, I'd slap that huge audio source in a sequence, edit out the parts I don't want, and allow Premiere to only look there and ignore the rest. 

 

However, it looks like they way they're implementing the newer features of transcribe, is that it'll analyze the whole source clip...and the best way you can get 'Identify Speakers' to work is to tell Premiere to analyze a source clip.

 

Is your expereience jibe'ing with my analysis?

Votes

Translate

Translate

Report

Report
Community Expert ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

@Path 88 Productions,

 

See this staff post in the Beta forum:

https://community.adobe.com/t5/premiere-pro-beta-bugs/text-based-editing-doesn-t-work-with-multiple-...

 

You can open your wav in the Source monitor, mark in/out, add to a sequence (with or without video), and do a static transcription of that sequence. Then use a nest of that sequence where you want that audio/transcript.

 

Let us know if this works for you.

 

Stan

 

Edit: I meant to add. Yes, you can transcribe an audio-only file. And when you add audio (nested or not), the transcript follows it. And Nico's comment about using a static transcript: I thought they were different creatures - source media transcript for clips and editing and static transcript for sequence and captions. But if you use a sequence as a nest, its static transcript becomes editable.

 

 

Votes

Translate

Translate

Report

Report
Participant ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

Thanks for the advice.  I will try to experiement and see what happens.  I'm bouncing between versions of Premiere depending on what I need to do.

I tried right clicking a few source files in my project window, and then asking for them to be transcribed.  Interestingly, my source files typically have 6 tracks and all six tracks show up in the progress window.  That tells me it's analyzing all six tracks one at a time.  That's a shame.  Track1 of the file is the "mix" and it would be nice if Premiere only looked there to transcribe.

 

Do you know if there's a way to do that?

 

After all, having to wait as long as a day for 1 of audio is not very productive.

 

Screenshot 2023-05-26 at 1.37.46 PM.png

 

Votes

Translate

Translate

Report

Report
Participant ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

quote

check Edit -> Preferences -> Transcription and be sure you have speaker separation set there. If it shows "Select an option," it is not set. You can set it there by turning on "Automatically transcribe clips," setting speakers to "Yes, separate speakers," and then turning off "Automatically transcribe clips."

 

This solution might be what other's need to make transcribe work as requested in the OP?

Votes

Translate

Translate

Report

Report
Community Expert ,
May 27, 2023 May 27, 2023

Copy link to clipboard

Copied

>

check Edit -> Preferences -> Transcription and be sure you have speaker separation set there. If it shows "Select an option," it is not set. You can set it there by turning on "Automatically transcribe clips," setting speakers to "Yes, separate speakers," and then turning off "Automatically transcribe clips."

 

> This solution might be what other's need to make transcribe work as requested in the OP?

Yes, I think of the several ways to deal with it, that one is key.

 

Stan

 

 

Votes

Translate

Translate

Report

Report
Community Expert ,
May 27, 2023 May 27, 2023

Copy link to clipboard

Copied

@Path 88 Productions 

 

Great detective work. It is my belief that such transcribes will only use track 1. But I just tested a dual track file and it was processing two tracks.  The workaround is to nest as described - when doing so, you can pick audio 1 or mix. I just tested, and the static transcription of the dual track sequence showed only one row in the progress panel.

 

But I'd like some staff input to guide you:

@Francis-Crossman @nbechere @Kevin-Monahan Who best to address this?

 

Stan

 

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 09, 2023 Jun 09, 2023

Copy link to clipboard

Copied

I have been having a similar issue with transcribing source clips from the Program Monitor Transcript view: speakers were not separated but rather all labeled as chunks of undifferentiated "Unknown." I tried the route of going to Settings/Transcription, turning on "Automatically transcribe clips," selecting "Speaker Labeling: Yes, separate speakers," then turning "Autmatically transcribe clips" back off, but that didn't seem to help.

 

In case it's useful to anyone else, here's what has so far been working for my particular situation: I am working with two scenarios: 1) two cameras + separate audio and 2) one camera + separate audio. All source files have time-of-day timecode. What has worked for both situations is to create Multi-Camera Source Sequences, create static transcripts inside those sequences, and then edit those multi-cam sequences into my main timelines. So far, even working with multiple multi-cam sequences in one timeline, all transcripts show up correctly.

 

My workflow:

1) Select a group of related video and audio-only clips in the Project panel, right-click and choose "Create Multi-Camera Source Sequence..."

2) I choose "Synchronize Point: Timecode / Track Assignments: None" (which discards the video files' audio tracks and only keeps the separate audio, but that works for me in this situation); and choose "Audio: Sequence Settings: All Cameras," "Audio Channels Preset: Mono"; and "Camera Names: Use Clip Names."

3) Right click the that multi-cam sequence in the Project panel and choose "Open in Timeline."

4) Go to the Text panel and choose "Generate static transcript," which lets me choose to separate speakers and choose which audio track to use, which is important for situations where I have multiple people on separate mics, each on their own track: I choose Track 1, which is one of the in-the-field mixed tracks from my sound operator. (It sounds like Premiere will default to Track 1, but I don't want to risk it mixing all those separate lavalier tracks together.)

5) Wait for the auto transcription to complete. Question all my life choices.

6) Edit that transcribed multi-cam sequence into my main sequences/timelines.

 

I've actually found the separate speakers function to be a bit too aggressive in some situations, in one case separating one person's interview into multiple speakers in the transcript, sometimes word by word — I'm guessing because she often had long pauses in her sentences.

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

Hey, thanks for everyone's replies and sharing of similar issues! TLDR: I re-imported the clip and auto-transcribed and it worked. Maybe that will work for you too. And maybe it had something to do with needed to clear the cache, because no matter how many times I've tried hitting re-transcribe on the first instance of the clip in my project, it would not separate the speakers.

 

More details:

 

- I'm transcribing a clip, not a sequence. BUT, I had first tried putting only that clip into a sequence and transcribing the sequence, so maybe that duplicate use of the clip made something weird happen? 

 

-Also, the first time I tried transcribing the clip, I was also having five other clips transcribed at the same time. Maybe something with memory/RAM disallowed the separating of speakers?

 

Clip details:

This is a 1 video/audio track clip. It's around an hour long and recorded over Zoom, so the audio quality isn't the best. However, I've auto-transcribed around 20 other Zoom videos of the same length through Premiere without an issue (before Version 23.4).  I always ensure "Identify Speakers" is enabled and the speakers in the clip that is giving me trouble have very distinct voices, so the program should have been able to tell them apart. In the past, even with two similar female voices, the transcription software in Premiere was able to distinguish between the two.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 19, 2023 Oct 19, 2023

Copy link to clipboard

Copied

LATEST

Late to this thread. I've been having the same issue... 

 

In settings --> transcription, under "automatic transcription" you can select "yes, separate speakers." This option seems to be turned off by default in the newest version of Permiere. You may have to check "automatic transcription" to un-gray the below area, but you can turn this automatic transcription option off afterwards if you'd like.  

Votes

Translate

Translate

Report

Report